1. GiuA's Avatar
    I performed this morning this morning a speed test (speediest.net both website and sideloaded android app) and my results under 4G is always around 4/5 Mbps D/U.
    I found this results a bit disappointing and i called Swisscom hotline.
    I have a Z10 0.99 STL 100-2 bought in UK with a Swisscom sim card with no limit data plan.
    Their answer was that, considering that i bought the Z10 in UK, here in switzerland they don't use the same frequencies for 4G/LTE...
    I don't want to be "pedantic" but i suppose that if this is true, i can't even see the 4G icon on the smartphone.
    So please give me your advice about this issue, thanks in advance.
    G
    04-25-13 10:23 AM
  2. GiuA's Avatar
    Maybe posting threads like "Waiting for Shazam" or "I throw my z10 out of the Window' I'll be more popular and get a lot of answers..

    Posted via CB10
    Omnitech likes this.
    04-26-13 02:32 AM
  3. kidmac13's Avatar
    Maybe no one knows. I'll say this, I bought my Bold 9900 from Optus in Australia while being with Telstra in Australia.
    At the start my reception was always cool, but Telstra changed the towers after about 6 months(to move forward towards 4g) and my reception suffered horribly. I went to the main store(that I used to work at) and spoke with the Techies and they confirmed that different companies sometimes use difference network frequencies and if your phone isn't made for that one, you won't get that higher reception, if any at all.

    I get that that's not exactly the news you want, but I hope it helped you to decide your next move.

    Sent from Amber via CB10.
    04-26-13 03:39 AM
  4. jrohland's Avatar
    4G and LTE are not always the same thing. If you don't see LTE under Settings, Network Connections, Mobile Network then you don't have LTE. The carrier could be correct. Your UK fone could do 4G but not LTE on that carriers network.

    I see the same thing. My phone is from a Canadian carrier but I'm using it in the states. On one carrier (T-Mobile) I get LTE. On another carrier (AT&T) I get 4G. My friends phone is just the opposite. She gets LTE on AT&T but not on T-Mobile.

    I've tested Speedtest.net under every combination with both phones. I see higher speeds and lower latency on LTE.

    Posted via CB10
    04-26-13 03:48 AM
  5. Vector-SS's Avatar
    According to SwissCom they use 800/1800/2600 LTE frequencies.

    The UK BlackBerry Z10 supports 800/900/1800/2600 so the people you spoke to had no idea what they're talking about

    Do you see an LTE or 4G choice under your network selection? If yes, once you select it, leave the settings, and then come back do you notice that it deselected itself and it went back to 3G?

    Few possible issues:

    A) It is an STL100-1 model

    B) You're simply not finding LTE coverage

    C) See the questions above - us Middle East customers who bought an STL100-2 model cannot hook onto an LTE network even though our phone supports it and we can see it in the optiobs. It seems that BlackBerry needs to update something on their end for it work.



    Posted via CB10
    04-26-13 01:30 PM
  6. GiuA's Avatar
    Hi thank you all for the answers.
    Under network i have 4G, 3G and 2G, and normally I'm under 4G, it never displays LTE, i checked is a 102.
    Under 4G i got always max 6 mbps download.


    Posted via CB10
    04-27-13 12:05 PM
  7. SDTRMG's Avatar
    Hi thank you all for the answers.
    Under network i have 4G, 3G and 2G, and normally I'm under 4G, it never displays LTE, i checked is a 102.
    Under 4G i got always max 6 mbps download.


    Posted via CB10
    On my phone there is a separate setting for LTE, 4g, 3G etc. I can use 4g on Rogers Canada but they don't support lte yet so I have it switched off and 4g on.
    04-27-13 01:10 PM

Similar Threads

  1. Post your 4G LTE speeds
    By MartyMcfly in forum Apple iPhone/iPad
    Replies: 1
    Last Post: 09-24-12, 09:19 PM
  2. PB LTE speed test result
    By GeneralHerzog in forum BlackBerry PlayBook
    Replies: 9
    Last Post: 09-08-12, 05:47 PM
  3. 4G/3G Speed Test Link - Test your speed
    By Cilke in forum BlackBerry Bold Series
    Replies: 16
    Last Post: 10-08-11, 03:06 AM
  4. AT&T "4G" Mobile Speed Test
    By mrmcbizzie in forum General Carrier Discussion
    Replies: 9
    Last Post: 09-30-11, 02:39 PM
  5. Replies: 35
    Last Post: 09-04-09, 01:48 PM
LINK TO POST COPIED TO CLIPBOARD