12-19-13 10:24 PM
34 12
tools
  1. Rex_kwon_do's Avatar
    After 45 minutes with Vodaphone CS, another hour with 3 CS, and over an hour with BlackBerry CS in Canada, I still cannot get data working on my Z even though I can get phone calls and text messages. I will try to make this quick:
    I am on Verizon and wanted to use my Z in the UK. I have no problem using data in the US. My first day in the UK I went to Vodaphone to buy a prepaid SIM. We activated it, but we could not get data to work. Thinking maybe there was an incompatibility, I went to 3. They have an unlimited data plan, and data is more important to me than UK phone and text. The 3 SIM would not get me data either. This made me think the problem was not the SIM. We swapped SIMs from the 3 CS rep's phone into mine, and mine into his. His SIM did not get me a data connection, but my SIM worked fine in his phone. This sounded like it might be a phone issue. The BBRY CS I spoke to was horrible and kept asking me if I had turned my network connection on and then tried blaming the SIM cards. Every time I asked to get connected to another CS rep, I was denied. Yes, we went around in circles for an hour.

    Interestingly enough, my Verizon SIM works with roaming on in the UK, but their international data plan is ridiculous, so I am not going that route. I have already tried a security wipe, but that didn't seem to help either. Of course 3 won't let me return the SIM, which is very frustrating. Here are some screen shots that might help.

    Unlocked Verizon Z10 Data in UK-img_00000227.jpg
    Unlocked Verizon Z10 Data in UK-img_00000228.jpg
    Unlocked Verizon Z10 Data in UK-img_00000229.jpg
    Unlocked Verizon Z10 Data in UK-img_00000230.jpg
    Unlocked Verizon Z10 Data in UK-img_00000231.jpg
    Unlocked Verizon Z10 Data in UK-img_00000232.jpg
    Unlocked Verizon Z10 Data in UK-img_00000233.jpg
    Unlocked Verizon Z10 Data in UK-img_00000234.jpg
    Unlocked Verizon Z10 Data in UK-img_00000236.jpg
    07-14-13 10:42 AM
  2. Lendo's Avatar
    That's a bummer. If the phone is unlocked, it should work with that network. Another Verizon mystery.
    07-14-13 10:51 AM
  3. Rex_kwon_do's Avatar
    That's a bummer. If the phone is unlocked, it should work with that network. Another Verizon mystery.
    Thanks. That's not quite what I had wanted to hear, but at this point it sounds like that might explain the inexplicable.
    07-14-13 10:54 AM
  4. peter0328's Avatar
    You are on a leaked OS maybe try rolling back to stock.

    Posted via CB10
    07-14-13 11:01 AM
  5. Lendo's Avatar
    So you tried 2 SIM from 2 companies? They're not related companies?
    07-14-13 11:04 AM
  6. Rex_kwon_do's Avatar
    So you tried 2 SIM from 2 companies? They're not related companies?
    Nope, completely unrelated companies.
    07-14-13 11:13 AM
  7. Rex_kwon_do's Avatar
    You are on a leaked OS maybe try rolling back to stock.

    Posted via CB10
    I guess that will be my next option. I am backing up now.
    07-14-13 11:14 AM
  8. Lendo's Avatar
    I'd go forward, not back try 10.2.0.483
    07-14-13 11:15 AM
  9. ediggity's Avatar
    I guess that will be my next option. I am backing up now.
    Please let us know the outcome. Currently I'm using my Z only with wifi, but have considered adding data to my T-Mobile sim here in Hungary.

    Posted via CeeBee 10 on that Whiteberry
    07-14-13 11:17 AM
  10. Rex_kwon_do's Avatar
    I'd go forward, not back try 10.2.0.483
    I am more than willing to do that if you are serious and think it would help. The reason I didn't jump on the 10.2 leaks is that I worried about their compatibility with my SIM. My 10.1 has been pretty stable.

    Please let us know the outcome. Currently I'm using my Z only with wifi, but have considered adding data to my T-Mobile sim here in Hungary.
    Posted via CeeBee 10 on that Whiteberry
    My Verizon SIM works just fine, but they want $30 for 250 megs of data. I can't speak for T-mo, but as long as the price is right, I don't see why you couldn't use data, but you might want to see what a local SIM would cost (if it works!)
    07-14-13 11:22 AM
  11. Lendo's Avatar
    I'm not real sure that the OS would have anything to do with it. Some problems are specific to carriers. This may be one of them. You could always try 10.1.0.4543 first.
    07-14-13 11:25 AM
  12. ediggity's Avatar
    My Verizon SIM works just fine, but they want $30 for 250 megs of data. I can't speak for T-mo, but as long as the price is right, I don't see why you couldn't use data, but you might want to see what a local SIM would cost (if it works!)
    I already have a local sim T-Mobile here through the company I work for, but I haven't added data to it. Looks like it's a good idea so far because of what is going on with you. If the 1004 model doesn't work properly overseas I'll be extremely pissed.

    I'll try my coworkers sim tomorrow to confirm if you are still having trouble as well.

    Posted via CeeBee 10 on that Whiteberry
    07-14-13 11:35 AM
  13. b4ulaf's Avatar
    I'm not real sure that the OS would have anything to do with it. Some problems are specific to carriers. This may be one of them. You could always try 10.1.0.4543 first.
    I'm on Verizon in the US and. 4543 has been the best OS by far for me. I can't speak of international use on this version though.

    Posted via CB10
    07-14-13 04:59 PM
  14. Rex_kwon_do's Avatar
    Are there any Verizon Z10 users who have successfully used data with another SIM? I will be in Spain in a few months, and I need to know if this is a phone, OS, or Verizon issue.
    07-16-13 02:14 AM
  15. patel26's Avatar
    Wouldn't the z10 variants come Into play? Here in the UK we have stl100-02 I'm not sure about u guys in the US.

    My guess is there could be some incompatibility with the radios maybe? Just a suggestion!

    Posted via CB10
    07-16-13 02:48 AM
  16. Rex_kwon_do's Avatar
    Wouldn't the z10 variants come Into play? Here in the UK we have stl100-02 I'm not sure about u guys in the US.

    My guess is there could be some incompatibility with the radios maybe? Just a suggestion!

    Posted via CB10
    Verizon is stl100-04. My wife will be here with her Z on stock Verizon OS, so I can test that with my SIM.
    07-16-13 08:00 AM
  17. Rex_kwon_do's Avatar
    Success! I just loaded B@stard_10.1_4561-4544_Z_2-3-4 (20130713) and got my SIM to work. Now I am just restoring. As long as the restore comes through without a hitch (knock on wood), I am thrilled. Conspiracy theory over!

    UPDATE: Restore worked flawlessly. Rockin' it out!
    Last edited by Rex_kwon_do; 07-16-13 at 10:07 AM.
    07-16-13 08:55 AM
  18. fazl3h's Avatar
    Hi Rex i'm having exactly the same problem as you. What did you do to get round this problem. I would be extremely grateful if you could explain what you did to resolve this issue. I've tried different Sims from different service providers but have not been able to get data.
    09-11-13 07:51 PM
  19. guygardner73's Avatar
    Hi Rex i'm having exactly the same problem as you. What did you do to get round this problem. I would be extremely grateful if you could explain what you did to resolve this issue. I've tried different Sims from different service providers but have not been able to get data.
    I've just read this thread and I'm surprised nobody stepped in and settled this immediately. The Verizon Z10's are CDMA, not GSM like the others so they will not work in the UK. The best advice I can give you is to trot into Carphone Warehouse and buy a sim free STL100-2 for 230 pounds and bung any sim in it. You can then sell it when you're done with it. Or you could just pick up a cheap Android phone for 80 pounds, that'll do the job for a couple of weeks.

    Z10STL100-2/10.1.0.4780 O2 Uk
    09-12-13 12:28 AM
  20. guygardner73's Avatar
    Maybe the cheapest option for you would be to ask Verizon if they can cut you a deal on the roaming charges.

    Z10STL100-2/10.1.0.4780 O2 Uk
    09-12-13 12:29 AM
  21. guygardner73's Avatar
    I've checked and if you can use your phone in the UK, it would only be on the EE network on 4G. It's possible this may not work, but that is the only possible solution for using a UK sim. The other networks won't get you data for sure. In fact, I'm surprised the OP could get calls and texts. Another option would be to ask in any of the network stores (O2, EE, Vodafone, Orange) or even Carphone Warehouse if you could buy a pay as you go Sim and borrow a phone and leave yours as a deposit. I have heard of them doing that if they have an available handset kicking around.

    Z10STL100-2/10.1.0.4780 O2 Uk
    09-12-13 12:57 AM
  22. fazl3h's Avatar
    I've tried a 3 sim, Virgin, O2, EE nothing works, only thing that did work was Rex's idea of loading B@stard_10.1_4561-4544_Z_2-3-4 (20130713). But now I'm having trouble restoring my data via BB Link. But that's not a major problem since I backed things up and I don't have many things on the phone. Atleast now it works, thanks Rex for the solution mate.
    09-12-13 07:25 AM
  23. ediggity's Avatar
    I've just read this thread and I'm surprised nobody stepped in and settled this immediately. The Verizon Z10's are CDMA, not GSM like the others so they will not work in the UK. The best advice I can give you is to trot into Carphone Warehouse and buy a sim free STL100-2 for 230 pounds and bung any sim in it. You can then sell it when you're done with it. Or you could just pick up a cheap Android phone for 80 pounds, that'll do the job for a couple of weeks.

    Z10STL100-2/10.1.0.4780 O2 Uk
    You do realize that the 1004 version from Verizon comes unlocked with GSM bands? Data should work perfectly so your post makes no sense. When I bought my storm 2 used, it was unlocked and haven't had a problem with it here in Hungary. Luckily I'm going home tomorrow so I will upgrade my OS as I'm using a Mac out here.

    Posted via CeeBee 10 on that Whiteberry
    09-12-13 11:09 AM
  24. guygardner73's Avatar
    You do realize that the 1004 version from Verizon comes unlocked with GSM bands? Data should work perfectly so your post makes no sense. When I bought my storm 2 used, it was unlocked and haven't had a problem with it here in Hungary. Luckily I'm going home tomorrow so I will upgrade my OS as I'm using a Mac out here.

    Posted via CeeBee 10 on that Whiteberry
    No sir, I did not realise that the STL100-4 could also use GSM. I was under the impression that it was CDMA only. My apologies for the inaccuracy.

    Z10STL100-2/10.1.0.4780 O2 Uk
    09-12-13 11:45 AM
  25. fazl3h's Avatar
    Ok new problem, can't seem to get 4G on it now. Is the 100-4 capable of getting 4G. I popped in a 4G EE sim but only got H. Could this be a hardware issue?
    09-12-13 11:51 AM
34 12

Similar Threads

  1. CrackBerry's "Switch to BB10 in a 140 Characters" Contest!
    By CrackBerry Kevin in forum CrackBerry.com News Discussion & Contests
    Replies: 301
    Last Post: 03-23-14, 01:27 PM
  2. How don't i uninstall a leak on my z10
    By harryhayde in forum BlackBerry 10 OS
    Replies: 22
    Last Post: 07-17-13, 10:23 PM
  3. Replies: 4
    Last Post: 07-14-13, 10:43 AM
  4. Minimum Wage UK?
    By TiagoPD in forum Rehab & Off-Topic Lounge
    Replies: 3
    Last Post: 07-14-13, 10:04 AM
  5. BlackBerry Z10 prices come crashing down to $49, how long till their free?
    By ItsMrMark in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 07-14-13, 09:27 AM
LINK TO POST COPIED TO CLIPBOARD