12-26-13 09:07 AM
75 123
tools
  1. scrannel's Avatar
    So sad that most of the answers went in a wrong direction. Please accept that Z10 wifi receiver is so special, sometimes you have to change the settings in your Router. I had issues with FtitzBox in connecting wifi, when I shifted to a new apartment (now please don't tell me that I don't know the wifi world), and solved problem by changing Router setting, which affected my flat mates, because they had to change their settings in their devices too but now they like my Z10).
    When you are visiting somewhere, you cannot request your host to change settings in his Router. He will think you are crazy, because you are the first one who is complaining or may be the second BlackBerry user.
    I know we BlackBerry have problem. Not the whole world. That's why I just give up trying connecting wifi if it doesn't connect after 3 times.
    BUT I am happy with my Z10!

    Z10STL100-2/10.1.0.4633 Germany
    Nothing personal but... what? So far I've never had any trouble connecting to any wifi.
    08-27-13 06:44 PM
  2. Bs06TL's Avatar
    Have you guys tried desktop
    mode?

    Posted via CB10
    08-27-13 06:51 PM
  3. mitchy_mitch's Avatar
    I believe it's the hotel router's fault. Their router software is not up to date and doesn't stand up to BlackBerry's security protocol

    Posted via CB10
    08-27-13 08:33 PM
  4. djenkins6's Avatar
    I believe it's the hotel router's fault. Their router software is not up to date and doesn't stand up to BlackBerry's security protocol

    Posted via CB10
    But it will work perfectly one day for both z10 and nexus 7, and the next day it will work perfectly with one device but not the other, or sometimes neither will work without some resets.

    Sent from my Nexus 7 using CB Forums mobile app
    08-27-13 08:52 PM
  5. cyberjunkie1's Avatar
    I've had this issue happen to me to. I think this is truly a bug. If you turn off all radios except wifi the login page comes up and am able to connect. Otherwise it's a no go.

    Posted via CB10
    awindsr likes this.
    08-27-13 09:39 PM
  6. RR10's Avatar
    Nothing personal but... what? So far I've never had any trouble connecting to any wifi.
    No worries! Lucky you

    Z10STL100-2/10.1.0.4633 Germany
    08-28-13 01:02 AM
  7. Thunderbuck's Avatar
    But it will work perfectly one day for both z10 and nexus 7, and the next day it will work perfectly with one device but not the other, or sometimes neither will work without some resets.

    Sent from my Nexus 7 using CB Forums mobile app
    Okay, but you understand that this is a pretty clear indication that the hotel's setup is hinky...
    08-28-13 01:09 AM
  8. DetlevCM's Avatar
    When I went to Poland back in June, I used my Z10 on the hotel's WiFi (offered by T-Mobile) without issues.

    That's was on a 10.1 OS leak.
    I have used my Z10 on the trains WiFi in the UK as well, though not regularly because I can't be bothered to type the login details in.

    I would suspect it is a matter of the specific setup rather than a Z10 issue.

    Posted via CB10
    08-28-13 02:32 AM
  9. Gambit_DE's Avatar
    I've had this issue happen to me to. I think this is truly a bug. If you turn off all radios except wifi the login page comes up and am able to connect. Otherwise it's a no go.

    Posted via CB10
    This^

    It's not a bug, it's a feature. For real. My windows 8 does the same when I got WLAN and UMTS card active.
    Z10 decides to route your traffic through all ways that have Internet access. When you have the login page, there is currently no Internet access which is why the Z goes through Cell(where the address of the login page can not be found)

    Both updating the router and using the workaround with turning off cell will solve this for you.

    Have fun with it

    Posted via CB10
    mikecosmo likes this.
    08-28-13 02:55 AM
  10. cyberjunkie1's Avatar
    This^

    It's not a bug, it's a feature. For real. My windows 8 does the same when I got WLAN and UMTS card active.
    Z10 decides to route your traffic through all ways that have Internet access. When you have the login page, there is currently no Internet access which is why the Z goes through Cell(where the address of the login page can not be found)

    Both updating the router and using the workaround with turning off cell will solve this for you.

    Have fun with it

    Posted via CB10
    I don't know how one would update every hotspot router in public areas. This is not a feature and if it is then it isn't working properly. Public hot spots doesn't even pop up when it is detected even though the setting has been enabled. It only pops up if it detects a hotspot that has previously been saved. Even when it does pop-up for a previously saved connection, it doesn't connect because it doesn't properly hand off the connection and therefor not connecting to the hotspot's login page. Been like this since day 1 and even after putting 10.2.1047 leak.

    Posted via CB10
    kbz1960 likes this.
    08-28-13 05:58 AM
  11. anon(5624621)'s Avatar
    I had this issue at the Halifax airport trying to use their free wifi. My playbook worked fine.

    Posted via CB10
    08-28-13 06:09 AM
  12. mkelley65's Avatar
    I had this issue at the Halifax airport trying to use their free wifi. My playbook worked fine.

    Posted via CB10
    That's because your PlayBook does not have a cell radio. The simple solution to this is to turn off the cellular radio, connect to the hotspot, then turn the radio back on. The Z10 sends traffic on the open interface.
    anon(5624621) likes this.
    08-28-13 06:22 AM
  13. anon(5624621)'s Avatar
    That's because your PlayBook does not have a cell radio. The simple solution to this is to turn off the cellular radio, connect to the hotspot, then turn the radio back on. The Z10 sends traffic on the open interface.
    I'll have to try that next time, thanks.

    Posted via CB10
    08-28-13 06:32 AM
  14. Gambit_DE's Avatar
    It's not meant to be a bug. In general the underlying features improves your online time by switching off the route to a (seemingly) dead hotspot. And the hot spot acts offline. So, technically the Z works as expected.
    However this could be fixed by BlackBerry AND the hotspot provider.

    Posted via CB10
    08-28-13 07:20 AM
  15. kbz1960's Avatar
    This^

    It's not a bug, it's a feature. For real. My windows 8 does the same when I got WLAN and UMTS card active.
    Z10 decides to route your traffic through all ways that have Internet access. When you have the login page, there is currently no Internet access which is why the Z goes through Cell(where the address of the login page can not be found)

    Both updating the router and using the workaround with turning off cell will solve this for you.

    Have fun with it

    Posted via CB10
    It's a feature? Who would ask for a feature that makes your phone use cell data when you want to use wifi data? So even if it's on wifi the feature will use cell data if it chooses?
    08-28-13 07:36 AM
  16. Gambit_DE's Avatar
    It's a feature? Who would ask for a feature that makes your phone use cell data when you want to use wifi data? So even if it's on wifi the feature will use cell data if it chooses?
    I've answered your question in the post before. It only chooses cell because the hotspot "acts" as if it was offline

    Posted via CB10
    08-28-13 07:58 AM
  17. cyberjunkie1's Avatar
    I've answered your question in the post before. It only chooses cell because the hotspot "acts" as if it was offline

    Posted via CB10
    Shouldn't all other mobile users get the same result if it were the case ? Again, I still believe that this is a bug.


    Posted via CB10
    08-28-13 08:02 AM
  18. kbz1960's Avatar
    I've answered your question in the post before. It only chooses cell because the hotspot "acts" as if it was offline

    Posted via CB10
    So why is the hotspot acting like it's offline? Because the bug makes it that way or the hotspot sees a bbry and says I'm going to appear offline because that device doesn't want to acknowledge me?
    08-28-13 08:09 AM
  19. Gambit_DE's Avatar
    My win8 Notebook does exactly the same.
    A) other devices have fixed it
    B) they deal differently with failing wifi, like iPhone does. When my home wifi fails, the iPhone takes minutes until it switches wifi off...
    So you can call it a bug if you like.

    I find the iPhone way annoying because I prefer being online than having wifi


    Posted via CB10
    08-28-13 08:09 AM
  20. kbz1960's Avatar
    My win8 Notebook does exactly the same.
    A) other devices have fixed it
    B) they deal differently with failing wifi, like iPhone does. When my home wifi fails, the iPhone takes minutes until it switches wifi off...
    So you can call it a bug if you like.

    I find the iPhone way annoying because I prefer being online than having wifi


    Posted via CB10
    But your iPhone will connect unlike the bbry?
    08-28-13 08:12 AM
  21. kbz1960's Avatar
    Posted before reading your edit.

    Do you have an unlimited plan? You prefer using cell data than wifi data which doesn't use up your cell data?
    08-28-13 08:14 AM
  22. Gambit_DE's Avatar
    The iPhone stays connected to all useless wifi for minutes. I don't like it that way but for you it would be helpful.

    We have different data plans in Germany. We are never switched off, but only slowed down. So, for me the iPhone thing is annoying

    Posted via CB10
    08-28-13 08:15 AM
  23. sklotz2000's Avatar
    I have the same issue when I travel outside the country.
    Try turning Airplane mode ON then OFF again. Not sure why, but toggling all of the radios OFF and ON seems to be the answer.
    I often do the same with my PlayBook when it has connectivity issues.
    08-28-13 08:17 AM
  24. scrannel's Avatar
    So why is the hotspot acting like it's offline? Because the bug makes it that way or the hotspot sees a bbry and says I'm going to appear offline because that device doesn't want to acknowledge me?
    Because the hotspot is off-line... depending how your device "sees" it. I've had a similar issue with an Android device when traveling and got it to work by switching to an "after market" browser. Which is why I asked if anyone here had tried that route. Like "Simple Browser", which is free.
    08-28-13 11:18 AM
  25. glamrlama's Avatar
    How many devices do you currently have connected under that one password and login? From my experience, hotels often times only allow 2-3 actual connections using any given password and then the rest just get booted off.

    They also tend to use repeaters to boost signal, in which case go into Settings, WiFi, Advanced, Saved networks and find the hotel connection. Under the advanced settings, enable the box that says "Inter-Access point Handover" as it will allow the device to transfer between the WiFi spots easier.
    I have been in a few locations that require the "Inter-Access point Handover" be enabled as well. Usually connects to most sites very easily and painlessly but the situation described here with the login requirement can usually be solved by enabling the hand over and proceeding as normal.
    08-28-13 02:31 PM
75 123

Similar Threads

  1. Bold 9650 best way to transfer to Q10
    By dpoverlord in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 09-04-13, 02:53 AM
  2. STL100-1 seems to be bad
    By AJMR2498 in forum BlackBerry Z10
    Replies: 13
    Last Post: 08-28-13, 06:06 PM
  3. Verizon Mobile Hot spot? How to setup
    By dpoverlord in forum General Carrier Discussion
    Replies: 15
    Last Post: 08-28-13, 03:25 PM
  4. Nice to have BBs! Apple Allows Police to Shut Down Camera/Video on iPhones
    By BB_BxNyc in forum General BlackBerry News, Discussion & Rumors
    Replies: 20
    Last Post: 08-28-13, 12:24 PM
LINK TO POST COPIED TO CLIPBOARD