1. adampageuk's Avatar
    After nearly 9 months of having a z10, my battery usage had remained pretty stable, off the charger at 6 am, back on at 10pm, with about 30% remaining.

    I'm on the 10.2.0.1725 leak, have wifi on, bluetooth and Nfc off, brightness around 30%, allow screen gestures on, location services on, diagnostics off, dev mode off, BlackBerry Link off. I have twitter, Facebook, hotmail, outlook.com, and a work exchange account set up, with the outlook.com account set to not sync email.

    All of these have been like this for a while and like I say, he battery drain has been fine. Until yesterday...

    Suddenly I'm draining a full battery in 4 to 5 hours with it idle. Using it... It's dropping by 10% a minute.

    I've just bought battery guru to see what the levels are like, but beyond deleting recent app upgrades/purchases (say it, Facebook, iunarchiver, badpiggies, bam comic reader) in case they are duff, I'm clueless.

    I've had to do a few battery pulls recently: on Saturday, location services got stuck on despite no apps using it, on sunday morning just after midnight, we had a power cut and the phone lost all signal, on sunday afternoon, again location services got stuck on.

    Any ideas?

    Posted via CB10
    10-20-13 11:54 PM
  2. adampageuk's Avatar
    More info: it's an stl100-2, orange/ee network in the UK, set for 2g/3g (the lte signal cuts off about 2 miles up the road, so no need to have it on)

    Posted via CB10
    10-20-13 11:57 PM
  3. mnc76's Avatar
    After nearly 9 months of having a z10, my battery usage had remained pretty stable, off the charger at 6 am, back on at 10pm, with about 30% remaining.

    I'm on the 10.2.0.1725 leak, have wifi on, bluetooth and Nfc off, brightness around 30%, allow screen gestures on, location services on, diagnostics off, dev mode off, BlackBerry Link off. I have twitter, Facebook, hotmail, outlook.com, and a work exchange account set up, with the outlook.com account set to not sync email.

    All of these have been like this for a while and like I say, he battery drain has been fine. Until yesterday...

    Suddenly I'm draining a full battery in 4 to 5 hours with it idle. Using it... It's dropping by 10% a minute.

    I've just bought battery guru to see what the levels are like, but beyond deleting recent app upgrades/purchases (say it, Facebook, iunarchiver, badpiggies, bam comic reader) in case they are duff, I'm clueless.

    I've had to do a few battery pulls recently: on Saturday, location services got stuck on despite no apps using it, on sunday morning just after midnight, we had a power cut and the phone lost all signal, on sunday afternoon, again location services got stuck on.

    Any ideas?

    Posted via CB10
    10 percent per MINUTE??? That is totally totally insane... I would imagine that your battery must be damaged or dead. Even a heavy game with intense graphics (like Real Racing) can't do that. I don't think software alone could do that IMO.

    If you know anyone else with a Z10, try your battery in their phone, or try a spare or someone else's battery in yours to check.

    I support BB10, NOT BB Management!
    10-21-13 01:18 AM
  4. mnc76's Avatar
    Accidental double post
    10-21-13 01:20 AM
  5. Gatmyer's Avatar
    A few times my Z has had an unexpected 0.5 w drain while idle according to battery guru. A restart fixed it is this what's happening to you? 10% per minute seems extreme.

    Posted via CB10
    10-21-13 02:32 AM
  6. adampageuk's Avatar
    Insane battery drain continued all off yesterday, and I charged and drained the phone 4 or 5 times yesterday, resulting in me putting it onto charge at 10pm at 6% remaining.
    2 hours later, both Hub++ and BatteryGuru were reporting 16%, which just seemed stupid. I did a battery pull on the off chance, and when the phone rebooted, both apps were now showing 46%. The battery then charged at the same speed i'd expect, and todays battery drain is much more normal - off the charger at 7am and i'm only down to 78%. I'm guessing one of the earlier battery pulls made a crap connection (we all know the z10 battery has a bit of movement to it)
    10-22-13 06:12 AM
  7. The Big Picture's Avatar
    Insane battery drain continued all off yesterday, and I charged and drained the phone 4 or 5 times yesterday, resulting in me putting it onto charge at 10pm at 6% remaining.
    2 hours later, both Hub++ and BatteryGuru were reporting 16%, which just seemed stupid. I did a battery pull on the off chance, and when the phone rebooted, both apps were now showing 46%. The battery then charged at the same speed i'd expect, and todays battery drain is much more normal - off the charger at 7am and i'm only down to 78%. I'm guessing one of the earlier battery pulls made a crap connection (we all know the z10 battery has a bit of movement to it)
    My advice is to back up your phone using link and load 10.2.0.1767 as it is actually an official release. Then restore.

    Z30-Q10-Z10-iP5
    10-22-13 06:16 AM
  8. tushargkwd's Avatar
    Even on my phone, the location services age on for no reason... I have checked all open apps and I don't see anything running in the background...
    A reboot does fix the issue.

    Posted via the awesome keyboard on Z10STL100-1/10.2.0.1791 using CB10 App
    10-22-13 07:02 AM
  9. Undbiter65's Avatar
    Yeah. Just a quick reboot. I've had it happen once to me. Try rebooting it when it acts up and see if it works.

    "If you can't soar with the eagles, then don't fly with the flock!" (BBM#18)
    10-22-13 09:59 AM
  10. adampageuk's Avatar
    Hmm, it's happening again, massive battery drain when idle with no apps running (other than battery guru) and no obvious additional data use.

    Again, I've tried battery pulls with no change, I'm still getting the battery draining in less than 3 hours.

    Given the recent duff data from BlackBerry breaks sensors, is there potential for it being a similar issue, where some kind of communication with BlackBerry fails and it keeps trying, wiping the battery out quickly.

    Posted via CB10
    12-09-13 10:11 PM
  11. Rushi Pandya's Avatar
    Check battery status with SIM-INFO application... it's good or bad

    Posted via CB10
    12-10-13 12:47 AM

Similar Threads

  1. Battery Percentage showing in Official 10.2?
    By chudypee in forum BlackBerry 10 OS
    Replies: 22
    Last Post: 02-04-14, 03:42 AM
  2. 4500mAh battery : How well do they work?
    By smitty1077 in forum More for your BlackBerry 10 Phone!
    Replies: 8
    Last Post: 11-02-13, 08:57 PM
  3. BlackBerry Z30 Battery Life
    By BriniaSona in forum BlackBerry Z30
    Replies: 48
    Last Post: 10-24-13, 08:08 AM
  4. Good battery life with 10.1.
    By sgosh in forum BlackBerry Q10
    Replies: 2
    Last Post: 10-20-13, 01:26 PM
  5. Battery Percentage showing in Official 10.2?
    By chudypee in forum BlackBerry Z10
    Replies: 0
    Last Post: 10-20-13, 07:53 AM
LINK TO POST COPIED TO CLIPBOARD