1. Pronay's Avatar
    Hey there everyone. I recently purchased a Blackberry Z10. It was running OS version 10.1.something out of the box and it was working perfectly.
    The camera worked and the phone was perfect.

    Unfortunately though, there was a prompt that OS 10.2.0.415 was out and I accepted. The OS was installed onto my STL100-1 smartphone and ever since that happened my phone's camera doesn't work. Not to mention, videos from websites like youtube don't play either.

    I have tried to reload the OS using BB Link software and there was nothing that changed.
    Tried factory resets too but the OS version never changed and the problems still persisted.
    I have tried infinite reboots and nothing has worked. The phone otherwise works well but the camera is obviously pretty important.

    If anyone can help me out with this please do. I bought the phone only recently and am already having troubles with it.
    12-16-13 10:06 PM
  2. RedFoxOne's Avatar
    Hi there. I actually had the same problem with you.
    Here is my thread that I started a while ago, but barely get any help:
    http://forums.crackberry.com/blackbe...e-help-883182/
    But please read it to get a basic idea of what I was trying to do. It will help if you know how to find and install leaked OS.

    And what I did to finally get it working:
    1. Backup media and settings with Link. I was wary if the apps caused the problems, and maybe it's better to just re-download apps.
    2. Took out SD card and SIM card. Installed leaked OS 10.2.1.1055. Didn't setup BB ID etc. Just went straight to..
    3. Security wiped
    4. Installed OS 10.2.1.1055 again. Set up BB ID etc
    5. Restored media and settings. (Contacts are backed up in settings)
    6. Went to sleep. Some say it takes time for the new OS to settle in and some processes might be running that would make the back of the phone warm. (At this point, I still hadn't inserted the SIM card)
    7. Woke up, battery pulled, and left it for about an hour. Inserted SIM card, put in battery, started the phone and no more problems.

    If you're going to try installing leaked OS, then be very caution with it. Don't do battery pull from 1-5. I won't be held responsible for any damage caused.
    Pronay likes this.
    12-16-13 10:19 PM
  3. Pronay's Avatar
    hey RedFoxOne,

    Thanks a lot for the help.
    I will try the method you suggested... All i want at this point is for my phone to work.

    will update if I get my phone working
    12-16-13 10:23 PM
  4. Uzi's Avatar
    in camera app tap the video icon,have you tried that?

    Posted via CB10
    12-16-13 10:24 PM
  5. Pronay's Avatar
    @usman_hidayat19

    The problem is that the camera app doesnt start up.

    I get a message that says the camera cant be started and there is nothing that opens or anything.
    12-16-13 10:28 PM
  6. Uzi's Avatar
    https://mega.co.nz/#!s8dGSaxQ!EoUGiD...iaxMLSIM11PaD8
    this camera bar file
    you need to sideload it using ddpb
    search in forum how to sideload

    Posted via CB10
    12-16-13 10:31 PM
  7. RedFoxOne's Avatar
    @usman hidayat : I also tried that start-camera-from-video thing and it also failed for me.
    @pronay : Be sure to learn about installing leaks first, because it could brick your phone if you screw up. There are threads about it in this forum. Also, do give usman hidayat's method a go, maybe installing that camera bar file could work, and is a more simple method. I didn't have his version of camera bar file before, I had older one.
    12-16-13 10:33 PM
  8. Pronay's Avatar
    Sure thing.

    I will try the camera bar file first (lets hope it stops at that)
    In case I have to install the leak, then i will make sure i go through the threads

    Wouldn't wanna brick my phone or anything

    Thanks a ton guys
    12-16-13 10:48 PM
  9. Pronay's Avatar
    Okay guys,

    I first tried the .bar file but it didnt help.
    After that attempt i downloaded the 10.2.1.1055 leaked OS and used the autoloader.
    The device works perfectly and i didn't have to do the security wipe either.

    Thank you so much guys!!!

    I really appreciate the help!!

    You SAVED MY PHONE!!!!
    Uzi likes this.
    12-17-13 04:31 AM
  10. RedFoxOne's Avatar
    Great! Enjoy your Z10!
    Now where's that benjamin nyc guy with the "no betas no leaks ever" motto...
    Pronay likes this.
    12-17-13 05:13 AM

Similar Threads

  1. Help with Go Music
    By sarcazmo in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 12-17-13, 03:32 PM
  2. Unlocked Bold 9650 won't work in US?
    By betterley in forum BlackBerry Bold Series
    Replies: 4
    Last Post: 12-17-13, 03:01 PM
  3. HELP, saving an email photo
    By windsurfar in forum BlackBerry Z30
    Replies: 12
    Last Post: 12-17-13, 10:00 AM
  4. Why is it theres always an exception in os stl100-1????????????
    By Jonathan Hernandez6 in forum BlackBerry Z10
    Replies: 5
    Last Post: 12-16-13, 10:15 PM
  5. cant send or receive mms messages on Z10! Help!!
    By jfletcherm in forum General Carrier Discussion
    Replies: 3
    Last Post: 12-16-13, 03:14 PM
LINK TO POST COPIED TO CLIPBOARD