1. nishant.dreamviewer's Avatar
    Hello Guys,
    There are thousands of STL100-1 out there having the Camera/Mic and Some random powering off issues. Blackberry is still not able to solve these issues and make people run after the service center to resolve them.

    After two long years and shifting to STL100-3 months back. I finally figured it out. There is actually a design flaw in the phone leading to these issues( I repeat Blackberry will not accept this). Changing your Mic and Camera is not the permanent solution.
    Here is what I did. I realized there was a 0.2mm gap between the mic pins and motherboard, so as a layman i just places a 0.4mm thick paper or you can say a visiting card cutout folded underneath the motherboard(make sure it is not to big and placed horizontally or it will show ghost screen at the bottom of ur display)
    I packed the phone and did test it out it worked out instantly. But now as always whenever the phone had a small bang or tap on the back the phone restarted. So i placed another small 0.4mm thick paper on top of the contact pins and that solved the issue too.

    But the weirdest thing that happened was that after fixing these two issues my camera which didn't work for months now started working without a software update or using an autoloader(dont know why). Yes guys its not a software issue. Nearly half the STL100-1 phone sold in India have this problem and also other places around the world. No software issue no hardware issue just a 0.2mm design fault. I have attached the image for the same. I hope this might help lat many people around the world using STL100-1,

    To,
    CrackBerry could please for sometime stop promoting and try solving the consumer issues by posting a DIY article for others as not many people look at forums for answers.

    Note: If this doesn't resolve your mic issues, try pressing the speaker if it detects voice you may need to loosen or tighten the crews or add a thinner paper(I used Voice control/search to test without sim card inserted)

    I am not a frequent forum user so might not reply to the threads. Best of Luck.

    [Solved] STL100-1 issues Camera,Mic and phone turning off randomly.-untitled.jpg
    11-04-14 07:24 AM
  2. hamsterwheel's Avatar
    Good deal, thanks for taking the time to post this. Let's hope it helps others as well.
    11-08-14 02:38 PM
  3. Dhaval090's Avatar
    Yes the phone available in india are having this kind of problem and I am one of them.


    Z10STL100-1/10.2.1.3442
    11-10-14 09:27 AM
  4. Dhaval090's Avatar
    And the phones available on ebay.in are ****box, they are selling this phones at cheapest price and with 15 days seller warranty only for software issues.

    Paradise94
    11-10-14 09:30 AM

Similar Threads

  1. Magicjack and 10.3 O.S
    By Hernan Mondragon in forum Android Apps (Amazon Store & APK Files)
    Replies: 4
    Last Post: 12-06-14, 10:00 PM
  2. Replies: 1
    Last Post: 11-04-14, 07:45 PM
  3. Simple (and probably stupid) question...be nice :)
    By TJKGT in forum BlackBerry Z30
    Replies: 3
    Last Post: 11-04-14, 07:29 AM
  4. How do I get my San Disk 64gb to work on my Q10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-04-14, 07:13 AM
  5. Classic and BES 12
    By Needkeys in forum BlackBerry Classic
    Replies: 1
    Last Post: 11-04-14, 07:02 AM
LINK TO POST COPIED TO CLIPBOARD