1. George Jenkinson's Avatar
    Hi folks, anyone able to help?

    I've noticed with my new Z10 [had it less than a week] that sometimes the scrolling on the screen jumps from when I first use it - a bit like it suddenly waking up and then catching up. Does this settle down after a few days of use?

    Also, the official Twitter app takes up to 5 seconds to load (with the blue birdy in the centre of the screen) and once this opens, it takes a few more seconds to update itself. Does this settle/speed up after a while, or is there a better twitter app you would recommend?

    I got this Z10 SIM free [and for a bargain price!] in Carphone Warehouse, UK - in case this makes any difference to the way it works...?

    Cheers
    12-02-13 05:58 AM
  2. jaydee5799's Avatar
    Hi! and welcome!
    I think a lot of people dumped the native twitter app and use BLAQ available in BBWorld.
    We like that a whole lot better. As for lag, no. I never experienced any lag when first using my Z10. Have you rebooted a few times to help it?
    12-02-13 06:08 AM
  3. eyecrispy's Avatar
    +1 for blaq

    SQN100-1 10.2.1.1055, STL100-3 10.2.1.1055
    12-02-13 06:25 AM
  4. George Jenkinson's Avatar
    Hi! and welcome!
    I think a lot of people dumped the native twitter app and use BLAQ available in BBWorld.
    We like that a whole lot better. As for lag, no. I never experienced any lag when first using my Z10. Have you rebooted a few times to help it?
    No, didn't think to do a reboot! Is that a battery pull?

    Will check out Blaq too!

    Thanks for the suggestions.
    12-02-13 06:35 AM
  5. FF22's Avatar
    No, didn't think to do a reboot! Is that a battery pull?

    Will check out Blaq too!

    Thanks for the suggestions.
    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black, keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above
    12-02-13 01:00 PM
  6. George Jenkinson's Avatar
    That's very helpful, thank you F2.
    12-03-13 08:22 AM

Similar Threads

  1. Replies: 12
    Last Post: 02-22-14, 01:30 AM
  2. Do Normal Headphones Not Work on Blackberries?
    By PyramidHeadcrab in forum General BlackBerry News, Discussion & Rumors
    Replies: 16
    Last Post: 12-22-13, 09:38 PM
  3. Do BBM and Whatsapp eat the battery?
    By nanda_s in forum BlackBerry Q10
    Replies: 7
    Last Post: 12-04-13, 12:17 AM
  4. not showing recent update on bbm
    By onlyidiot in forum BlackBerry OS Apps
    Replies: 1
    Last Post: 12-03-13, 02:20 AM
  5. Replies: 7
    Last Post: 12-02-13, 12:16 PM
LINK TO POST COPIED TO CLIPBOARD