1. Nico Louis's Avatar
    Hi guys, i just wanna ask why i have slow browsing experience even my signal indicator says H+ w/c is iknow its has to be fast browsing experience, i felt like im using EdGE while browsing hope you can help me guys.. TIA
    05-01-13 06:08 PM
  2. BergerKing's Avatar
    Hi guys, i just wanna ask why i have slow browsing experience even my signal indicator says H+ w/c is iknow its has to be fast browsing experience, i felt like im using EdGE while browsing hope you can help me guys.. TIA
    I see an answer hasn't been given, perhaps we can get some member or members to chime in with some assistance.
    05-09-13 04:41 PM
  3. mad33man's Avatar
    Is it also slow on wifi? If not it's probably coverage.

    Posted via CB10
    05-09-13 04:50 PM
  4. baolam86's Avatar
    Clear your browsing history, cache and cook. Turn off flash if necessary. Reset your search engine in browser setting

    Posted via CB10
    05-09-13 05:21 PM

Similar Threads

  1. Bold and the slow browsing experience
    By BananAlex in forum BlackBerry Bold Series
    Replies: 6
    Last Post: 11-11-08, 08:49 AM
  2. question about browsing this forum
    By pooger in forum New to the Forums? Introduce Yourself Here!
    Replies: 9
    Last Post: 04-14-08, 09:17 PM
  3. Slow Browsing with Wi-Fi - Why?
    By phoneboy101 in forum BlackBerry Curve Series
    Replies: 6
    Last Post: 03-21-08, 03:42 PM
  4. Slow browsing...
    By jcjdoss in forum BlackBerry Curve Series
    Replies: 8
    Last Post: 02-16-08, 03:27 AM
  5. Replies: 7
    Last Post: 12-13-07, 08:43 PM
LINK TO POST COPIED TO CLIPBOARD