1. joserMireles's Avatar
    Ok so I'm having trouble sending and receiving mms messages. I just recently noticed a few days ago when I try to send a picture it just shows a red clock and it never changes. When people send me photos I just never receive them.
    Here's the deal, I have the Z10 with t-mobile and I had it working with their normal 500mb data plan and everything worked fine, but I recently bought a used bold 9900 but that plan didn't allow me to receive e-mails or sign in to bbm. I switched to a 500mb blackberry data plan for the same price and now I can receive e-mails on the bold.
    Could this be the issue? Even with wifi off, I can sign in to bbm, receive and send emails, surf the web and download apps with my z10, it's just the mms that's not working. I haven't been able to test if I can send mms with my bold since I left it at work and having been back.
    Does anybody have this problem?
    10-06-13 07:42 PM
  2. SCrid2000's Avatar
    SMS and MMS don't have the best track record for sending and receiving. If you have bad cell reception, that could be the issue.
    10-06-13 08:55 PM
  3. EmaliMcrtny's Avatar
    Just noticed today that I've not been able to send/ receive MMS. Don't know how long I've had this issue as I usually e-mail or post photos using social sites. I am on Optus, on 10.1.04181 using STL100-2. Everything else, like, OP works normal. I've turned off phone, pulled batt, checked network settings, had my daughter send pics to both hubby and I (we're all on the same network) and it's just my Zed that doesn't get it. Is there a fix for this?

    On my chosen one... z10
    10-14-13 04:14 AM
  4. pejjy's Avatar
    Same issue here. With att. Can't send pics. 10.2 leak installed.

    Posted via CB10
    10-14-13 07:38 AM
  5. ams083's Avatar
    Check your MMS settings (hub>settings>text messages>advanced>sms) scroll to the bottom section and check you have at least APN entered and also the MMS settings, will be something like a URL and a proxy IP. If there's nothing there, check the settings with your carrier.

    Also under the MMS tab, make sure you have auto retrieval mode set to 'always' or 'home'.



    Z10STL100-2/10.1.0.1720 Telstra AU
    10-14-13 07:39 AM
  6. EmaliMcrtny's Avatar
    Tried that, thank you Amos083. No joy. Had my handset for 3 months and I've only just noticed this. Will keep an eye out for fix.

    On my chosen one... z10
    10-14-13 05:32 PM
  7. joserMireles's Avatar
    Tried that, thank you Amos083. No joy. Had my handset for 3 months and I've only just noticed this. Will keep an eye out for fix.

    On my chosen one... z10
    Hey just letting you know I was able to fix mine, I went to settings, network connections, mobile network, and then tap the apn button. Under apn it had something like fast.tmobile.com for some reason that apn wasn't working so I typed in epc.tmobile.com and that fixed my problem. I never messed with the apn settings so I don't know what caused it to stop working but that fixed it, try it if you're with tmobile.

    Posted via CB10
    10-14-13 05:43 PM
  8. mckillio's Avatar
    This worked for me and doing it in my regular ApN settings fixed my issue of not being able to use desktop mode in the browser. Still can't do tethering or mobile hot spot without a plan though.

    Posted via CB10
    10-15-13 06:17 PM

Similar Threads

  1. Crackberry and BlackBerry enthusiasts unite
    By styleskey in forum Rehab & Off-Topic Lounge
    Replies: 159
    Last Post: 08-01-14, 10:47 AM
  2. Z10 Questions - volume and software updates
    By JuiciPatties in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-10-13, 08:35 PM
  3. My opinion and issues after a few days of Q10
    By RegN in forum BlackBerry Q10
    Replies: 45
    Last Post: 10-07-13, 08:59 PM
  4. I am the only one with these problems?
    By playyah in forum BlackBerry Z10
    Replies: 1
    Last Post: 10-06-13, 04:58 PM
LINK TO POST COPIED TO CLIPBOARD