1. Ferrari430Spider's Avatar
    Hi guys wondering if you can help me out.

    Yesterday my beloved Z10 just packed up!

    Was in my pocket and was just dead when I went to check it.

    I have since tried battery pulls, left it on charge. Tried an auto loader and also not detected by link...

    Only thing it does it flashes twice when plugged in on charge after I press and hold the power button for a while.

    I really need this phone to work as I cannot function without it.

    Any suggestions?

    Thanks in advance.
    07-19-15 12:46 PM
  2. Paul94's Avatar
    Hi guys wondering if you can help me out.

    Yesterday my beloved Z10 just packed up!

    Was in my pocket and was just dead when I went to check it.

    I have since tried battery pulls, left it on charge. Tried an auto loader and also not detected by link...

    Only thing it does it flashes twice when plugged in on charge after I press and hold the power button for a while.

    I really need this phone to work as I cannot function without it.

    Any suggestions?

    Thanks in advance.
    What OS are you on? Try flashing 10.3.2.2339 via autoloader.

    Z10 10.3.2.2339
    07-19-15 01:08 PM
  3. Ferrari430Spider's Avatar
    I'm running the latest official 10.3.1

    Not sure of the build

    The phone is not detected when I plug it into the PC
    07-19-15 02:22 PM
  4. Paul94's Avatar
    I'm running the latest official 10.3.1

    Not sure of the build

    The phone is not detected when I plug it into the PC
    Try to plug it without the battery. Or change the usb slot.

    Z10 10.3.2.2339
    07-19-15 02:57 PM
  5. stevec66's Avatar
    It's died a nature death, break open the wallet time to purchase a new phone. Look on the bright side you will be supporting some $5.00 a day Chinese worker.

    Posted via CB10
    WanShark69 likes this.
    07-19-15 03:05 PM
  6. Ferrari430Spider's Avatar
    Haha

    The his is tragic

    So the conclusion is its properly f@cked?
    07-19-15 03:08 PM
  7. goodayeh's Avatar
    Usually if your led flashes , there is hope of revival...
    07-19-15 03:13 PM
  8. Ferrari430Spider's Avatar
    That's what I'm thinking. Surprised no one has a definitive answer on here !

    I got so much data I cannot afford to lose
    07-19-15 03:38 PM
  9. goodayeh's Avatar
    Just search the forums on CB. There are many threads about this.

    There was someone not to long ago who battled it out for over a month and finally got it working again !
    ( don't remember what the solution was , though ! )
    07-19-15 05:30 PM
  10. Ferrari430Spider's Avatar
    I've tried searching and no joy. Anyone else got ideas ?
    07-20-15 03:30 AM
  11. yngvarrsen24's Avatar
    I was in a same situation. Try this : pull out battery for 5 minutes then insert it back to the phone and connect it to your pc via USB. Then wait a while and your BlackBerry must become alive again showing that battery was fully discharged and it will be charging.

    Posted via CB10
    jojo beaconsfield likes this.
    07-20-15 03:40 AM
  12. shorski's Avatar
    Have you tried another battery on it to be sure it's battery issue?
    When you plug it in to charge, did you confirm it was actually charging?
    When you plug it in to your PC, what did Link display?

    You can try to plug in the device without the battery for one minute, after which you put back the battery without removing the charger. Don't plug in to a PC and use the original charger. It should charge and turn on by itself. However, this will only apply if the issue has to do with battery.
    07-20-15 03:54 AM
  13. yeo123's Avatar
    Hi guys wondering if you can help me out.

    Yesterday my beloved Z10 just packed up!

    Was in my pocket and was just dead when I went to check it.

    I have since tried battery pulls, left it on charge. Tried an auto loader and also not detected by link...

    Only thing it does it flashes twice when plugged in on charge after I press and hold the power button for a while.

    I really need this phone to work as I cannot function without it.

    Any suggestions?

    Thanks in advance.
    These are a few solution as follows,
    1. Reset by hold the power button until the BlackBerry Logo appear and then release button.
    2. Device connect via USB to PC , open BlackBerry Link, and hitting factory reset.
    3. Device Connect. Via USB to PC, open Sachesi and hitting wipe.
    4. Kidding Buy. A. new BlackBerry device.
    The device reset is need 50% above battery power .good luck.

    BlackBerry Z10/STL100-2
    07-20-15 05:12 AM
  14. Ferrari430Spider's Avatar
    guys i have tried all of these. its not doing anything. just wont switch on i am baffled. its not even a year old. the phone just dont respond.
    07-20-15 05:14 AM
  15. Frankskytop's Avatar
    This has started happening to me as well since I upgraded a while back to 10.3
    It a huge pain in the arse!
    What I found works best is pulling the battery, pulling the sim card and then try holding the top button down without releasing for a good 2 minutes.
    Repeat if needed or re try pressing top reset for 3 minutes. It will come back and you will lose it again just in time for an important conf call with your boss.
    I've called spoken to BlackBerry and they told me to reinstall. I did that and same problem. I think it has to do with the size of the new or and the old z10 engine. They keep denying there is a problem but I have run into many people with this same problem

    Posted via CB10
    07-20-15 07:22 AM
  16. Ferrari430Spider's Avatar
    Can you be a bit clear please ? Do I hold the button with no battery or with battery ? Do I need charger in place?
    07-21-15 04:57 AM
  17. Ferrari430Spider's Avatar
    I genuinely think I'll be leaving BB after years and years of using them.
    07-21-15 05:42 AM
  18. Michael Liang's Avatar
    I share your angst. Had an incident with my laptop years ago.

    Had a problem booting up the Z10 once in 2014. Red LED flashes once or twice when I press on the button but it refuses to boot. I took out the battery and left it for an hour. Pop back in and charge with original charger. Works well after that. Non-recurring problem, so I don't think my experience helps.

    This will be a good reminder for us to make a habit backing up data and contacts regularly. I must thank my lucky stars that I have had a good years with this phone.

    Posted on my white Z10 via CB10
    07-21-15 05:55 AM
  19. Michael Liang's Avatar
    My phone was showing heating symptoms during that incident. So can't be sure if it is hardware or software problem.

    Posted on my white Z10 via CB10
    07-21-15 05:57 AM
  20. Ferrari430Spider's Avatar
    I've tried everything. End of my tether. Feel hard done by BB. So frustrated just want it to boot back up. Sounds like it's just pot luck for it to work.
    07-21-15 07:39 AM
  21. Paul94's Avatar
    Your device might have a hardware problem. Go check a service

    Z10 10.3.2.2339
    07-21-15 12:16 PM
  22. Johnny Dollar's Avatar
    I've tried everything. End of my tether. Feel hard done by BB. So frustrated just want it to boot back up. Sounds like it's just pot luck for it to work.
    You said you've had the phone for less than a year? It's still under warranty. Send it back to Blackberry and make them deal with it.

    Posted via CB10
    07-21-15 03:25 PM
  23. Ferrari430Spider's Avatar
    What about all my personal data
    07-22-15 01:46 PM

Similar Threads

  1. MY Blackberry Z10, wont turn on after I charge it. What do i do?
    By Badong Manalili1 in forum BlackBerry Z10
    Replies: 2
    Last Post: 07-21-15, 09:02 AM
  2. Can't delete pictures on my z30
    By usmandennis in forum Ask a Question
    Replies: 5
    Last Post: 07-20-15, 08:37 PM
  3. What happened to my whatsapp
    By anishchowdary in forum BlackBerry Q10
    Replies: 2
    Last Post: 07-20-15, 09:06 AM
  4. I need help with my android run time
    By tkulthenoble in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 07-19-15, 11:46 AM
  5. Replies: 2
    Last Post: 07-19-15, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD