1. zefreaky's Avatar
    So as the title says my BlackBerry Z10 started acting up on me for the last 2 weeks, it lags a lot and restarts itself sometimes.
    I've been using the z10 for more then 5 months and OS 10.2.0.1725 since it was leaked, and I've never had issues, everything was running smooth and battery life was just great.
    But 2 weeks ago my z10 is lagging a lot: the screen freezes, the keyboard not responding quickly (especially on Android apps and browser), there's also a delay on notifications and I get empty boxes on the hub. When I'm playing games such as iron-man or NFS it stops and restarts itself with no apparent reason, and battery drains real quick when used, no overheating though.

    So my questionis: is there a solution to fix these issues? Reloading the OS? Security wipe?
    I didn't upgrade to the latest leaked OS because I think this one is just perfect and it was running perfectly until 2 weeks ago.

    Posted via my awesome Z10 !
    10-20-13 12:18 PM
  2. hrim5493's Avatar
    Did you do a security wipe when installed the leak?
    10-20-13 12:21 PM
  3. zefreaky's Avatar
    Did you do a security wipe when installed the leak?
    Nop!
    But everything was running great so I didn't think it was necessary -_-'

    Posted via my awesome Z10 !
    10-20-13 12:24 PM
  4. soonph87's Avatar
    I experienced the same scenario too. I did security wipe after reload.

    Posted using BlackBerry Z10 via CB10
    10-20-13 12:24 PM
  5. zefreaky's Avatar
    I experienced the same scenario too. I did security wipe after reload.

    Posted using BlackBerry Z10 via CB10
    So you saying, I should l reload OS and do a security wipe afterwards? Right?

    Posted via my awesome Z10 !
    10-20-13 12:26 PM
  6. hrim5493's Avatar
    Nop!
    But everything was running great so I didn't think it was necessary -_-'

    Posted via my awesome Z10 !
    Not saying it was the sole reason of the lag but it's always good for your new os once you install leak, you then do a wipe of it. Try installing 1791. Its supposedly the most stable leak out there. It might solve your problems.
    10-20-13 12:28 PM
  7. zefreaky's Avatar
    Not saying it was the sole reason of the lag but it's always good for your new os once you install leak, you then do a wipe of it. Try installing 1791. Its supposedly the most stable leak out there. It might solve your problems.
    OK thanks, I'll try that whenever I have a spare moment.

    Posted via my awesome Z10 !
    10-20-13 12:37 PM
  8. soonph87's Avatar
    So you saying, I should l reload OS and do a security wipe afterwards? Right?

    Posted via my awesome Z10 !
    Opss.. sorry I mean even I did the wipe, my phone still experiencing what you described. It restarts itself twice today.

    Posted using BlackBerry Z10 via CB10
    10-20-13 12:37 PM
  9. hrim5493's Avatar
    Opss.. sorry I mean even I did the wipe, my phone still experiencing what you described. It restarts itself twice today.

    Posted using BlackBerry Z10 via CB10
    I would recommend loading a new leak. It would def help.
    10-20-13 12:41 PM
  10. soonph87's Avatar
    I would recommend loading a new leak. It would def help.
    Ok. Thanks. Will try the coming weekend.

    Posted using BlackBerry Z10 via CB10
    10-20-13 12:47 PM
  11. @craig's Avatar
    Try 1791. I've had zero issues so far with that build.

    So as the title says my BlackBerry Z10 started acting up on me for the last 2 weeks, it lags a lot and restarts itself sometimes.
    I've been using the z10 for more then 5 months and OS 10.2.0.1725 since it was leaked, and I've never had issues, everything was running smooth and battery life was just great.
    But 2 weeks ago my z10 is lagging a lot: the screen freezes, the keyboard not responding quickly (especially on Android apps and browser), there's also a delay on notifications and I get empty boxes on the hub. When I'm playing games such as iron-man or NFS it stops and restarts itself with no apparent reason, and battery drains real quick when used, no overheating though.

    So my questionis: is there a solution to fix these issues? Reloading the OS? Security wipe?
    I didn't upgrade to the latest leaked OS because I think this one is just perfect and it was running perfectly until 2 weeks ago.

    Posted via my awesome Z10 !
    10-20-13 12:53 PM
  12. m1kr0's Avatar
    1791 for me also very stable thus far. Perhaps you should try. I have no experience of 1725 though and dunno if that's the problem.
    10-20-13 01:20 PM
  13. Undbiter65's Avatar
    .1725 was buggy for me. Try another leak. And don't forget to wipe after installing it.

    "If you can't soar with the eagles, then don't fly with the flock!" (BBM#18)
    10-20-13 01:39 PM
  14. zefreaky's Avatar
    Thank you all for your help I really appreciate it.
    Well I guess it's time to the change the OS, and do a security wipe! XD

    Posted via my awesome Z10 !
    10-20-13 05:09 PM

Similar Threads

  1. Q10 Restart Issue
    By John Holley in forum BlackBerry Q10
    Replies: 16
    Last Post: 10-17-13, 03:07 PM
  2. Deleted apps appear on my phone when I restart my phone!
    By tommynap01 in forum BlackBerry Q10
    Replies: 2
    Last Post: 10-16-13, 10:01 PM
  3. Help! BB 9320 Always Restarting by itself > 10X
    By OmarVo in forum General BlackBerry News, Discussion & Rumors
    Replies: 2
    Last Post: 10-15-13, 09:31 AM
  4. Outgoing text message lag issue.
    By MistahMan in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 10-13-13, 03:50 AM
  5. Q10 lags when opening settings
    By mulhimns in forum BlackBerry Q10
    Replies: 9
    Last Post: 10-11-13, 09:53 PM
LINK TO POST COPIED TO CLIPBOARD