04-22-13 04:18 PM
209 ... 789
tools
  1. doggy10's Avatar
    My z10 has been perfect since I got it on Feb 5th on telus network. Loving this Device!!

    BlackBerry Z10 and 32gb PlayBook
    04-06-13 12:14 AM
  2. Maal628's Avatar
    Seems like us Verizon users are having the most issues. That's why they need to release latest OS asap.

    CB10 on Verizon Z10
    04-06-13 12:22 AM
  3. scrannel's Avatar
    Here's the deal (as I mentioned in a thread) bought my T-Mo phone and it was perfect. Then a few days ago began random shut-downs. Screen even went blue and crashed. Wracked my brains and the only thing I had done was add a tight fitting rubber case... overheating? Took the case off and am back to perfection. Very weird. Been four days and not a single incident.
    04-06-13 12:30 AM
  4. ThaMayor's Avatar
    Smooth sailing

    Posted via CB10
    04-06-13 12:31 AM
  5. TTQ225's Avatar
    In my 60 days of ownership (today) it never failed. Works as advertised. No glitches. Perfect.

    Posted via CB10
    LostOnThePianoRoll likes this.
    04-06-13 12:34 AM
  6. tfrankson's Avatar
    None here as well however different case for my hubby. We went to exchange it for a brand new one. All is well. Seems its a hardware issue.

    Posted via CB10
    04-06-13 12:34 AM
  7. 1magine's Avatar
    The device has been decent - until I started putting applications on it. Tetris and Face Flow both caused freezing, lags and re-boots. Once I removed both, the phone has been pretty stellar. Honestly - if every app worked as well as the NY Times app, I'd be a very happy guy.

    The Times App actually seems to work better than many BBRY made apps. But in any case - yeah, if you have issues, start deleting apps.
    04-22-13 03:50 PM
  8. playbookster's Avatar
    Bought feb5th. 0 issues

    Posted via CB10
    04-22-13 04:02 PM
  9. LuayS's Avatar
    Mine has rebooted maybe twice randomly. Rogers, otherwise no real issues. I do notice randomly ng bluetooth cuts out from the car and the song will play but no audio is heard through the speakers. This requires a reboot and it is fixed

    Posted via CB10
    04-22-13 04:18 PM
209 ... 789

Similar Threads

  1. My Z10 has shipped!
    By randomroyalty in forum BlackBerry Z10
    Replies: 78
    Last Post: 02-04-13, 08:11 AM
  2. My GPS has never worked, do I have a faulty unit?
    By turqrazor in forum BlackBerry PlayBook
    Replies: 21
    Last Post: 06-12-11, 11:16 PM
  3. Well... My Torch has never done THAT before.
    By BBRYCnvnedMe in forum BlackBerry Torch Series
    Replies: 11
    Last Post: 03-28-11, 03:51 PM
  4. since the upgrade my screen has been finicky
    By MyThai in forum BlackBerry Storm Series
    Replies: 0
    Last Post: 10-30-09, 10:49 AM
  5. Replies: 3
    Last Post: 06-03-09, 11:34 PM
LINK TO POST COPIED TO CLIPBOARD