04-22-13 04:18 PM
209 123 ...
tools
  1. guinnkevinr's Avatar
    Yup, just saying, but my Z10 has been a complete gem and isn't all drama like I've seen some people experience.

    Posted via CB10
    03-31-13 05:07 PM
  2. ErinnM's Avatar
    So far, so good for me!
    03-31-13 05:08 PM
  3. diegonei's Avatar
    Is it only just the two three of us? Can't be...
    03-31-13 05:08 PM
  4. scorepion's Avatar
    I'm here...

    Posted via CB10
    03-31-13 05:09 PM
  5. asuprice's Avatar
    No problems with mine either.

    Posted via CB10
    03-31-13 05:10 PM
  6. gpx6's Avatar
    No problems here.

    Posted via CB10
    03-31-13 05:11 PM
  7. Ali Allen's Avatar
    Same here. The. Again I dunno if it has something to do with not loading any apps on it besides this one

    Posted via CB10
    03-31-13 05:12 PM
  8. Richard Buckley's Avatar
    No problems here either.

    Posted via CB10
    03-31-13 05:13 PM
  9. boss_hog's Avatar
    I have had an app or 2 that needed to be restarted but the phone nowhere close. Rock solid

    Posted via CB10
    03-31-13 05:13 PM
  10. K00na's Avatar
    It is also noteworthy that my car has never been stolen and my house has not ever been broken into yet.
    3_M4N likes this.
    03-31-13 05:17 PM
  11. guinnkevinr's Avatar
    That's why I've stayed away from side loading apps. And I have a handful of BlackBerry apps and still no problems. My battery life is rock solid too.

    Posted via CB10
    allstar0088 likes this.
    03-31-13 05:18 PM
  12. sosof's Avatar
    No issues so far

    Posted via CB10
    allstar0088 likes this.
    03-31-13 05:18 PM
  13. sfor13thlegion's Avatar
    No problems. Running as smooth as day one.


    Posted via CB10
    allstar0088 likes this.
    03-31-13 05:19 PM
  14. Gnomesane's Avatar
    Add me to no lags, no freezes, no battery pull or forced restart, no device reload. Got it Feb 5, so far so good.

    Posted via CB10
    allstar0088 likes this.
    03-31-13 05:20 PM
  15. Nabooy's Avatar
    Never had an issue on my previous STL-1 but once I got my newly STL-2, I had like 3 times randomly reboots on the first day but seems to be solid fine now. Strange? Yes.
    03-31-13 05:22 PM
  16. anon(5639363)'s Avatar
    Same here no issues, and I have 4 or 5 sideloaded apps too. It's run flawlessly.

    Ya, I am an unabashed BB supporter. Don't like that? Then put me on ignore.
    guinnkevinr likes this.
    03-31-13 05:23 PM
  17. Gnomesane's Avatar
    It is also noteworthy that my car has never been stolen and my house has not ever been broken into yet.
    Are you a glass half empty kind of guy? I don't think the OP is denying people have had issues, just wanted to hear from people who've had no major issues. Surely the more that have had a positive experience the better.

    Posted via CB10
    03-31-13 05:24 PM
  18. mike-berry's Avatar
    No issues here!

    Posted via CB10
    03-31-13 05:24 PM
  19. K00na's Avatar
    Are you a glass half empty kind of guy? I don't think the OP is denying people have had issues, just wanted to hear from people who've had no major issues. Surely the more that have had a positive experience the better.

    Posted via CB10
    Depends on what is in the glass, really. And yes, the more people have had no reboots the better, obviously. I wish I had none, they are somewhat annoying, although less so since I disabled SIM card code lock.
    03-31-13 05:26 PM
  20. knighty2112's Avatar
    Nope! No freezing or random reboots here either. Had my Z10 for over eight weeks with none of the above problemos!

    Whoosh.....!!!!!!!!!! Careful! Z10 in action here!
    guinnkevinr likes this.
    03-31-13 05:26 PM
  21. BB Marissa's Avatar
    Denying it isn't happening to you, doesn't change the fact that it's happening for others.
    It'd happened to me once, in the last week and I have no side loaded apps installed.


    Posted via CB10
    03-31-13 05:26 PM
  22. guinnkevinr's Avatar
    Denying it isn't happening to you, doesn?t change the fact that it's happening for others.
    It'd happened to me once, in the last week and I have no side loaded apps installed.


    Posted via CB10
    Not denying some people have the issues. Just having a nice mid day chat with my peers who haven't experienced any problems. Just a warm fuzzy feeling of enjoying this wickedly awesome phone to the fullest.

    Posted via CB10
    alan510 likes this.
    03-31-13 05:29 PM
  23. TheTigerTek's Avatar
    Same here. My Z10 works fine.

    Posted via CB10
    allstar0088 likes this.
    03-31-13 05:30 PM
  24. missing_K-W's Avatar
    Hopefully shills or trolls aren't creating freeze/random reboot threads. device is rock solid
    allstar0088 likes this.
    03-31-13 05:30 PM
  25. independentvolume's Avatar
    My girlfriends has only rebooted a few times. She has never mentioned it freezing so there is that.
    03-31-13 05:30 PM
209 123 ...

Similar Threads

  1. My Z10 has shipped!
    By randomroyalty in forum BlackBerry Z10
    Replies: 78
    Last Post: 02-04-13, 08:11 AM
  2. My GPS has never worked, do I have a faulty unit?
    By turqrazor in forum BlackBerry PlayBook
    Replies: 21
    Last Post: 06-12-11, 11:16 PM
  3. Well... My Torch has never done THAT before.
    By BBRYCnvnedMe in forum BlackBerry Torch 9800
    Replies: 11
    Last Post: 03-28-11, 03:51 PM
  4. since the upgrade my screen has been finicky
    By MyThai in forum Storm OS Discussion
    Replies: 0
    Last Post: 10-30-09, 10:49 AM
  5. Replies: 3
    Last Post: 06-03-09, 11:34 PM
LINK TO POST COPIED TO CLIPBOARD