1. Rito Kapfo's Avatar
    Posted via CB10
    01-14-15 05:15 AM
  2. menshawy's Avatar
    You probably have a STL100-1 model, which is known for a battery calibration issue.. That means the phone doesn't read the precise battery percentage, so probably your 20% that the phone shuts down at is actually 0% or a bit more..

    There's threads here with different methods on how to fix the battery calibration issue. Try any of them
    01-14-15 05:18 AM
  3. rawkerboi 07's Avatar
    You may try these
    1) when your phone is dead, remove sim card, memory card, and battery for an hour or two.
    2) try to charge it via PC
    3) Try different battery

    Posted via CB10
    01-14-15 05:51 AM
  4. Jonathon Goodwin's Avatar
    My ST100-3 does this almost everyday. I think I need a new battery!
    01-14-15 09:08 AM

Similar Threads

  1. Is your passport full of native apps or android apps?
    By tippytoppy in forum BlackBerry Passport
    Replies: 75
    Last Post: 01-24-15, 08:33 PM
  2. Why isn't my BlackBerry Protect working?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-21-15, 01:30 PM
  3. My Z10 Squeaks?
    By meltbox360 in forum BlackBerry Z10
    Replies: 6
    Last Post: 01-17-15, 01:22 AM
  4. What is the best alternative browser for BB10?
    By GSM-S in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 01-14-15, 07:38 AM
  5. I miss my email icons
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 01-14-15, 05:55 AM
LINK TO POST COPIED TO CLIPBOARD