1. zozo1980's Avatar
    When I make a phone call the screen should be dimmed or be black.... this is the way it should be... but it is not...although I have noticed that this feature is working with viber very well.... weird!!!

    Any ideas....

    Thanks in advance...

    Posted via CB10
    07-08-14 08:50 AM
  2. ArmedHitman's Avatar
    When I make a phone call the screen should be dimmed or be black.... this is the way it should be... but it is not...although I have noticed that this feature is working with viber very well.... weird!!!

    Any ideas....

    Thanks in advance...

    Posted via CB10
    I had that same problem... Have u tested to see if the sensor works? Use BBVE tool to see if it works... Its under proximity sensor.
    07-08-14 08:53 AM
  3. FF22's Avatar
    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black (ignore the screenshot), keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above
    TeresaMKA likes this.
    07-08-14 09:20 AM
  4. zozo1980's Avatar
    I had that same problem... Have u tested to see if the sensor works? Use BBVE tool to see if it works... Its under proximity sensor.
    Thanks... I did the test with BBVE and it worked fine but with the calls, the same thing....

    Posted via CB10
    07-08-14 10:36 AM
  5. zozo1980's Avatar
    Try a restart:

    Press and HOLD both Vol Up/Down buttons. Keep holding while the screen goes fully black (ignore the screenshot), keep holding through the Black/White logo and when the Colored Logo shows up, release those buttons.

    If you have the STL100-1 variant the volume button reset method doesn't work. In that case, Press and HOLD the Power On Button until you see the LOGO as above
    Thanks... I did the hard reset as you guided me but nothing worked....

    Posted via CB10
    07-08-14 10:37 AM
  6. vrud's Avatar
    Do you have a screen protector? I once had glass protector on my z10 and it blocked the light.

    Posted via CB10
    07-08-14 10:51 AM
  7. zozo1980's Avatar
    Do you have a screen protector? I once had glass protector on my z10 and it blocked the light.

    Posted via CB10
    Yes I have a tempered glass protector on my screen... but the sensor works fine with viber!!! then why it is not working with calls??? It's really weird....

    Posted via CB10
    07-08-14 11:07 AM
  8. vrud's Avatar
    The glass blocks partial light and the OS will not detect light change. It was annoying for me so I had to get rid of the glass. Other apps might have different light level thresholds than built-in phone.

    Posted via CB10
    zozo1980 likes this.
    07-08-14 11:12 AM
  9. ArmedHitman's Avatar
    Another App might be blocking functionality of the sensor because that app is using it. An app must be interfering with the sensor, viber just overrides it because its an Android port.
    07-08-14 12:38 PM
  10. zozo1980's Avatar
    Another App might be blocking functionality of the sensor because that app is using it. An app must be interfering with the sensor, viber just overrides it because its an Android port.
    Maybe you are right.... I don't know... it works well with everything else...

    Posted via CB10
    07-08-14 01:00 PM
  11. Jeroen Vos's Avatar
    Had the same problem once. Restore did the trick.


    Posted via CB10
    zozo1980 likes this.
    07-09-14 04:56 PM
  12. wasalph's Avatar
    Had the same problem once. Restore did the trick.

    Posted via CB10
    Hi i have similar problem, before i do the wipe/restore which will take hours, would like to know if you also have those tempered glass blocking the sensors?

    Z10 10.2.1.2977
    07-18-14 05:47 PM
  13. FF22's Avatar
    Hi i have similar problem, before i do the wipe/restore which will take hours, would like to know if you also have those tempered glass blocking the sensors?

    Z10 10.2.1.2977
    There have been a few threads that glass screen protectors that cover the sensor's port can affect or disable the proximity sensor. Other screen protectors that cover it might also cause problems but I'm not sure. The one I got from Verizon has cut-outs for the various "stuff" at the top edge of the screen.
    07-18-14 06:29 PM
  14. zozo1980's Avatar
    I have a tempered glass protector but the sensor works fine in viber and even in any other apps!!!

    Posted via my awesome Z10 STL100-3
    07-23-14 02:23 PM
  15. wasalph's Avatar
    I have a tempered glass protector but the sensor works fine in viber and even in any other apps!!!

    Posted via my awesome Z10 STL100-3
    I just installed a new tempered glass with the proper cutout on the front cam and proximity area, now its working fine. And the phone goes blank during calls

    Z10 STL-2 10.2.1.2977
    FF22 likes this.
    10-14-14 01:36 AM

Similar Threads

  1. Playbook is all slow motion.
    By whatsever in forum BlackBerry PlayBook OS
    Replies: 10
    Last Post: 09-01-14, 11:25 PM
  2. UDS iOS Workspace not reinstallable
    By bb42 in forum BES 10
    Replies: 1
    Last Post: 07-08-14, 10:45 AM
  3. Call Log not showing Dialled or received Numbers
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-08-14, 08:27 AM
LINK TO POST COPIED TO CLIPBOARD