1. aboldcurve's Avatar
    Just wanted to get some more experiences opinions on this issue. When I first got my z10, I keep running into an issue where my phone would brick. Not even the led light would ignite when it was plugged in with no charger. Within two months I had it replaced 3x with (no leaked os, ported apps, etc at the time.) Just recently had one do the same thing. Except this was just on the .1925 leak. My phone would not turn on and this time the red led would ignite when I had it plugged in with no battery. Whenever this happens I switch my batteries, switched cables, and even try reloading the os. Luckily I purchased the insurance...otherwise I'd be hating blackberry. Any ideas as to why this is happening? I also plug my charger into a surge protector, js

    Posted via the Android CrackBerry App!
    Last edited by aboldcurve; 01-18-14 at 04:24 PM.
    01-18-14 03:02 PM
  2. obaquerizo's Avatar
    what can i tell you had a problem with a z10 that with the battery that came with the phone it turns on, if i change the battery will never turn on. why a mistery i can tell you, hopefully i was able to make the change of device and haven┤t get any problem again, but haven┤t know the real deal of it, every device no matter the brand can have issue, i buy my daugther in iphone 5s, after a week had to change it because lost signal issues
    01-18-14 03:09 PM
  3. anon721037's Avatar
    Are you sure you downloaded the proper file for your phone. Make sure bb link is closed when you run the autoloader. Try loading the os again and when you start the autoloader if it does not start automatically hold the power button down until it starts.

    Posted with the almighty Z30 using 10.2.1.1925 and the 1926 radio looking for a bird to BBQ
    01-18-14 03:15 PM
  4. aboldcurve's Avatar
    I have 3 different batteries I use, whenever this happens that's the first thing I try is swapping batteries. At first I thought this was something from a surge but my charger is in a surge protector

    Posted via the Android CrackBerry App!
    01-18-14 03:17 PM
  5. aboldcurve's Avatar
    Are you sure you downloaded the proper file for your phone. Make sure bb link is closed when you run the autoloader. Try loading the os again and when you start the autoloader if it does not start automatically hold the power button down until it starts.

    Posted with the almighty Z30 using 10.2.1.1925 and the 1926 radio looking for a bird to BBQ
    Yeah when this first happened I was using stock is, this time I was running a 1925 built for the stl-4 which I had of course.

    Posted via the Android CrackBerry App!
    01-18-14 03:18 PM
  6. serbanescu's Avatar
    Just a shot in the dark: are you sometimes wearing clothes that are producing a lot of static electricity? I had some clothes that were charging so high that I was getting powerful jolts when touching metal objects like the sink battery.

    Maybe the static electricity is frying your phone.


    --------------------

    Pic Tagger for BB10 and PlayBook
    01-18-14 03:27 PM
  7. anon721037's Avatar
    you know if u had an iphone you wouldn't be on your 4th phone.
    You only need one
    Ya but then he wouldn't have a good phone he would be like all the other iPhone drones.

    Posted with the almighty Z30 using 10.2.1.1925 and the 1926 radio looking for a bird to BBQ
    01-18-14 03:33 PM
  8. aboldcurve's Avatar
    you know if u had an iphone you wouldn't be on your 4th phone.
    You only need one
    IPhones suck, bro

    Posted via the Android CrackBerry App!
    anon721037 and kthhrrsn like this.
    01-18-14 03:34 PM
  9. aboldcurve's Avatar
    Just a shot in the dark: are you sometimes wearing clothes that are producing a lot of static electricity? I had some clothes that were charging so high that I was getting powerful jolts when touching metal objects like the sink battery.

    Maybe the static electricity is frying your phone.


    --------------------

    Pic Tagger for BB10 and PlayBook
    Besides the first three times I had kept my phone in a case with rubber in it. It is winter in new england so I stay layered but Idk I guess that could be it

    Posted via the Android CrackBerry App!
    01-18-14 03:35 PM
  10. serbanescu's Avatar
    Besides the first three times I had kept my phone in a case with rubber in it. It is winter in new england so I stay layered but Idk I guess that could be it

    Posted via the Android CrackBerry App!
    Static electricity as a cause it's only a hypothesis, but if it was involved, the rubber case would not protect the phone because the buttons are metallic.


    --------------------

    Pic Tagger for BB10 and PlayBook
    01-18-14 03:42 PM
  11. aboldcurve's Avatar
    I'm really thrown off by this, I don't know what I'm doing wrong!

    Posted via the Android CrackBerry App!
    01-18-14 03:48 PM
  12. anon721037's Avatar
    Some people have said here that there batteries were loose and had to put a piece of paper or something in to tighten up so the contacts made better connections.

    Posted with the almighty Z30 using 10.2.1.1925 and the 1926 radio looking for a bird to BBQ
    01-18-14 03:50 PM
  13. Grumblegrumble's Avatar
    Im sorry if you have answered this already,

    but what kind of case? Are you in a high humidity area?
    01-18-14 03:58 PM
  14. SparkyBC's Avatar
    Get a new sim...
    01-18-14 04:05 PM
  15. aboldcurve's Avatar
    Im sorry if you have answered this already,

    but what kind of case? Are you in a high humidity area?
    I bought it at a kiosk its nothing special, I go between that and the leather holster. And no I'm in the dead of winter in new england.

    Posted via the Android CrackBerry App!
    01-18-14 04:13 PM
  16. ablefunzo's Avatar
    I think how we use any electronic matters, I have been using mine for ten months and have had no issues whatsoever. I have not loaded any leaks or sideloads.


    Posted via CB10
    01-18-14 04:18 PM
  17. John Timothy's Avatar
    The reason for the Iphone issue is that they started using a garbage antenna (unlike the Z30) , and a lot of new Iphone users have complained about this. So the moral of the story is that every phone brand has issues from time to time! So stop bashing BB, and stop being an Isheep!
    01-18-14 04:20 PM
  18. aboldcurve's Avatar
    I think how we use any electronic matters, I have been using mine for ten months and have had no issues whatsoever. I have not loaded any leaks or sideloads.


    Posted via CB10
    With what just happened recently I only had the 1925 leak. When the first 3x occurred I was running stock os, no side loaded apps. I use my phone for texting and twitter. That's it.

    Posted via the Android CrackBerry App!
    01-18-14 04:22 PM
  19. aboldcurve's Avatar
    Get a new sim...
    How does that make a difference?

    Posted via the Android CrackBerry App!
    01-18-14 04:23 PM
  20. anon(4044683)'s Avatar
    Can you send it back to BlackBerry? BBRY looted on the Z10 pricing it so high for loyal and early adopters. Though my Z10 is great (touch wood), I still hear a lot of people complaining about the Z10 here in CB. Now I will think twice before I buy a BlackBerry or wait for the fire sale.
    01-18-14 07:12 PM
  21. aboldcurve's Avatar
    Can you send it back to BlackBerry? BBRY looted on the Z10 pricing it so high for loyal and early adopters. Though my Z10 is great (touch wood), I still hear a lot of people complaining about the Z10 here in CB. Now I will think twice before I buy a BlackBerry or wait for the fire sale.
    I'm in the us so we didn't get it right away but when I did I had to get it replaced 3x for the same issue. Pretty frustrating, however I still will be sticking with blackberry. Even if I didn't have it insured the manufacturer warranty would've covered it

    Posted via the Android CrackBerry App!
    01-18-14 07:24 PM
  22. Ftov72's Avatar
    Just a shot in the dark but are u shutting down the device before switching batteries because I've read that the z10 needs to be shut down every time before removing the Battery.
    01-18-14 07:25 PM
  23. aboldcurve's Avatar
    Just a shot in the dark but are u shutting down the device before switching batteries because I've read that the z10 needs to be shut down every time before removing the Battery.
    Well I only think to swap the battery after my phone won't turn on so ya I do..but I would never just rip the battery out while it's on. That can't be good for any phone..

    Posted via the Android CrackBerry App!
    01-18-14 08:11 PM
  24. kthhrrsn's Avatar
    Just wanted to get some more experiences opinions on this issue. When I first got my z10, I keep running into an issue where my phone would brick. Not even the led light would ignite when it was plugged in with no charger. Within two months I had it replaced 3x with (no leaked os, ported apps, etc at the time.) Just recently had one do the same thing. Except this was just on the .1925 leak. My phone would not turn on and this time the red led would ignite when I had it plugged in with no battery. Whenever this happens I switch my batteries, switched cables, and even try reloading the os. Luckily I purchased the insurance...otherwise I'd be hating blackberry. Any ideas as to why this is happening? I also plug my charger into a surge protector, js

    Posted via the Android CrackBerry App!
    I too am on my 4th Z10. The last brick was my fault.

    Got a good rep once (at&t) and he replaced everything for me:

    Phone
    Battery
    Sim card

    He said that something wasn't playing nice with my phone & as a precaution, he replaced it all. Everyone else replaced the device but put my old battery & sim card back in. If one of those caused the problem, it could happen again.

    So far, after more than 3 months, I seem to have a winner. I also threw out the cheap car charger that I found on Amazon for like a dollar & bought one from the shop.

    Try this & good luck.

    Keith H. Posted via CB10 on Z10.
    01-19-14 08:21 AM
  25. aboldcurve's Avatar
    I too am on my 4th Z10. The last brick was my fault.

    Got a good rep once (at&t) and he replaced everything for me:

    Phone
    Battery
    Sim card

    He said that something wasn't playing nice with my phone & as a precaution, he replaced it all. Everyone else replaced the device but put my old battery & sim card back in. If one of those caused the problem, it could happen again.

    So far, after more than 3 months, I seem to have a winner. I also threw out the cheap car charger that I found on Amazon for like a dollar & bought one from the shop.

    Try this & good luck.

    Keith H. Posted via CB10 on Z10.
    Thanks will do, I think the only thing I can try at this point is to switch my Sim card. I used to the provided charger and even had a brand new battery sent it. And my phone still wouldn't turn on just a few days ago. I appreciate the info

    Posted via the Android CrackBerry App!
    01-19-14 12:44 PM

Similar Threads

  1. Help pinpoint battery hog on my phone
    By zenzi2014 in forum BlackBerry Z30
    Replies: 14
    Last Post: 01-19-14, 07:57 PM
  2. iPhone 5S battery life vs Z10 battery life?
    By 2Peks1Bird in forum BlackBerry Z10
    Replies: 23
    Last Post: 01-19-14, 05:59 PM
  3. Help needed to explore files on my Z10
    By MultiDoc in forum BlackBerry Z10
    Replies: 4
    Last Post: 01-18-14, 05:31 PM
  4. I want the Silver Guitar Frets on the dial pad too
    By IJKBB10 in forum BlackBerry Z10
    Replies: 5
    Last Post: 01-18-14, 03:05 PM
LINK TO POST COPIED TO CLIPBOARD