1. el-bucho's Avatar
    BlackBerry Link and Blend can't detect my phone while using various usb cables but can do so when I connect via wifi. I'm trying to backup my phone so that I update the os via sachesi
    09-20-15 03:15 PM
  2. BB-JAM215's Avatar
    You didn't say exactly what happens when you connect via USB cable or whether you're using a PC or a Mac and which OS.
    09-20-15 04:12 PM
  3. el-bucho's Avatar
    I'm using a pc. Link shows that my device is disconnected
    09-21-15 03:19 AM
  4. el-bucho's Avatar
    I can access my sd card on my laptop if I allow usb mass storage mode
    09-21-15 03:20 AM
  5. BB-JAM215's Avatar
    Sounds like a problem with the BlackBerry Device Manager. Do you get a small pop-up window in the lower right corner of your screen when you plug in your phone?

    Which version of Link are you using? (In Link click on Preferences in the upper right hand corner, next to Help, and choose About)
    09-21-15 10:42 AM
  6. el-bucho's Avatar
    No popup. BlackBerry Link version is 1.2.4.39
    09-22-15 01:04 AM
  7. BB-JAM215's Avatar
    Are you sure you have 1.2.4.37? I have 1.2.3.48 and I thought the latest version was 1.2.3.56. If you didn't install it recently, I suggest you update Link and the Drivers to the latest versions: http://swdownloads.blackberry.com/Downloads/
    Last edited by BB-JAM215; 09-22-15 at 01:33 AM.
    09-22-15 01:21 AM
  8. el-bucho's Avatar
    There you go. Says 1.2.4.39
    Link connectivity issues-img_20150922_084759.jpg
    Last edited by el-bucho; 09-22-15 at 04:38 AM.
    09-22-15 01:48 AM
  9. BB-JAM215's Avatar
    Nice to see that BlackBerry seems to regularly updating Link even if having "Automatically download updates" doesn't seem to work for my version of Link."

    What version of Windows are you running? I suggest you use the Windows Programs and Features Control Panel to uninstall Link and do a complete new installation from the BlackBerry website, although 1.2.4.39 appears be the latest version as of June 2015.
    kbz1960 likes this.
    09-22-15 11:29 AM
  10. el-bucho's Avatar
    Win 7 professional. I've tried uninstalling and reinstalling it but witthe same results
    09-23-15 02:48 AM
  11. BB-JAM215's Avatar
    1.2.3.48 works for me with Windows 7 Home Premium. I'm going with "if it ain't broke don't fix it" approach at this point.

    I see you can still download 1.2.3.56 from BlackBerry. It might be worth a try: https://swdownloads.blackberry.com/D...0E31AF7485EE07
    Leonatthebeach likes this.
    09-23-15 10:53 AM
  12. el-bucho's Avatar
    Thanks. I'll download it in the evening and tell you how it goes
    09-24-15 07:04 AM
  13. el-bucho's Avatar
    That didn't work either. I tried it on my friend's pc and it still didn't work but link on his pc recognised his z30. Could it be a problem with the phone
    09-26-15 03:02 AM

Similar Threads

  1. Touch screen issue.
    By shawnreum in forum BlackBerry Passport
    Replies: 18
    Last Post: 09-27-15, 07:44 AM
  2. Replies: 4
    Last Post: 09-24-15, 08:13 AM
  3. Replies: 5
    Last Post: 09-21-15, 09:31 PM
  4. Stereotube download link stopped working?
    By The_Passporter in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 09-21-15, 12:08 PM
  5. Snap issues
    By kitsos in forum BlackBerry Classic
    Replies: 3
    Last Post: 09-19-15, 04:22 PM
LINK TO POST COPIED TO CLIPBOARD