12-31-13 07:26 PM
26 12
tools
  1. RonBHolmes2nd's Avatar
    I'm suddenly having trouble connecting my Z10 to my home network. I've had my Zed since day one in Canada and have had no issues until last night.

    I did a security wipe on my device because of a storage issue. This fixed one problem but for what ever reason I've been unable to access the Internet through my home network ever since.

    Nothing has changed with the network. All other devices are working fine including my wife's BlackBerry. I've added, deleted and added the network a few times but get the same problem over and over.
    Limited WiFi on home network-img_00000002.png
    Just curious if anyone else has experienced this and/or knows how to resolve this.

    Thanks

    Posted via CB10
    07-10-13 09:27 PM
  2. diegonei's Avatar
    Yes. This always happens when my internet goes down. The router keeps broadcasting a dead signal. The Z10, my PlayBook and my PC all warn me of limited signal. I can still do wifi transfers but I can't access the internet.

    May be time to nag your ISP.
    07-10-13 09:34 PM
  3. RonBHolmes2nd's Avatar
    Thanks. My Internet did go down today but it has been up and running for hours now. Do you have to do anything to get your Z10 to reconnect or is it a matter of just waiting it out?

    Posted via CB10
    07-10-13 09:39 PM
  4. RADEoN1337's Avatar
    You could try resetting the phone, but I'd actually start by power cycling the router.

    Posted via CB10
    07-10-13 09:40 PM
  5. MGDania's Avatar
    Try deleting the saved wife connection and then re connect.

    Posted via CB10
    07-10-13 09:45 PM
  6. RonBHolmes2nd's Avatar
    Thanks guys. I've tried all these things. Nothing is working..... yet

    Posted via CB10
    07-10-13 10:14 PM
  7. bgregory902's Avatar
    Is it disabled on your phone? If not unplug your router for a minute or two and plug it back in. You may have too much hooked up to it for it to handle. Try only connecting one thing at a time.

    Posted via CB10
    07-10-13 10:55 PM
  8. trsbbs's Avatar
    Reboot the DSL/cable modem.

    Reboot the router.

    Change the frequency/channel on the router.

    Reboot the phone.

    If using N try G.

    Hope you get it cleared up.



    Using a BlackBerry Z10
    07-10-13 11:05 PM
  9. jscaroo's Avatar
    Every time I install the Os I have to delete and reconnect. Once I had to enable under settings.

    Posted via CB10
    07-10-13 11:07 PM
  10. jscaroo's Avatar
    Oh misread. Sorry. Hmmmm?


    Posted via CB10
    07-10-13 11:07 PM
  11. RonBHolmes2nd's Avatar
    Thanks for your help everyone. I still haven't fixed this problem but I'll take all your advice and get this solved tonight.

    I am glad to say my Z10 is connecting to other networks no problem this morning so it's not an issue with my awesome BlackBerry

    Posted via CB10
    07-11-13 07:37 AM
  12. Sergeant_Im's Avatar
    I still have this problem on my Z10 and no matter what people suggest, they're only workarounds and not permanent fix.

    My Z10 can connect to my router's WIFI and able to browse internet at first, but after a some times (usually after an hour or so - it varies), the internet connection will drop. The phone is still connected to the WIFI network, just no internet. IP is correct (192.168.x.x).

    Rebooting the modem will fix this temporarily, but it will still occur in the next hours. This does not occur to any other devices in my home.
    I have tried all suggestions but that doesn't seem to fix. The only thing I haven't tried is changing the security from WEP to WPA, not sure if it makes any difference.

    My router model is D-link DSL-2730E. I don't have a spare router to test though.

    I'm also using OpenDNS if that helps.

    The difference between mine and OP is that I find the 'BlackBerry logo' also gone from the top bar.
    Attachment 192487
    Last edited by Sergeant_Im; 08-14-13 at 02:02 PM.
    08-14-13 01:28 PM
  13. GTVictor's Avatar
    I found with my Playbook that it would never maintain the connection. The wifi was added manually, typing in the password, etc.It would be a near daily task to un-disable the WiFi.

    Then I deleted the connection and added it via the automated WPS button and now I've gone months without losing the connection. So when I added my Z10 I did it the same way and no problems.
    08-14-13 04:42 PM
  14. niftymu's Avatar
    I would recommend trying the fix of changing your WiFi password from WEP encryption to WPA like another user stated. I also had this "limited WiFi" issue, and doing that fixed things for me at two locations.

    Posted via CB10
    08-14-13 05:50 PM
  15. talberry's Avatar
    I think this would have to do more with the wifi and modem itself rather than the phone right?

    Posted via CB10
    08-14-13 09:34 PM
  16. sarajane82's Avatar
    I have the same problem and mine is already WPA...restarting the router, modem, deleting the network /re-entering password, all of these work temporarily but it's a daily struggle. No other devices in my home have an issue. It's gotten to where I'm considering just selling the phone on ebay and going back to Apple. Someone please help so I don't have to do that!

    Posted via CB10
    08-20-13 08:52 PM
  17. zack west's Avatar
    No balls... you won't go back to apple.

    Q10SQN100-5/10.2.1.1259
    12-30-13 09:30 PM
  18. prithvi64's Avatar
    I too get similar message quite often from my home wifi router. Sometime after resetting router, it gets connected and some time, just by switching off and on from device helps in reconnection.
    12-30-13 09:36 PM
  19. prithvi64's Avatar
    the same problem have been on samsung and apple devices too. some time, these get connected and some time not. So changing the device doesn't provide you any relief.
    12-30-13 09:37 PM
  20. Deadmunny's Avatar
    I thought I was the only one....but I "think" it is my ISP I only have to toggle off and on the wifi on my z10 and am instantly back on to my home network....however the odd thing is it shows connected on my device? .....

    Z10 / 10.2.1.537
    12-30-13 09:53 PM
  21. BB30000's Avatar
    I've had this for a few months now. Have tried close to everything, thought the wire was the issue, thought the IP, Windows 8.1, router itself, but still comes up every few days and the only temporary solution is to unplug the router and plug it back in. There has to be a simple solution!

    Via The BlackBerry Z10 Experience.
    12-30-13 10:02 PM
  22. lord_hibiskus's Avatar
    I've had this for a few months now. Have tried close to everything, thought the wire was the issue, thought the IP, Windows 8.1, router itself, but still comes up every few days and the only temporary solution is to unplug the router and plug it back in. There has to be a simple solution!

    Via The BlackBerry Z10 Experience.
    Change router settings, universal solution is to change mode to b/g instead of b/g/n mode. Apparently there is some issue with bb10 and n wireless mode on some routers

    Posted via CB10
    12-31-13 03:23 AM
  23. Paisley Pirate's Avatar
    One other thing to check: If you have an older cable modem that is not using the latest DOCSYS revision, it may be that the ISP is causing the problem.
    Reason: The later revisions are "backwards compatible" - meaning that a 1.x modem will work on a 3.x system... however, if the system (their end, not your end) switches the modems around a bunch, it could switch you to one of the channels that 1.x can't see, but a 2.x or 3.x can. This will give you limited connectivity to the internet, but full wifi.
    I had an older PC that was very sensitive to it (running XP SP3) but my main desktop, running Win7, just hiccuped for a second, and came right back in, as the modem changed it's handshake with the ISP. It took some noodling through to figure out why I was losing internet, but still showing connection, I went 3 levels deep in tech support before we finally jointly figured out what was happening, with me watching my end while on the telephone with the tech watching on their end.

    It's not supposed to happen like that... but it does, according to the tech guy at my ISP and my personal experience. (and he said it's not that uncommon). And if the Z10 is touchy about it, it may take a delete and reset of the connection to get it to settle back down.

    SO one more thing to take a look at.
    12-31-13 03:37 AM
  24. bbinburlington's Avatar
    I had this exact problem as well. When I did an update for a maintenance release about 6 months ago it would no longer connect to my home network (which I did the update on). My Z10 would connect to all other networks except for my home network. All other devices would connect to the network without a problem.

    I tried resetting all the settings on my phone and router but no success.

    I am with Rogers and they provided some troubleshooting ideas but without success. The BlackBerry.com support forum also gave me ways to try to fix the problem. Through one thread/idea I could connect to the network briefly (about 15 seconds) but then it would disconnect again. This series of ideas was quite technical, but easy to follow. I can send you the link to that thread if you like.

    In the end I just ended up buying a new router and I am fully functional again.

    Sorry I can't be if more help but I had the same problem. Let me know if you want the link to the thread on BlackBerry.com.

    Cheers,
    Paul

    Posted via CB10
    12-31-13 10:06 AM
  25. scrannel's Avatar
    Had this issue a while back. Doing a factory (paper clip) reset of router + firmware update cured whole issue.
    12-31-13 12:32 PM
26 12

Similar Threads

  1. How to change the memory card reader on curve 8520
    By Poliakos Daniel in forum BlackBerry Curve Series
    Replies: 3
    Last Post: 07-13-13, 08:58 PM
  2. Installing Android Apps on 2 separate Blackberry Z10 devices
    By doink726 in forum More for your BlackBerry 10 Phone!
    Replies: 6
    Last Post: 07-11-13, 08:52 AM
  3. Unable to configure work email account on my bold 9900
    By BigAssBitchin in forum BlackBerry Bold Series
    Replies: 2
    Last Post: 07-11-13, 01:56 AM
  4. Phones 4U giving up on the BlackBerry Z10??
    By nothingworks in forum BlackBerry Z10
    Replies: 11
    Last Post: 07-10-13, 10:41 PM
  5. Error setting up Evernote Account on Z10 "missing oauth_token"
    By southlander in forum BlackBerry 10 Apps
    Replies: 1
    Last Post: 07-10-13, 05:41 PM
LINK TO POST COPIED TO CLIPBOARD