1. Draven94's Avatar
    Hi guys, I have a problem with my new Z10. If I start a video recording, the camera doesn't take the focus when I change image. To take the focus I have to tap in the screen (when the registration has already begun). It seems that there isn't automatic adaptation. Is it normal or my device has some problems?
    02-08-14 07:09 AM
  2. jaydee5799's Avatar
    It is definitely your device as mine focuses automatically when I change what I am seeing through the viewfinder. What OS do you have on your phone?
    02-08-14 08:11 AM
  3. Draven94's Avatar
    My Z10 has 10.2.1 (latest upgrade).
    The situation is this: when I start a video recording of an object (for example 10 ft from me) the viewfinder from white becomes green. I tap the screen to start the rec. But if in this recording I want to rec an other object (for example 30 cm from me) the viewfinder is always green and the focus doesn't change. I have to tap on the viewfinder and move it to take the new focus. I think there isn't automatic adaptation. I don't know if this is a normal feature (manual adaptation trough viewfinder) or if my device has some problems...
    02-08-14 08:37 AM
  4. Sam Rosu1's Avatar
    2 things I've noticed, 1: make sure that the lens and flash area are clean... 2: in the upper left corner you will see a shake reduction icon, if you leave this on it seems the lcd display doesn't seem to update... check your recorded image to see if it recorded in focus... mine displays out of focus but playback is perfect. With the shake reduction off it updates on the fly.

    Posted via CB10
    02-08-14 08:49 AM
  5. cesarpq's Avatar
    i remember this was happening to me when i install the leak camera app with the face recognition, there was no way to focus anything, but a restart use to work for me, try a restart, if if works maybe you should try reinstall the camera app or something, if it doesnt work you should try to make sure it isnt a hardware issue.
    02-08-14 09:58 AM
  6. Draven94's Avatar
    2 things I've noticed, 1: make sure that the lens and flash area are clean... 2: in the upper left corner you will see a shake reduction icon, if you leave this on it seems the lcd display doesn't seem to update... check your recorded image to see if it recorded in focus... mine displays out of focus but playback is perfect. With the shake reduction off it updates on the fly.

    Posted via CB10
    I tried but no luck
    02-08-14 10:57 AM
  7. Draven94's Avatar
    i remember this was happening to me when i install the leak camera app with the face recognition, there was no way to focus anything, but a restart use to work for me, try a restart, if if works maybe you should try reinstall the camera app or something, if it doesnt work you should try to make sure it isnt a hardware issue.
    The focus works well but during video registration it doesn't update on the fly (automatic adaptation) but the update is only in "manual mode". So I don't think it's a hardware problem but software problem.
    02-08-14 11:00 AM
  8. wasalph's Avatar
    Hi guys, I have a problem with my new Z10. If I start a video recording, the camera doesn't take the focus when I change image. To take the focus I have to tap in the screen (when the registration has already begun). It seems that there isn't automatic adaptation. Is it normal or my device has some problems?
    I didnt notice my z10 with the latest 10.2.1 also has this problem until i read your poat and tried it

    Z10 10.2.1.1925
    02-08-14 11:07 AM
  9. PatrickMJS's Avatar
    The auto-focus works exactly as expected on my Z10 when recording video. The little square focus box become green a second after I hold camera pointed at something nearby, then as I point the camera at something further away, the focus box becomes white, then green as soon as it refocuses on the new subject.

    I have mine set to record at 1080p and, wow, the videos sure look good on the bigscreen!

    Posted via CB10
    02-08-14 11:27 AM
  10. Draven94's Avatar
    The auto-focus works exactly as expected on my Z10 when recording video. The little square focus box become green a second after I hold camera pointed at something nearby, then as I point the camera at something further away, the focus box becomes white, then green as soon as it refocuses on the new subject.

    I have mine set to record at 1080p and, wow, the videos sure look good on the bigscreen!

    Posted via CB10
    In my case the box focus is always green, the adaptation from white to green when I change subject doesn't work on the fly
    02-08-14 11:35 AM
  11. Draven94's Avatar
    I didnt notice my z10 with the latest 10.2.1 also has this problem until i read your poat and tried it

    Z10 10.2.1.1925
    I updated my Z10 to 10.2.1 version the day after purchase (one week ago), so I don't know how to work the camera in the old release/firmware.
    02-08-14 11:39 AM
  12. BBstarBB's Avatar
    I Have the same problem after the OS update 10.2.1.537 thru Sasktel carrier. My BB Z30 will not refocus when video recording in 1080p
    The green "square" doesn't turn white to refocus on another object. It is always green.
    The funny thing is that , when you don't star video recording the auto focus works. ie. the green square turns white and vise versa.

    In my case the box focus is always green, the adaptation from white to green when I change subject doesn't work on the fly
    02-10-14 01:11 PM
  13. rtang1007's Avatar
    Hi guys, I have a problem with my new Z10. If I start a video recording, the camera doesn't take the focus when I change image. To take the focus I have to tap in the screen (when the registration has already begun). It seems that there isn't automatic adaptation. Is it normal or my device has some problems?
    I have never experienced such thing on my Z10 since I own it (ten months so far). The auto-focus of video recording works all the time regardless of what version of OS I am running on (currently 10.2.1.1925). I always pinch the focus (zoom in and zoom out) when recording. It auto-focuses no matter how frequently I zoom in and out. If your camera still has trouble taking the focus, you may try pinching the focus when recording to see if the lens can pick up focus properly.
    PatrickMJS likes this.
    02-10-14 01:28 PM
  14. Draven94's Avatar
    I Have the same problem after the OS update 10.2.1.537 thru Sasktel carrier. My BB Z30 will not refocus when video recording in 1080p
    The green "square" doesn't turn white to refocus on another object. It is always green.
    The funny thing is that , when you don't star video recording the auto focus works. ie. the green square turns white and vise versa.
    Yes, the same problem also when I do a video in 720p
    In other forum they told me the problem may be the apps permissions
    02-10-14 06:07 PM
  15. Draven94's Avatar
    I have never experienced such thing on my Z10 since I own it (ten months so far). The auto-focus of video recording works all the time regardless of what version of OS I am running on (currently 10.2.1.1925). I always pinch the focus (zoom in and zoom out) when recording. It auto-focuses no matter how frequently I zoom in and out. If your camera still has trouble taking the focus, you may try pinching the focus when recording to see if the lens can pick up focus properly.
    I think it's a software issue because the refocus (manual mode) and pinching work well.
    02-10-14 06:10 PM
  16. Nharzhool's Avatar
    It's not app permissions. The camera app is most likely buggering around. I've had this on a previous version of the camera app. I just reinstalled the camera app.

    For this, you need the BlackBerry PlayBook App Manager plug in for Google Chrome on a PC or Mac and a copy of the camera app file...which I will see if I can get for you tomorrow.
    Put you phone into development mode by opening settings>Security and Privacy>Development Mode.
    Turn it on, choose a password and note the IP listed there.
    Connect the phone via USB or Wi-Fi works as well.
    Open the PlayBook App Manager Extension.
    Type the IP of the phone...most likely 169.254.0.1 and click save
    Then click on that IP listed below
    Click continue anyway on the security warning
    Type in the password you put.
    Now you need to drag the camera app file into the top right corner of the webpage and release.
    It should start installing the new camera app.
    When it is done, disconnect and restart your phone.
    Hopefully, all is sorted.

    Mmm...CB10! Just the tip though...
    02-10-14 06:37 PM
  17. Draven94's Avatar
    Thanks for reply and explanation. I wait for camera bar file.

    sent using BlackBerry Z10
    02-10-14 07:22 PM
  18. wasalph's Avatar
    Thanks for reply and explanation. I wait for camera bar file.

    sent using BlackBerry Z10
    Waiting too....

    Z10 10.2.1.1925
    02-10-14 09:09 PM
  19. arrowz's Avatar
    Hi guys, I have a problem with my new Z10. If I start a video recording, the camera doesn't take the focus when I change image. To take the focus I have to tap in the screen (when the registration has already begun). It seems that there isn't automatic adaptation. Is it normal or my device has some problems?
    me too, after start recording, just move the green box to focus.

    CB10 with Z10STL100-1/10.2.1.1925
    02-13-14 09:01 PM
  20. JustAnotherBeerbot's Avatar
    The video camera on 10.2.1 purposely is applying a focus lock all the time when recording starts. You can still drag the focus box around in order to cause it to refocus during a video. This is in contrast to the constant refocusing behaviour which some people may find distracting in a video recording (but is find during still capture).

    Out of curiosity, how would you guys rather see it work? Would you rather have the older re-focusing behaviour, but with the ability to long-press to lock it? I think the problem may be that a lot of people did not discover the lock feature.
    03-03-14 07:46 PM
  21. Draven94's Avatar
    The video camera on 10.2.1 purposely is applying a focus lock all the time when recording starts. You can still drag the focus box around in order to cause it to refocus during a video. This is in contrast to the constant refocusing behaviour which some people may find distracting in a video recording (but is find during still capture).

    Out of curiosity, how would you guys rather see it work? Would you rather have the older re-focusing behaviour, but with the ability to long-press to lock it? I think the problem may be that a lot of people did not discover the lock feature.
    I prefer the old function (re-focusing and manually focus lock) and...I hope for a manually setting (ISO, exposure's time,...)

    Posted via CB10 || BlackBerry Z10
    03-04-14 01:59 PM
  22. mage_ca's Avatar
    My issue is not the autolock but that the focus doesn't work at all. Neither in the camera or video mode. It will not do a focus of any kind regardless of dragging the box, locking the box or any of the above suggestions. Since the last update, there is NO focusing at all. It doesn't even try.
    06-26-14 04:47 PM
  23. FF22's Avatar
    My issue is not the autolock but that the focus doesn't work at all. Neither in the camera or video mode. It will not do a focus of any kind regardless of dragging the box, locking the box or any of the above suggestions. Since the last update, there is NO focusing at all. It doesn't even try.
    I guess as a test, although time-consuming, would be to roll back to the earlier OS. Also, some folks have loaded older camera bar files - a bit more complex in finding just the camera bar file. Or you could try loading the newest OS which was officially released today for some carriers and is available.
    06-26-14 08:12 PM

Similar Threads

  1. Camera not starting
    By terahlundeba in forum BlackBerry Q5
    Replies: 12
    Last Post: 06-25-14, 05:18 PM
  2. Qualcomm 800 or 805 for BB Ontario & Wndermere?
    By BBPandy in forum General BlackBerry News, Discussion & Rumors
    Replies: 39
    Last Post: 02-11-14, 04:33 AM
  3. BlackBerry Z10 shuts down at 50% power
    By Eslam Maher in forum BlackBerry Z10
    Replies: 6
    Last Post: 02-10-14, 10:58 AM
  4. BBM with channels update Z10!
    By toc610 in forum General BlackBerry News, Discussion & Rumors
    Replies: 3
    Last Post: 02-08-14, 07:00 AM
  5. Camera app on 10.2.1
    By mvpcrossxover in forum BlackBerry Z10
    Replies: 3
    Last Post: 02-08-14, 03:48 AM
LINK TO POST COPIED TO CLIPBOARD