1. GTG007's Avatar
    When i Plug my iphone headset in z10, i hear static and music is like on and off.....seems iphone 5 headsets not compatible with z10 or my z10 headset jack is faulty..

    Anyone else had similar issues..
    If this is happening to lot of people, which headset you recommend me to buy...

    Thanks!
    04-17-13 12:19 PM
  2. Gnomesane's Avatar
    When i Plug my iphone headset in z10, i hear static and music is like on and off.....seems iphone 5 headsets not compatible with z10 or my z10 headset jack is faulty..

    Anyone else had similar issues..
    If this is happening to lot of people, which headset you recommend me to buy...

    Thanks!
    Shouldn't be an issue. Have you tried any other generic microjack headset / earplugs? If you have the same result, I'd suggest it's hardware, and take it to your carrier where you purchased and verify that so they can replace it.
    04-17-13 12:22 PM
  3. ripperj's Avatar
    I use my iPhone 5 ear buds all the time in my BlackBerry z10. They work fine including the volume.

    Via Z
    04-17-13 12:26 PM
  4. rtang1007's Avatar
    Are you sure you plugged into the jack all the way? If you plug in half way through, even the Z10 headset doesn't work. Sometimes, I plug in my iPhone 4 headset into my Z10 in case I forget to bring the Z10 headset. It works perfectly. I guess any headsets can be used with Z10.
    04-17-13 12:28 PM
  5. GTG007's Avatar
    I have only used with one iphone 5 headset...and sometimes it works fine and sometime i get static...
    headset works fine with laptops and iphone 5........I am having issues with headset only while plugging in z10, so thought may be Iphone 5 headsets and z10 jack are not compatible?
    04-17-13 12:29 PM
  6. GTG007's Avatar
    Are you sure you plugged into the jack all the way? If you plug in half way through, even the Z10 headset doesn't work. Sometimes, I plug in my iPhone 4 headset into my Z10 in case I forget to bring the Z10 headset. It works perfectly. I guess any headsets can be used with Z10.
    Yeah i plug headset all the way ....
    04-17-13 12:30 PM
  7. sager's Avatar
    It's working fine with me.

    Posted via CB10
    04-17-13 12:32 PM
  8. Gnomesane's Avatar
    Yeah i plug headset all the way ....
    Again, I'd try another set of micro-jack headsets just to verify it's an issue with the phone. If so, you should be able to easily replicate it at your carrier store and get it swapped out, I would think. Just tried my iPhone 4S earbuds and they work fine on the Z10.
    04-17-13 12:34 PM
  9. GTG007's Avatar
    Thanks everyone for replies and advice.
    Even when i plug in my headset and make no calls, no music and phone is in sleep mode...i still hear static...looks like my z10 is faulty...but will check few more headsets...
    04-17-13 12:41 PM
  10. GTG007's Avatar
    Quick Update Friends - I tried my colleague headset, he also have iphone 5 headset and worked nicely no static, when z10 on sleep mode...its strange though..why my iphone 5 headsets produce static, while they work fine with laptop and iphone 5...

    I might buy new headset and try..dont want to go through headache of exchanging bcz i bought z10 online from t-mobile......Thanks again everyone for help......
    Please let me know if anyone had similar strange thing..
    04-17-13 01:17 PM
  11. RubenDM's Avatar
    When i Plug my iphone headset in z10, i hear static and music is like on and off.....seems iphone 5 headsets not compatible with z10 or my z10 headset jack is faulty..

    Anyone else had similar issues..
    If this is happening to lot of people, which headset you recommend me to buy...

    Thanks!

    Iphones headphones didn't work on every bb i owned...
    Every other brand did.
    04-17-13 01:21 PM
  12. Gnomesane's Avatar
    Quick Update Friends - I tried my colleague headset, he also have iphone 5 headset and worked nicely no static, when z10 on sleep mode...its strange though..why my iphone 5 headsets produce static, while they work fine with laptop and iphone 5...

    I might buy new headset and try..dont want to go through headache of exchanging bcz i bought z10 online from t-mobile......Thanks again everyone for help......
    Please let me know if anyone had similar strange thing..
    Good to know. Thanks for the follow up! It's an APPLE CONSPIRACY, I tell ya... =)

    Seriously, that is strange. I would have thought any micro-jack headset would work the same as any other... ? Well, at least you don't have to go through the hassle of swapping out your phone. Cheers.
    04-17-13 01:24 PM
  13. GTG007's Avatar
    Iphones headphones didn't work on every bb i owned...
    Every other brand did.
    That makes me feel better bro...Thanks!..
    Most likely problem will be solved by buying another brand headset...
    04-17-13 01:24 PM
  14. RubenDM's Avatar
    one day i forgot mine , asked a friend to use them (iphone 4s earbuds). Did not work.
    a while ago i owned a iphone and a bb , again did not work , but did work with bb's earbuds...

    That makes me feel better bro...Thanks!..
    Most likely problem will be solved by buying another brand headset...
    04-18-13 09:27 AM

Similar Threads

  1. LED not working with my z10 profile
    By Double_J75 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 04-11-13, 06:43 PM
  2. bluetooth connection not working with headset ...
    By ceroberts75 in forum BlackBerry PlayBook
    Replies: 2
    Last Post: 04-24-11, 08:03 PM
  3. My Iphone headset doesnt work with the blackberry 9700
    By prettyboyian in forum BlackBerry Bold Series
    Replies: 10
    Last Post: 11-24-09, 08:16 PM
  4. Headset with answer call button will not work with Music
    By Mozygirl in forum BlackBerry Storm Series
    Replies: 8
    Last Post: 06-08-09, 07:00 PM
  5. Motorola S9 Headset does not work with Pearl... Nor Vista?
    By gibbs0828 in forum General BlackBerry News, Discussion & Rumors
    Replies: 8
    Last Post: 04-28-08, 01:47 PM
LINK TO POST COPIED TO CLIPBOARD