1. volatilestargazer's Avatar
    Every single Z10 I've had has died like this:

    The screen freezes and fades to black while I am doing a normal activity. Then, it refuses to come back on, but the LED light will flash very occasionally. Taking the battery in and out does nothing (although sometimes when I take the battery out, the LED light will come on for a few seconds, then it goes out). Taking the SIM card out does nothing. Plugging it in to the wall or the computer does nothing. When I try to factory-reset it, it will not let me because it thinks the phone is still on. Each time this has happened, I've had to take my phone to the Verizon store and get a new one.

    There is no reason for this to be happening. I never take my phone near water, I never drop it, and I have a case and screen protector on it. The Z10 is the best phone I have ever owned other than this. I've scoured CB forums and the rest of the internet for information on this problem but have found nothing. My mom has a Z10 as does one of my best friends and neither of them have ever had any problems with theirs. I'm very disheartened, as I have finally found a phone that I love, but I can't keep doing this over and over again.
    04-07-15 08:40 PM
  2. jaydee5799's Avatar
    I have a Z10 and used it for a year. Still own it. Never did anything like this.
    What OSes are you using? Is it something like an app...game, etc that you are putting on it?
    04-07-15 08:55 PM
  3. filanto's Avatar
    A jealous roommate maybe
    04-07-15 09:09 PM
  4. chaosdivine's Avatar
    I strongly suspect heat buildup from the rock hard/dried thermal paste against the CPU and the metal heat spreader in the phone. Anyone who has a Z10 KNOWS they get hot, real hot when the CPU is under serious load. When dried thermal paste occurs, air bubbles are created and that makes for non-continuous contact between the paste and the heat spreader leading to heat build up in the CPU and ultimately sudden death. That's just how it works...

    I suspect this is the case because I personally have cracked open my own phone and saw just how brutal it was (when I changed out my screen). I of course replaced my thermal paste with desktop quality CPU paste and have not had a problem and my phone never gets very warm since I changed mine out. I have ZERO proof that this is the case with any of your phones or that of anyone else suffering the same sudden death fate. But it would make the most logical guess for this to be the case.

    I have seen an awful lot of Z10 guts (the phone's insides) and every single one of them has had rock hard, grey chunky thermal paste (and an awful lot of it too by the way) around the CPU and against the heat spreader. That's all the protection this puppy has...and they used CRAPPY paste when manufacturing!
    moody and jabia like this.
    04-07-15 09:10 PM
  5. goodayeh's Avatar
    Have you by chance , attached your device to a TV via HDMI ?
    There are some devices that are functioning but cannot display on their own screen .
    If you plug it to BB Link is it recognized ?
    04-08-15 01:44 AM
  6. bob03sue's Avatar
    I have had my Z10 for over 2 years and it is perfect. 5th Z10 wow what have you been really doing to your phone?????

    Posted via CB10
    04-08-15 06:23 AM
  7. m3ach's Avatar
    Wow you have been unlucky, did you notice the phone getting warm before it died, what were you doing when it happened, was it the same thing on all occasions?

    Did you try and connect it to your computer without the battery in and reload the software?

    It does seem that you have just been very unlucky though, good luck with the fifth phone!

    Just another thought, have all the devices you have been given new or refurbished?

    Posted via CB10 using my Z10 STL100-2 /
    moody likes this.
    04-08-15 07:30 AM
  8. Michael Liang's Avatar
    If it is consistently happening like this, could it be your environment or the way you uses it?
    Do you place the phone near magnets, do you always put it on charger and run heavy loads on it (like videos or games)
    Just my thoughts

    Posted on my white Z10 via CB10
    04-08-15 07:33 AM
  9. moody's Avatar
    My Z30 screen will just go black while I'm using it. I haven't had it get hot as one poster described above. I have been fortunate that a press of the power button will bring it back.

    This is my second Z30 and it was a replacement meaning it was probably refurbished. What stinks is there was probably nothing actually wrong with my first one but I got it replaced under warranty thinking the antenna was bad.

    Anyway this is a known issue for sure w/ Z30 and BlackBerry is repairing/replacing under warranty for Z30 owners even if out of the warranty period. I am currently awaiting my paper work now as they have approved to replace mine even though at the present I can get it to come back on.

    With that said, if you can get in touch w/ BlackBerry warranty and respectfully report all you have been through you should do that. Then ask them to replace it w/ a brand new device not a refurbished one.

    I am almost 100% positive when consumers get "replacement" phones they are sent refurbished ones. I have been kicking myself for sending my original Z30 back b/c I can guarantee they sent me a refurbished. And I just done think it's possible to truly refurbish any cell phone and it turn out successful. Just my opinion.
    04-08-15 08:38 AM
  10. scrannel's Avatar
    Bad charger.
    CyberMan2013 likes this.
    04-08-15 10:01 AM
  11. volatilestargazer's Avatar
    I have the latest OS. On my old phones I've had several sideloaded apps but this time I'm going to try to go without them and see if that makes a difference.
    04-08-15 12:15 PM
  12. volatilestargazer's Avatar
    Nope, never. I do charge it a lot, but usually it's just overnight after the phone has run down for the day. I don't have any games but I did have a sideloaded app which could've been the problem.
    04-08-15 12:16 PM
  13. filanto's Avatar
    Get a new charger just to eliminate that as a possible culprit
    04-08-15 02:07 PM
  14. RubenDM's Avatar
    I got in the "same" situation few days ago.
    Suddenly went black, no possibility to boot it.
    Saw some led's flashing so i ran a autoloader and it fixed it.
    This happened after a OTA update on my z10 slt-100-2

    Posted via CB10
    04-08-15 03:24 PM
  15. mdmullis's Avatar
    For your next Z10 get a style 100-3 model and rock on with no issues.

    Michael in Atl

    Posted via CB10
    04-08-15 04:02 PM
  16. MRTTNS's Avatar
    I paid 750 USD (STL 100-1) September 2013 and it died December 2014. Motherboard issue. I believe I'm not the only one with this issue. Now bought another one for 250 usd (STL 100-4) . Let's see...

    Posted via CB10
    04-09-15 07:20 AM
  17. m3ach's Avatar
    Doesn't the 100-4 only work on 1 network?

    Posted via CB10 using my Z10 STL100-2 /
    04-09-15 08:06 AM
  18. scrannel's Avatar
    Odds against you receiving that many bad phones: astronomical. Odds that you are "doing something" to all your phones: highly likely. Again, I think your charger is pooching your phones.

    Or... are you using the same battery from phone to phone?
    04-09-15 09:43 AM

Similar Threads

  1. Why am I unable to install Google Play Services on my new Passport?
    By CrackBerry Question in forum Android Apps (Amazon Store & APK Files)
    Replies: 6
    Last Post: 09-22-17, 12:56 PM
  2. "iPhone gets a resounding 'meh' in China."
    By tchocky77 in forum Apple iPhone/iPad
    Replies: 9
    Last Post: 04-10-15, 09:48 AM
  3. How to remove the Amazon app from my BB Z10?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 13
    Last Post: 04-09-15, 01:17 PM
  4. Replies: 4
    Last Post: 04-07-15, 09:54 PM
  5. Which OS build is suppose to fix the low notifications????
    By curves2000 in forum BlackBerry Q10
    Replies: 1
    Last Post: 04-07-15, 08:27 PM