03-27-14 09:22 PM
28 12
tools
  1. jamesmcp5's Avatar
    Last night i dropped my phone and the speaker stopped working

    Z10 STL100-1 on 10.2.1.1925/1926 radio
    01-26-14 01:39 AM
  2. Maxz888's Avatar
    Same here. Speaker not working

    Sent by awesome Z30.
    01-26-14 01:44 AM
  3. agarwal.apar's Avatar
    No case on Z10?
    01-26-14 02:03 AM
  4. DNae's Avatar
    no warranty ?
    01-26-14 02:06 AM
  5. jamesmcp5's Avatar
    Yes have a case, what can i do? Anybody know how to fix it?

    Z10 STL100-1 on 10.2.1.1925/1926 radio
    01-26-14 02:09 AM
  6. Maxz888's Avatar
    Regretted for no case but luckily my screen protector save my screen. It's a Human error, I don't think warranty can help.

    Sent by awesome Z30.
    01-26-14 02:10 AM
  7. jamesmcp5's Avatar
    I lost the warranty

    Z10 STL100-1 on 10.2.1.1925/1926 radio
    01-26-14 02:10 AM
  8. jamesmcp5's Avatar
    We have the same problem friend

    Z10 STL100-1 on 10.2.1.1925/1926 radio
    01-26-14 02:11 AM
  9. cantina4me's Avatar
    That happened to me several months ago. Searched the forums and found were some people pressed down on the back of the phone somewhere with a little bit of pressure and that was supposed to help. Didn't work for me but I did hear a little crackling after. So I did a few good smacks on the palm of my hand and that actually worked. No sound issues now at all.

    Z10STL100-3/10.1.0.2074 AT&T
    01-26-14 02:38 AM
  10. kolowosh's Avatar
    I dropped mine and my camera is gone.
    I dropped my z10 :(-img_00001843.jpg

    Posted via CB10
    leehardballer12 likes this.
    01-26-14 05:25 AM
  11. jamesmcp5's Avatar
    Youre awesome i did this and my speaker is working!!!

    Z10 STL100-1 on 10.2.1.1925/1926 radio
    cantina4me likes this.
    01-26-14 09:49 AM
  12. mEntal8y's Avatar
    I flinched involuntarily by just reading the name of this post.
    01-26-14 09:54 AM
  13. Affie36's Avatar
    Or you could replace it? If you really want it...

    Posted via CB10
    01-26-14 10:03 AM
  14. Gatmyer's Avatar
    Sounds like the speaker connector came loose and pressing in a certain location probably got the connector seated again (will probably come off again) if you are a tinkerer there are many u tube fix it videos

    Posted via CB10
    01-26-14 10:06 AM
  15. RADEoN1337's Avatar
    I'd like to develop a fix for this issue.

    Like I've said in many other posts, if someone wants to mail a damaged phone to me, I can try to figure out a quick and easy solution for it.

    Posted via CB10
    01-26-14 10:10 AM
  16. FF22's Avatar
    Last night i dropped my phone and the speaker stopped working

    Z10 STL100-1 on 10.2.1.1925/1926 radio
    You can try testing a bit more. BBworld has an app that tests the various systems. BB Virtual Expert.

    But it sounds as if some connection broke loose. There are videos on youtube on how to open and check things out. But use care as you could break something else. Do headphones work?

    What happened to your warranty - although they generally don't cover physical damage like dropping unless it shows no sign of damage.
    01-26-14 10:24 AM
  17. BlackBerryEnthusiast's Avatar
    If they wanted to improve the connections and circuit board reliability, BlackBerry should dip the entire internal components in black epoxy. That would eliminate any loose connections in my opinion.

    Posted Via Z10
    01-26-14 10:39 AM
  18. RADEoN1337's Avatar
    And eliminate any heat dissipation.

    Posted via CB10
    02-01-14 10:05 PM
  19. Sporatic's Avatar
    And remove all possibilities of it being fixable if something does break.
    02-01-14 10:11 PM
  20. DJM626's Avatar
    Posted via CB10
    02-01-14 10:21 PM
  21. wentouch's Avatar
    Nerd alert.

    Just kidding.
    02-01-14 10:36 PM
  22. bubbbab's Avatar
    That happened to me several months ago. Searched the forums and found were some people pressed down on the back of the phone somewhere with a little bit of pressure and that was supposed to help. Didn't work for me but I did hear a little crackling after. So I did a few good smacks on the palm of my hand and that actually worked. No sound issues now at all.

    Z10STL100-3/10.1.0.2074 AT&T
    A few smacks with the palm of your hand to get it to work... let's cross post this to the Lazy Wife thread.

    This is likely one of those things that couldn't be repaired with normal home soldering equipment if a connection has been compromised. If there are no marks from the drop warranty might be applicable. I'm not advocating lying of course, just omitting

    Posted via my BlackBerry Zeadache 10.2.0.429
    02-02-14 12:41 AM
  23. cantina4me's Avatar
    A few smacks with the palm of your hand to get it to work... let's cross post this to the Lazy Wife thread.

    This is likely one of those things that couldn't be repaired with normal home soldering equipment if a connection has been compromised. If there are no marks from the drop warranty might be applicable. I'm not advocating lying of course, just omitting

    Posted via my BlackBerry Zeadache 10.2.0.429
    Really don't appreciate the "Lazy Wife" comment since I'm not married. Lol. Anyway it's not like I smacked the crap outta it, and besides it worked and still is working with no issues, aside from no 10.2 update yet. But anyway be nice with your words ...

    Z10STL100-3/10.1.0.2074 AT&T
    02-02-14 04:03 PM
  24. leehardballer12's Avatar
    That happened to me several months ago. Searched the forums and found were some people pressed down on the back of the phone somewhere with a little bit of pressure and that was supposed to help. Didn't work for me but I did hear a little crackling after. So I did a few good smacks on the palm of my hand and that actually worked. No sound issues now at all.

    Z10STL100-3/10.1.0.2074 AT&T
    I wonder if this would help the slight crackling in my ear piece.....

    Posted via CB10
    02-02-14 04:32 PM
  25. bubbbab's Avatar
    Really don't appreciate the "Lazy Wife" comment since I'm not married. Lol. Anyway it's not like I smacked the crap outta it, and besides it worked and still is working with no issues, aside from no 10.2 update yet. But anyway be nice with your words ...

    Z10STL100-3/10.1.0.2074 AT&T
    Was just thinking is your process would work on a lazy wife. Unfortunately not, I got beat up.

    Posted using BlackBerry ZedAche 10.2.1.537
    02-02-14 06:50 PM
28 12

Similar Threads

  1. New Z10
    By iwantsleep in forum New to the Forums? Introduce Yourself Here!
    Replies: 11
    Last Post: 02-04-14, 09:35 AM
  2. WTT my electricacoustic guitar for a Blackberry Anyone PLEASEEE!!!!
    By Kemir in forum The Marketplace - Buy, Sell & Trade
    Replies: 5
    Last Post: 02-01-14, 02:11 AM
  3. My Android Runtime has stopped working (10.2.1.1925)
    By Akainzo in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 01-28-14, 04:20 AM
  4. Unlock z10 with att sim
    By jtmo3 in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 01-26-14, 12:07 PM
  5. How do I fresh install Z10 for 10.2.1?
    By gameson in forum BlackBerry Z10
    Replies: 4
    Last Post: 01-25-14, 08:13 PM
LINK TO POST COPIED TO CLIPBOARD