1. lunarlegend1524's Avatar
    I bought a STL100-3 with AT&T logo on the backdoor cover, and on the startup and shutdown screen it shows the AT&T logo also. Now after updated to 10.2.1 by sachesi with Telus' OS, the logo is gone.

    Is there anyway I can set the carrier logo to reappear? (my SIM is from a Vietnam carrier)

    Z10 the Awesomeness
    02-02-14 10:53 AM
  2. eldricho's Avatar
    Normally it is assigned to your sim by your carrier and the phone reads it from the sim card

    Posted via CB10
    thurman likes this.
    02-02-14 10:56 AM
  3. Branta's Avatar
    The initial boot splash screen is from the SIM and shows the network which supplied the SIM. At least that is how my Z10 works, boot with the O2 SIM and I see the O2 logo. Boot with the vodafone SIM and I see the Voda logo. No idea what happens if the SIM doesn't have an embedded logo.
    02-02-14 10:59 AM
  4. lunarlegend1524's Avatar
    So, does anyone knows how to set a custom logo or to "trick" the phone to read an embedded SIM? Because I like it better than with only a BB logo show up

    Z10 the Awesomeness
    02-02-14 11:10 AM
  5. thurman's Avatar
    It is determined my you SIM card installed in it one the device is booted. Nothing to do with the software of phone.


    Z10 STL100-3 >>>>>>>>Leaks 1055, 1259, 1925
    02-02-14 06:41 PM
  6. Hamilton Guy's Avatar
    There's a bunch of threads from last year that say the splashscreen is set by the SIM. For example:
    http://forums.crackberry.com/blackbe...hanges-815536/
    02-02-14 08:11 PM
  7. lunarlegend1524's Avatar
    Weird, after I do a battery pull and left the battery for a night, the AT&T logo appear at the shutdown screen again

    Z10 the Awesomeness
    02-02-14 11:51 PM
  8. jpvj's Avatar
    I am quite sure the logo is not stored on the SIM. I would not make sense as it should support multiple resolutoins (e.g. 720x720 for the Q10). Instead the device reads the MMC/MNC and determine what logo to show. I assume it is part of the OS. Alternatively it could be downloaded from RIM.

    The reason for your device to show it after second boot is because the SIM is not initialized during boot, so the device does not know which carrier logo to show first time.
    02-03-14 05:34 PM
  9. lunarlegend1524's Avatar
    If only we know how to set the custom logo...I personally like Movistar logo

    Posted via CB10
    02-07-14 10:19 PM
  10. tickerguy's Avatar
    There's a carrier logo set on the phone and the MCC/MNC that's on the SIM is the selector to pick which one to display.
    02-07-14 10:29 PM
  11. jpvj's Avatar
    Tickerguy> Thx for confirming.

    Posted via CB10
    02-08-14 06:27 PM
  12. tickerguy's Avatar
    Yeah if you rip apart a ROM you can find the logo screens; they're easy. However, you can't change them because you don't have a BlackBerry signing key, and you need it for the phone to accept any system file. Once you modify the file the original cryptographic signature is invalid.
    02-08-14 08:27 PM
  13. lunarlegend1524's Avatar
    Thanks for letting me know, tickerguy. That's some difficult work

    Posted via CB10
    02-08-14 11:12 PM

Similar Threads

  1. CB10 Active Frame on Z30 OS 10.2.1.537
    By xThamer in forum Site and App Feedback & Help
    Replies: 4
    Last Post: 02-05-14, 11:27 PM
  2. How tough is the Z30's screen? Does it scratch easily?
    By mohawk apple in forum BlackBerry Z30
    Replies: 28
    Last Post: 02-04-14, 08:08 PM
  3. I downloaded the snap app but there is problem (unable to open the file)
    By khader alkhateeb1 in forum More for your BlackBerry 10 Phone!
    Replies: 7
    Last Post: 02-04-14, 12:29 AM
  4. Is face focus on official
    By Dale Lindley in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 02-02-14, 11:21 AM
  5. From leak to official
    By Lmuzzammil in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 02-02-14, 10:24 AM
LINK TO POST COPIED TO CLIPBOARD