12-30-13 12:57 PM
79 123 ...
tools
  1. Spiri91's Avatar
    hello
    today i saw another white stuck pixel on my blackberry z10 so now i have two in total.
    this doesn't bothers me , i am just curious to see how many do you have on amoled screens (q10 z30) vs ips (z10)
    by the way my bb is 8 months old.
    12-27-13 11:32 AM
  2. JamBueree's Avatar
    I've had my Z10 for nine months, and my screen is completely fine.
    12-27-13 11:34 AM
  3. BrentRoss's Avatar
    10 months and nothing that I can see?

    Posted via CB10
    12-27-13 11:37 AM
  4. Xavier85's Avatar
    10 months, zero pixels

    Posted via CB10
    der_mit likes this.
    12-27-13 11:39 AM
  5. pvphooman's Avatar
    None. It's not like an iPhone or Android device with so many hardware problems. The Z10 is perfect!

    Had it since March, dropped it a few times and dented the corner. The screen is tough!

    Z10STL100-3/10.2.1.1925 CB10
    damien kupuku likes this.
    12-27-13 11:41 AM
  6. shahyaz's Avatar
    0, and I've had one since March.
    12-27-13 11:41 AM
  7. ProjectBrett's Avatar
    None

    Posted via CB10
    12-27-13 11:41 AM
  8. BB30000's Avatar
    None

    Via The BlackBerry Z10 Experience.
    12-27-13 12:06 PM
  9. pttptppt's Avatar
    None but my PlayBook has a lot

    Posted via CB10
    12-27-13 12:15 PM
  10. TTQ225's Avatar
    Zero after almost 11 months.

    Posted via CB10
    der_mit likes this.
    12-27-13 12:21 PM
  11. CecilTsunami's Avatar
    0 on my Z10 since Feb. 8

    Posted via CB10
    12-27-13 12:28 PM
  12. SirJes's Avatar
    zilch, zip, zero,
    der_mit likes this.
    12-27-13 12:37 PM
  13. Peevish's Avatar
    I don't have any dead pixels but when I launch browser I do see a few white pixels when they should be black. I think it's an app issue though, cause it doesn't happen anywhere else.

    Posted via CB10
    12-27-13 12:39 PM
  14. Mike1117's Avatar
    0 (Day 1 VZW user)
    12-27-13 12:40 PM
  15. thatplaybookguy's Avatar
    I have the first z10 since launch and prefect screen. No Pixel Junk for me.
    12-27-13 12:45 PM
  16. Spiri91's Avatar
    i can see them only on boot screen, and a very close look. or with a pixel checker app an black screen with brightness to max.
    12-27-13 12:48 PM
  17. Fougasse's Avatar
    None in seven months.

    Posted via Z10.
    12-27-13 12:54 PM
  18. cdnynot's Avatar
    Merry Christmas - I've had my Blackberry since February and I've had three blue dots on my screen. You could only see them when the screen was black.
    I went to the Bell mobility store and had them look at it, Bell shipped my Z10 to Blackberry to get a replacement screen.
    These blue dots were not bothering me - I was missing my Z10 when it was away.
    12-27-13 12:57 PM
  19. hdbulldog4's Avatar
    Zero.

    Posted via CB10
    12-27-13 12:59 PM
  20. newfie1974's Avatar
    8 months and all is good.
    12-27-13 02:07 PM
  21. anon(5906760)'s Avatar
    I don't have any dead pixels, but I have an area that is lighter than the others. It's weird but I don't notice it anymore. No other problems on my screen that I have noticed.

    Posted via CB10
    12-27-13 02:18 PM
  22. Javid Gozalov's Avatar
    None

    Posted via CB10
    12-27-13 02:35 PM
  23. Dave79's Avatar
    1 dead pixel in my playbook - the Q10 is still good.
    12-27-13 02:48 PM
  24. knighty2112's Avatar
    Had since launch in February and not one dead or incorrect pixel showing at all.

    Whoosh! Z10 in action!
    12-27-13 02:52 PM
  25. Chris Murphy's Avatar
    1 dead in the middle of my screen. Not a big deal, but annoys the hell out of me.

    Swiped on a beautiful AMOLED BlackBerry 10.
    12-27-13 02:54 PM
79 123 ...

Similar Threads

  1. How to Change Default notification in calendar
    By fred1266 in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 12-28-13, 08:15 AM
  2. How do you send gifts from BlackBerry world in BB10?
    By popengchan in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 12-27-13, 09:04 AM
  3. Replies: 4
    Last Post: 12-27-13, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD