1. CrackBerry Question's Avatar
    Hello guys, A BIG PROBLEM!!!!!!!! I have a Blackberry z10 . My z10's proximity sensor is not working! What to do or how much will it cost? My phone is in warranty? I also applied a glass guard...is this problem by guard? PLEASE HELP ME?!!!!!!
    04-20-15 11:02 AM
  2. paulwallace1234's Avatar
    Wow don't freak out, install BB VE and check it first, also if you've updated to 10.3.1 it could a software issue (I have it myself)

    https://appworld.blackberry.com/webs...countrycode=GB
    04-20-15 11:15 AM
  3. koebi90's Avatar
    I've got the same problem too.

    Light sensor and proximity sensor down. That's what BBVE tells me...

    Don't know whether it's a software or hardware problem...

    Posted via CB10
    04-23-15 04:00 AM
  4. Rustybronco's Avatar
    I also applied a glass guard...is this problem by guard?
    Remove it and find out. Or, ask yourself a question. Did this problem occur about the same time I installed it.
    04-23-15 08:32 AM
  5. vbdwork's Avatar
    Don't know whether it's a software or hardware problem...
    If it doesn't work on different OS releases and with no screen protector, then it's a faulty sensor and has to be replaced. You can do it yourself, search eBay for sensors module. There are many reports for faulty sensors, it's one of the common issues with Z10 devices, but not hard / expensive to fix.
    04-23-15 08:49 AM
  6. FF22's Avatar
    If the GLASS PROTECTOR covers the top area of the "screen" including the LED light then it could be interfering with the sensor.
    04-23-15 12:50 PM
  7. charu219's Avatar
    I also applied a glass guard...is this problem by guard? PLEASE HELP ME?!!!!!![/QUOTE]

    Yes the glass screen protectors do interfere. Had the same problem removed it... viola no problem!

    Posted via CB10
    nick13b likes this.
    04-23-15 02:46 PM
  8. nick13b's Avatar
    I also applied a glass guard...is this problem by guard? PLEASE HELP ME?!!!!!!

    Posted via CB10[/QUOTE]

    Lol this ^

    Posted via R115-Aramis.
    04-24-15 03:31 AM
  9. sandeepraghav85's Avatar
    I myself had the same problem. As the original post says he is using the glass guard. Remove it and use only a screen protector and you are good to go. At least it worked for me.

    Posted via CB10
    04-24-15 08:45 AM
  10. Shivam Sharma10's Avatar
    I solved it! It was just because of Screen Guard! It was covering the whole sensor! As i removed it..iT starts working fine~!
    FF22 likes this.
    04-27-15 01:29 AM

Similar Threads

  1. my blackberry Z10 keep restarting over and over
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 04-21-15, 09:15 AM
  2. Opera Mini for Z10
    By lyrical_ray in forum Ask a Question
    Replies: 4
    Last Post: 04-20-15, 12:18 PM
  3. How can I get my Media card working?
    By CrackBerry Question in forum BlackBerry Curve 8530/8520 Themes
    Replies: 3
    Last Post: 04-20-15, 11:43 AM
  4. Replies: 2
    Last Post: 04-20-15, 11:28 AM
  5. no sounds on my blackerry z10 after updating to os 10.3.1.1779
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 04-20-15, 09:18 AM
LINK TO POST COPIED TO CLIPBOARD