06-05-14 12:43 AM
31 12
tools
  1. crazigee's Avatar
    Hey all,

    All of a sudden I have no sound from the loud speaker. No notifications, no feedback when typing, media, no shutter when using the camera, and no sound when calls are on speaker phone.

    There is sound on calls on the normal speaker, but as soon as I switch to speaker phone I get nothing all.

    I checked my settings and everything is normal and sound is on. I've tried restarting the phone and nothing.

    The phone hasn't been dropped or banged or anything like that.

    Any suggestions?

    Posted using my Z10 via CB10
    05-21-14 12:50 PM
  2. anon(3950127)'s Avatar
    What os are you on and what model?

    Posted via CB10/O.S.10.2.1.2228
    05-21-14 01:11 PM
  3. altaf.s's Avatar
    May be loose internal connections, I had that issue, I just pressed lightly behind the back where speaker is located, and it poped sound again, or you try inserting headphones into jack and pull out, might resolve your issues.
    05-21-14 01:11 PM
  4. LostOnThePianoRoll's Avatar
    Nope it happens to me a lot usually the phone thinks that it's still connected to headphones after I disconnect it..
    To fix it play a song from the music app and from the overflow menu click audio then choose speakers..
    Or plug in headphones then take them off again..

    Posted via CB10 from my Z10STL100-1/10.3.0.442
    05-21-14 01:14 PM
  5. crazigee's Avatar
    What os are you on and what model?

    Posted via CB10/O.S.10.2.1.2228
    Z10STL100-3/10.2.1.2141

    Posted using my Z10 via CB10
    05-21-14 01:15 PM
  6. Levi_Asaiah's Avatar
    Try the audio test on BlackBerry Virtual Expert
    Help: No Sound From Speaker-img_20140521_141741.png

    CB10 via Z10STL100-3/10.3.0.296 /441 radio
    05-21-14 01:18 PM
  7. crazigee's Avatar
    Try the audio test on BlackBerry Virtual Expert
    Click image for larger version. 

Name:	IMG_20140521_141741.png 
Views:	1000 
Size:	72.1 KB 
ID:	272522

    CB10 via Z10STL100-3/10.3.0.296 /441 radio
    Loudspeaker test fails. Receiver test passes.

    I can't do the other cause I don't have a headset with me.

    Posted using my Z10 via CB10
    05-21-14 01:21 PM
  8. GiantSchnauzer's Avatar
    My friends z10 had that for a while until I turned the z10 over and gave it a few quick slaps on the back of the speaker (loose connection, read that also in a forum a while ago)

    Z30 Pooooooooower!
    05-21-14 01:32 PM
  9. crazigee's Avatar
    Try the audio test on BlackBerry Virtual Expert
    Click image for larger version. 

Name:	IMG_20140521_141741.png 
Views:	1000 
Size:	72.1 KB 
ID:	272522

    CB10 via Z10STL100-3/10.3.0.296 /441 radio
    Got home and did the complete audio tests sequence. The loudspeaker is the only on that fails. All others pass.



    Posted using my Z10 via CB10
    Attachment 272540
    05-21-14 02:37 PM
  10. crazigee's Avatar
    My friends z10 had that for a while until I turned the z10 over and gave it a few quick slaps on the back of the speaker (loose connection, read that also in a forum a while ago)

    Z30 Pooooooooower!
    OK, so I tried this and the speaker comes back for a second and then stops. So it seems like a connection issue.

    How do I get it solved? Is there a way into the back panel or do I need to take it in somewhere?

    Posted using my Z10 via CB10
    05-21-14 02:39 PM
  11. crazigee's Avatar
    Anyone know how to permanently solve this loudspeaker connection issue?

    Posted using my Z10 via CB10
    05-21-14 08:46 PM
  12. ronfc's Avatar
    As other have said, you can tap it slightly or you can blow air through it. If you're really concerned, drop by a BlackBerry Service Center and have it checked.
    05-21-14 08:53 PM
  13. crazigee's Avatar
    As other have said, you can tap it slightly or you can blow air through it. If you're really concerned, drop by a BlackBerry Service Center and have it checked.
    As said above tapping gets the loudspeaker to work for a few seconds. So it does seem to be a connection issue.

    Two seconds isn't long enough. This is my only phone. I need the loudspeaker to work reliably all the time. Otherwise I won't know when the phone is ringing, when I have new emails or texts, and even my alarm won't work in the morning.

    So is there are a permanent fix? Tapping doesn't seem to work for more than a few seconds.

    Posted using my Z10 via CB10
    05-21-14 09:02 PM
  14. ronfc's Avatar
    As said above tapping gets the loudspeaker to work for a few seconds. So it does seem to be a connection issue.

    Two seconds isn't long enough. This is my only phone. I need the loudspeaker to work reliably all the time. Otherwise I won't know when the phone is ringing, when I have new emails or texts, and even my alarm won't work in the morning.

    So is there are a permanent fix? Tapping doesn't seem to work for more than a few seconds.

    Posted using my Z10 via CB10
    Get the device checked and repaired in a service center. That should be permanent.
    05-21-14 09:11 PM
  15. crazigee's Avatar
    Get the device checked and repaired in a service center. That should be permanent.
    How do I find a BlackBerry service center near me?

    Any idea what the cost would be?

    Thanks for your help!

    Posted using my Z10 via CB10
    05-21-14 09:33 PM
  16. xBURK's Avatar
    Try the audio test on BlackBerry Virtual Expert
    Click image for larger version. 

Name:	IMG_20140521_141741.png 
Views:	1000 
Size:	72.1 KB 
ID:	272522

    CB10 via Z10STL100-3/10.3.0.296 /441 radio
    Hey Levi, I can't believe I didn't know about this app. Thank you for posting this. I just downloaded it.

    BBM CHANNEL - "BB POWERED " C001C1D66
    05-21-14 09:46 PM
  17. GiantSchnauzer's Avatar
    Give it more than a tap...

    Z30 Pooooooooower!
    05-21-14 10:36 PM
  18. GiantSchnauzer's Avatar
    Or try this:
    http://www.ifixit.com/Teardown/Black...Teardown/13445
    Looks easy

    Z30 Pooooooooower!
    05-21-14 10:39 PM
  19. crazigee's Avatar
    Give it more than a tap...

    Z30 Pooooooooower!
    Thanks. I'll try some more.

    Posted using my Z10 via CB10
    05-22-14 08:49 AM
  20. crazigee's Avatar
    Or try this:
    http://www.ifixit.com/Teardown/Black...Teardown/13445
    Looks easy

    Z30 Pooooooooower!
    I'll definitely look into that.

    Posted using my Z10 via CB10
    05-22-14 08:49 AM
  21. FF22's Avatar
    If you have a warranty you might not want to chance voiding it. But it might be quicker yourself.
    05-22-14 03:26 PM
  22. crazigee's Avatar
    If you have a warranty you might not want to chance voiding it. But it might be quicker yourself.
    Bought the phone factory unlock from a dealer. He in turn got not free at a BlackBerry event. I doubt it has a warranty, and if it does I wouldn't know how to get it serviced. Normally you bring it back to your carrier and they send it in for repair. In this instance I didn't buy the phone from my carrier.

    Posted using my Z10 via CB10
    05-22-14 03:43 PM
  23. Skye Gross's Avatar
    blackberry z10 speaker and audio wont connected to the headphones
    05-31-14 10:59 PM
  24. crazigee's Avatar
    So after banging away on the speaker area multiple times, the sound would come back for a little while but it would stop working again pretty quickly. On the last time it has stayed working.

    It's now been a couple weeks, and knock on wood, the speaker has been fine.

    If it happens again I'll have no choice but to replace the phone. It's my only phone and I can't afford to miss calls. My work also uses text messages as pages so I can't miss those either. Say the speaker stopped working in the middle of the night my alarm also wouldn't sound in the morning.

    Hopefully it will be fine until the next flagship touch device is released.

    I want to give a big thanks to GiantSchnauzer and Ron in Motion.

    Posted using my Z10 via CB10
    06-04-14 01:08 AM
  25. GiantSchnauzer's Avatar
    Fingers crossed!

    Z30 Pooooooooower!
    06-04-14 02:29 AM
31 12

Similar Threads

  1. Making Calls from Contacts
    By tntmom2013 in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 05-22-14, 09:08 PM
  2. BBM voice icon on 9900 no longer there
    By fryk in forum General BBM Chat
    Replies: 3
    Last Post: 05-22-14, 02:17 PM
  3. clicking sound on left side of screen
    By mhw100 in forum BlackBerry Q10
    Replies: 3
    Last Post: 05-21-14, 06:49 PM
  4. View webpages directly from the Hub with Card Browser
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 05-21-14, 10:30 AM
LINK TO POST COPIED TO CLIPBOARD