1. sakisZ10's Avatar
    I will try to make my story as short as possible...
    I bought my Z10 (STL100-3) from Ebay a few days ago and it arrived yesterday. I was so excited!!! I played with it while it was charging and I liked it more than I was expecting.
    Anyways, the seller claimed that the phone was an AT&T phone so that was one of the reasons I bought it because my current phone (Galaxy SII) is locked on AT&T too. Due to the fact that the Z10 uses a micro SIM card and my S2 uses a regular one, I had to go to AT&T after work to get a new SIM card. In the meantime I installed the *.1925 leak so that once I get my SIM card I will be good to go.
    After the AT&T employee installed the new micro SIM card on the phone he noticed that although the Z10 boots with all the AT&T logos and so on, for some reason it seems to be locked on to another network and he couldnt help me anymore. He checked to see if the phone was stolen but he said the phone was "clean".
    The Z10 is not recognizing the SIM card... I was SO disappointed! So I decided to keep the new micro SIM card, since it s activated, got an adapter (micro to regular SIM card) and installed the new SIM card in my S2 and went home.
    I contacted the seller through Ebay, asking for explanation. I am expecting a reply soon ( I hope...)
    In the meantime I thought of keeping the phone and buy an unlock code from the internet. And here is the weird part... The IMEI code of my Z10 has 17 digits instead of 15. Is this normal?
    If anyone has any idea of what should I do I would really appreciate it.
    The phone is in excellent condition and I would like to keep it. But I am not quite sure what is wrong with it!

    Thank you all!
    02-18-14 08:31 AM
  2. scrannel's Avatar
    First of all it is not unusual for some phones to have two more IMEI digits than "normal" -- ignore them, those are checksum numbers. Cutting to the chase: you could contact a reputable after-market unlock company and ask them about an unlock code. Yes, it sounds like it's locked (did you check? Settings > Security and Privacy > SIM Card. Last three selections will say "unlocked" if not, it is locked). The at&t splash screen could have come from the SIM. BTW is there any "logo" printed on the battery cover -- like "at&t"? If you have the box, any indication there of a carrier?
    sakisZ10 likes this.
    02-18-14 08:42 AM
  3. sakisZ10's Avatar
    I am going to "Tarantino" and start from the end.
    The AT&T splash screen was there before the I inserted a SIM card. From the first time I booted the phone.
    On the "SIM card" page of the phone it says "A SIM card isnt detected in the device."
    down at the "Unlock Network" part, both Network Subset and Service Provider says: "Unlocked"

    Thanks for your reply!
    02-18-14 08:50 AM
  4. MobileMadness002's Avatar
    Seems to be locked to another carrier? How did he come to this conclusion? Did he actually check the device SIM options and see any items needing unlocked?
    sakisZ10 likes this.
    02-18-14 08:57 AM
  5. MobileMadness002's Avatar
    I am going to "Tarantino" and start from the end.
    The AT&T splash screen was there before the I inserted a SIM card. From the first time I booted the phone.
    On the "SIM card" page of the phone it says "A SIM card isnt detected in the device."
    down at the "Unlock Network" part, both Network Subset and Service Provider says: "Unlocked"

    Thanks for your reply!
    There are 3 sections down there. Network, Network Subset and Service Provider. All 3 need to indicate "Unlocked"
    02-18-14 08:58 AM
  6. sakisZ10's Avatar
    Seems to be locked to another carrier? How did he come to this conclusion? Did he actually check the device SIM options and see any items needing unlocked?
    Thanks! No he actually assumed, but from what I can tell, that might be the case, unless there is something seriously wrong with the SIM card reader.
    02-18-14 09:00 AM
  7. scrannel's Avatar
    I am going to "Tarantino" and start from the end.
    The AT&T splash screen was there before the I inserted a SIM card. From the first time I booted the phone.
    On the "SIM card" page of the phone it says "A SIM card isnt detected in the device."
    down at the "Unlock Network" part, both Network Subset and Service Provider says: "Unlocked"

    Thanks for your reply!
    All three of the last choices should say "unlocked" Beneath the statement "Phone Network Lock" there should be no active "buttons". Still, if the splash screen is built in... any chance you could just have a bad SIM? I would wait (a reasonable amount of time) to hear from your seller because if the phone is defective, you should get your money back. You can always do a secuirty wipe.
    sakisZ10 likes this.
    02-18-14 09:01 AM
  8. sakisZ10's Avatar
    Under the "A SIM card isnt detected in the device." there is an active "Show me How" button

    Underneath there is the "Phone Network Lock" that says. "You current SIM card requires one or more Mobile Equipment Personalization codes before the Mobile Network will be available"
    and under that there is the active "Unlock Network button (with ten 10 attempts)
    and finally Network Subset and Service Provider says: "Unlocked"
    02-18-14 09:08 AM
  9. sakisZ10's Avatar
    All three of the last choices should say "unlocked" Beneath the statement "Phone Network Lock" there should be no active "buttons". Still, if the splash screen is built in... any chance you could just have a bad SIM? I would wait (a reasonable amount of time) to hear from your seller because if the phone is defective, you should get your money back. You can always do a secuirty wipe.
    The new SIM card works fine on my S2 right now...
    Just bought an unlock code form some site (hope is legit) and waiting for the email to unlock it.
    I ll update thanks everyone!
    02-18-14 10:03 AM
  10. scrannel's Avatar
    The new SIM card works fine on my S2 right now...
    Just bought an unlock code form some site (hope is legit) and waiting for the email to unlock it.
    I ll update thanks everyone!
    OK, but if it doesn't work do not keep trying you will use up your ten tries.
    sakisZ10 likes this.
    02-18-14 10:33 AM
  11. sakisZ10's Avatar
    First of all thank you for your support!
    Stupid question No.155: Is there any way that somehow the leak that I installed may have messed up the phone?
    02-18-14 10:37 AM
  12. nhanken's Avatar
    Hi Sakis make sure you get a recorder or use your S2 to record a video clip while you enter the unlock code on the Z10; this way if the unlock code doesn't work or is not legit, you can contact the seller & demand a refund. On the other hand, if the eBay seller doesn't reply back in a timely manner, file a complaint. Did the owner mention that the Z10 was unlocked or you just assumed since you're on AT&T?

    The new SIM card works fine on my S2 right now...
    Just bought an unlock code form some site (hope is legit) and waiting for the email to unlock it.
    I ll update thanks everyone!


    Posted via CB10
    02-18-14 10:40 AM
  13. nhanken's Avatar
    The leak shouldn't affect the lock or unlock part. As others have mentioned, did you make sure you see three "unlocked" like in this pic below? If that's the case, there could be something wrong with the SIM slot.
    Help or advise....-img_20140218_114325.png

    First of all thank you for your support!
    Stupid question No.155: Is there any way that somehow the leak that I installed may have messed up the phone?



    Posted via CB10
    sakisZ10 likes this.
    02-18-14 10:45 AM
  14. sakisZ10's Avatar
    Thanks for the advice and your insight!

    First of all, I didnt buy the phone because it was unlocked. There was no mention if the phone was locked or not. Actually I didnt care about that part at that point. I bought it because it was an AT&T phone, so I thought by getting a new SIM card it should be fine.

    The menu on my phone is a little different... How do you get a screenshot on a Z10?
    02-18-14 10:56 AM
  15. nhanken's Avatar
    When you press both volume keys together, it will take a screen shot. Ah if it's an AT&T phone, I don't know why it's not working with any AT&T SIM. Hopefully there's nothing wrong with the SIM slot >_<.

    I'm using a Z30 that's why it's different than your Z10
    sakisZ10 likes this.
    02-18-14 11:01 AM
  16. 1shady_llama's Avatar
    Screen shot : hold vol up & vol down simultaneously

    Posted via CB10
    sakisZ10 likes this.
    02-18-14 11:06 AM
  17. scrannel's Avatar
    Thanks for the advice and your insight!

    First of all, I didnt buy the phone because it was unlocked. There was no mention if the phone was locked or not. Actually I didnt care about that part at that point. I bought it because it was an AT&T phone, so I thought by getting a new SIM card it should be fine.

    The menu on my phone is a little different... How do you get a screenshot on a Z10?
    Yes. Understand and am a little confused as to why it will not work on at&t. Maybe you want to take a deep breath and think -- if the phone is messed up in some way, what is your envelope on returning it?
    sakisZ10 likes this.
    02-18-14 11:42 AM
  18. sakisZ10's Avatar
    the whole experience so far is bad and I am taking a lot of deeps breaths.
    I am waiting for the unlock code. If the phone unlocks but still doesnt read the SIM card that means it s messed up and it is going back. I hate returning stuff.
    The seller contacted me through Ebay and he apologized bla-bla and I can return the phone for a full refund if I want to.
    02-18-14 11:51 AM
  19. sakisZ10's Avatar
    update:
    I successfully unlocked the phone, but it seems like the phone was defective. It could still not read the SIM card.
    So I sent it back and I got another one. Hopefully I ll have better luck on that one

    Thank you all for your amazing support!
    02-18-14 04:56 PM
  20. scrannel's Avatar
    Hey -- now you're going to get a phone that works! Your seller sounded solid. $hit happens.
    02-18-14 05:54 PM
  21. nhanken's Avatar
    Please keep us posted! I hope everything will turn out well~!

    update:
    I successfully unlocked the phone, but it seems like the phone was defective. It could still not read the SIM card.
    So I sent it back and I got another one. Hopefully I ll have better luck on that one

    Thank you all for your amazing support!


    Posted via CB10
    02-19-14 12:41 AM

Similar Threads

  1. Black VZW Q10
    By Its Spade in forum Buy, Sell, Trade - Sold / Archived
    Replies: 82
    Last Post: 05-17-14, 11:09 AM
  2. Turn off stand-by screen notifi? Duplicate contacts? Help.
    By SenorPistachio in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 02-20-14, 05:45 AM
  3. Replies: 3
    Last Post: 02-19-14, 06:42 AM
  4. Unable to download from Mobogenie, 1mobile, or amazon
    By dr_hamed97 in forum More for your BlackBerry 10 Phone!
    Replies: 2
    Last Post: 02-18-14, 01:11 PM
  5. Problem installing app from SNAP after earlier installing it from Amazon, Help Please
    By jgrobertson in forum More for your BlackBerry 10 Phone!
    Replies: 2
    Last Post: 02-17-14, 06:07 PM
LINK TO POST COPIED TO CLIPBOARD