1. AlexB1227's Avatar
    Hi, I was shoveling snow, and I dropped my Z10. The headphone jack stopped working. It's like it doesn't recognize that they're plugged in.

    Posted via CB10
    01-25-14 11:45 AM
  2. kware84's Avatar
    Try a reset. Good luck
    01-25-14 12:18 PM
  3. jcarlos100's Avatar
    Are u sure? Did u try it with different headphones? Maybe there's melted snow messing up your jack?

    Posted via CB10
    01-25-14 12:18 PM
  4. AlexB1227's Avatar
    well, i use the BB premium sound headphones, but i did try with the apple ones. it still played through the phones speaker. now, i have it in some rice. maybe that will dry it out. i already restarted it (battery pull, the works)
    01-25-14 12:25 PM
  5. AlexB1227's Avatar
    I looked inside the jack, and there was a little something in it. I got it out, but its doesn't work still. I think im just gonna take it to get fixed

    Posted via CB10
    01-25-14 01:10 PM
  6. BBfishingaddict's Avatar
    This is my first post on the forum and I had an issue like yours on my Z10 where my headphone jack would for the most part stop working or work intermittently. It would not play one second and then work with one set of earbuds or speakers but then stop working if I removed the plug. I did drop the phone previously into some gravel but it worked fine right after that. I thought it was a hardware issue and thought I was going to have to get it repaired. I loaded a leaked OS a month ago and miraculously it started working again. I haven't had an issue since nor have I dropped again.
    01-25-14 02:46 PM
  7. FF22's Avatar
    I would try the rice suggestion - you might have gotten snow (now melted) into the jack. It should be dried fully.

    Also in bbworld, free, is BB Virtual Expert, it tests various functions.
    00stryder likes this.
    01-25-14 04:43 PM
  8. AlexB1227's Avatar
    Ok, so I turned my phone off for a bit, outside the rice. I turned it on and decided to try the headphones again. Weirdly it worked!!! I didn't do anything to it, except vacuum out the headphone jack hours earlier!

    Posted via CB10
    01-25-14 09:37 PM
  9. FF22's Avatar
    Electrical circuits do NOT like water. Drying it out can sometimes help. You might want to continue to dry it in a nice warm, dry environment.
    AlexB1227 likes this.
    01-25-14 10:01 PM

Similar Threads

  1. Sound problems (funny)
    By hbelkin in forum BlackBerry Z10
    Replies: 4
    Last Post: 04-18-14, 05:05 AM
  2. Sync Contacts - Problem
    By csoyen in forum BlackBerry Bold Series
    Replies: 11
    Last Post: 01-31-14, 11:36 AM
  3. Snapchat Problems
    By majinbuu1 in forum More for your BlackBerry 10 Phone!
    Replies: 5
    Last Post: 01-29-14, 06:59 PM
  4. Trouble Using Facebook
    By Semihsahu in forum BlackBerry Bold Series
    Replies: 4
    Last Post: 01-28-14, 03:31 AM
  5. Problem updating my apps
    By dannyeo in forum BlackBerry Z10
    Replies: 5
    Last Post: 01-25-14, 08:56 AM
LINK TO POST COPIED TO CLIPBOARD