1. nyallj's Avatar
    Hi all,

    Background: I'm in Guyana, South America. We have 2 providers here: GT&T and Digicel. Using GSM 900MHz spectrum.
    I bought 2 Z10s, one AT&T for my wife (which I unlocked via crackberryunlocked) and one Verizon (which is unlocked by default).
    The AT&T Z10 performs flawlessly, with both mine (GT&T) and my wife's (Digicel) SIM chips.
    The Verizon model however, while able to make/receive phone calls/text messages, does not connect to the Internet Data Services of either providers (GT&T and Digicel).
    What is happening is where the indicator appears to tell you what connection you have (4G, WiFi, EDGE), on the AT&T Z10, a 'E' appears, and works fine, but on the Verizon Z10, a 'e' appears, with the 'E' appearing ever so often, but only for a second or so. Apparently indicating attempting to lock in data services, but failing to do so.
    My question is: is this phone a lemon? Or is there some patch or fix that I can use to get this working please?

    Any help would be greatly appreciated.

    Thank you.

    EDIT: Also, if I go into Settings, About, Network, the Mobile network part comes on and goes off every 2 seconds (on for 1 second, off for 2 seconds). This part displays IPv6 data, IPv4 data, and IMS Status 'No'.

    Also, I'm able to use BBM over WiFi.


    EDIT: I went into both GT&T's and Digicel's offices and their techs indicate that they cannot see any problems from their ends. (Obviously since the SIMs work on the AT&T Z10).
    06-14-13 06:40 PM
  2. Elite1's Avatar
    The Z10 from Verizon works on totally different radio frequencies for data. It's meant as a CDMA device, plus LTE. It won't do 3G / HSPA / HSPA+.

    But, it should work for 2G EDGE service, per the info on the BBRY website. Appears to use the same bands for that.

    In Settings\Mobile Connections\Mobile Network, is there a dropdown box under Network Technology? If so, what are the choices? (Please provide a screenshot with dropdown open.)
    nyallj likes this.
    06-14-13 09:34 PM
  3. nyallj's Avatar
    Data services does not register on Verizon Z10-img_00000002.png

    Posted via CB10
    Elite1 likes this.
    06-14-13 10:36 PM
  4. Elite1's Avatar
    Okay, set it to 2G, then hit Back to exit/save.

    Next, you can try a device reset. (NOT the same as a restart.)
    Hold down your top button for about 30 seconds. Keep pressing it down, ignoring onscreen countdown and restart option, BB splashscreen, black screen, red LED, and BB splashscreen again. I hold down that button until I see the blue startup icon.

    This is how you CB10, son!
    nyallj likes this.
    06-15-13 02:51 AM
  5. nyallj's Avatar
    Thanks. The 2G part didn't help. Is a device reset the same as using Link to reload factory settings? I did that and it didn't help either.

    Posted via CB10
    06-15-13 06:10 AM
  6. wehttam's Avatar
    Living in the caribbean ive always been told never to buy a verizon phone because of the radio compatibility issues CDMA etc
    doubleup4life and nyallj like this.
    06-15-13 06:54 AM
  7. nyallj's Avatar
    Thanks. GT&T and Digicel both told me that too. But I can't understand why the data service would go in and out like that. Suspecting a faulty radio, but hoping there was some sort of patch I could have loaded for a fix.
    06-15-13 11:03 AM
  8. nyallj's Avatar
    And Solved!!!!! I think I know what I did, but I'm not sure. But I just wanted to give a huge shout of thanks to Kris S. who took some time to look at my problem and point me in what turned out to be the right direction. This is an awesome forum!
    06-19-13 08:22 AM
  9. Fred98TJ's Avatar
    What did you do to fix the problem ?


    And Solved!!!!! I think I know what I did, but I'm not sure. But I just wanted to give a huge shout of thanks to Kris S. who took some time to look at my problem and point me in what turned out to be the right direction. This is an awesome forum!
    06-19-13 08:33 AM
  10. nyallj's Avatar
    I played around in the escreens, turning on and off radios. Then turned off Auto setting on Data Services, and noticed the phone lost the APN settings when I did that. But when I turned back on Auto in escreens, the phone refused to pick up setting automatically. So I tried manually entering them, and voila!, it worked. At least, that's what I think happened. Not sure, and I am not going in back there to play around anymore!
    06-20-13 11:00 AM
  11. satej_neel's Avatar
    I am facing the same problem. Can someone help me please.
    I have a Z10 from Verizon (US). My Z10 is working fine with Airtel (India) sim for text and voice only. No data connection though I have an active data plan. It works fine on wifi.

    Badly need your help in this regrds.

    Thanks in advance.
    10-01-13 04:04 AM
  12. Yoli A's Avatar
    Please help I am having the very same issue and I need this resolved. ...Do I really need to do a system wipe and would it work. I see people talking about radio - where do I find that. I tried the manual setting - I am in Nigeria - Have MTN but tested on GLo with same issue. Called VZN it is a GSM CDMA GLobal phone already unlocked. Please I need my BBM and internet to function. Almost losing my mind. Thanks.
    12-18-13 06:59 AM

Similar Threads

  1. Facebook will not connect on Verizon Z10 Today
    By walabe16 in forum BlackBerry Z10
    Replies: 6
    Last Post: 05-06-13, 03:41 PM
  2. WiFi does not work on Z10
    By koolrosh in forum BlackBerry Z10
    Replies: 11
    Last Post: 05-02-13, 01:10 AM
  3. my blackberry data does not work on my second hand blackberry.
    By alexsenior123 in forum BlackBerry Curve Series
    Replies: 7
    Last Post: 10-26-10, 04:30 AM
  4. 8820 service books missing...not registering on BIS...please help
    By dubaireporter in forum BlackBerry 88xx Series
    Replies: 1
    Last Post: 07-22-09, 01:29 AM
  5. TeleNav Premium Does Not work on 8300
    By htsmithjr in forum BlackBerry Curve Series
    Replies: 1
    Last Post: 06-01-07, 07:47 AM