1. andrew1479's Avatar
    Is anyone else experiencing very slow loading? I'm in Southern Ontario running 10.2.0.429 and I'm on telus network, even when I'm on Wifi my Z10 is terribly slow, noticed the difference yesterday and today is much worse, took me nearly 5 mins to get this far in CB, it's slow on twitter, Facebook, just general loading takes longer then before. Any tips or idea what I could do to speed it up?!

    Posted via CB10
    12-06-13 02:04 PM
  2. zocster's Avatar
    Have you rebooted with the two fingers pressing the volume buttons? Leave them there until the blue BB logo shows.
    12-06-13 03:48 PM
  3. marco44's Avatar
    Funny my Z10 has been sluggish the last few days I'm on the same 10.2.0.429 but with Bell. I rebooted and it seems to have helped
    Wondering if it's all the free apps I'm downloading? Is there a limit?

    Posted via CB10
    12-07-13 08:57 AM

Similar Threads

  1. Sms, and contacts slow to load
    By crankedcoffee in forum BlackBerry Q5
    Replies: 5
    Last Post: 12-14-13, 05:30 PM
  2. Purchasing an unlocked Z10 for T-Mobile/WiFi calling
    By ishamid in forum BlackBerry Z10
    Replies: 19
    Last Post: 12-10-13, 12:16 PM
  3. My fourth Z10 !!! I've had it
    By Lee Eshelman in forum BlackBerry Z10
    Replies: 161
    Last Post: 12-08-13, 01:33 AM
  4. And Now for the problems…
    By adjdudley21 in forum BlackBerry Q10
    Replies: 8
    Last Post: 12-06-13, 11:57 PM
  5. Everyday there is new adventure (problem) with my phone
    By Marko M1 in forum BlackBerry Z10
    Replies: 2
    Last Post: 12-06-13, 03:43 PM
LINK TO POST COPIED TO CLIPBOARD