1. lord_hibiskus's Avatar
    Hi, today I got genius navigator 905bt mouse and currently having an issue with it. I can pair it with z10 and connect to it, but no arrow is shown or I cannot click anything. I tried some Sony mouse 2 months ago and it was working, however than I had official 10.1 and now I am running 1743 leak.
    Any thoughts?

    Posted via CB10
    10-02-13 06:17 AM
  2. Bla1ze's Avatar
    Hard to say.. maybe you should try the Sony one again and see if it works. Might help filtering out the issue be it the OS or the mouse.
    10-02-13 06:28 AM
  3. lord_hibiskus's Avatar
    UPDATE: After i came home and paired mouse with my laptop, now i cannot connect to mouse at all. It does pair, but always fails to connect to z10, this has to be softwarewise in my opinion.(i dont have than sony mouse anymore -.-). Tried hard reset with volume buttons, deleting, repairing and
    Since i am gonna try and cycle leaks abd official release, what is fastest way to reload offical OS? OTA or through link?
    10-02-13 08:27 AM
  4. lord_hibiskus's Avatar
    Update: Conclussion i think it is missing driver in OS for some BT devices.
    I downgraded to official 10.1.273 i think, and mouse somehow bugged z10, cause constantly it was replying with: only 2 BT controling devices you may start, and i didnt have any. So i downloaded latest leak, and with it also isnt working. You can imagine my shock when sucessfully paired mouse with my wifes 50euro android....
    Go go power BB rangers.....
    10-02-13 12:50 PM
  5. FF22's Avatar
    I have not tried to link my HP mouse with the z10 as it is already paired with my two playbooks.
    10-02-13 04:39 PM
  6. FF22's Avatar
    Well, tonight I wanted to watch a video that was on my Z10 but did not want to run over to it to control start/pause. So I finally paired my HP mouse. It worked well with the video app. BUT when I opened the settings to connect to my BB Music Gateway to listen through my system, I would NOT CLOSE the Settings app (screen) nor Minimize it. I could select other settings options but not close it - it remained full screen. I got up and did it manually. My video just ended and I tried it again - no avail. Then I opened another app - same problem. I could open it, move between its various screens but could not close or minimize. I could minimize/maximize the video and did so multiple times using the mouse. I did notice if I moved the mouse-cursor-pointer to the lower left I got a different pointer.

    Ideas anyone.
    10-19-13 12:41 AM
  7. lord_hibiskus's Avatar
    dumb question, have you tried gesture? Bt mouse support is based on OS you are running. For instance my Genius mouse runs only on 10.2.1.xxxx leaks, so neither of 10.2.0.xxxx OS's has drivers for it.
    Concerning shortcuts showing, try using them in browser cause in browser you dont need gestures with mouse, you just move mouse until shortcut shows and click, and gesture works.
    10-19-13 04:38 PM

Similar Threads

  1. Z10 Unlock code not found
    By drock3322 in forum General Carrier Discussion
    Replies: 4
    Last Post: 10-03-13, 11:09 PM
  2. ABC not working
    By So-sa in forum BlackBerry Z10
    Replies: 8
    Last Post: 10-03-13, 05:33 PM
  3. Would this work to show support for apps?
    By cheadlender in forum BlackBerry 10 Apps
    Replies: 8
    Last Post: 10-03-13, 04:24 PM
  4. Z10 "Satisfied or Not" Poll
    By cuek80 in forum BlackBerry Z10
    Replies: 33
    Last Post: 10-03-13, 08:37 AM
LINK TO POST COPIED TO CLIPBOARD