1. vishwajit1's Avatar
    My BlackBerry Z10 stl100-1 turning off randomly even if my battery is at 90%. Please someone help

    Posted via CB10
    12-16-16 09:10 AM
  2. Bayuprsr's Avatar
    Reset ur z10 mybe
    12-16-16 09:18 AM
  3. vishwajit1's Avatar
    Any other options


    Posted via CB10
    12-16-16 10:19 AM
  4. shorski's Avatar
    That's battery calibration problem. It's been a long while I saw anyone complained about it.

    Solution is
    1. Let the device go off by itself.
    2. Remove the battery
    3. Plug the device to a socket
    4. Put in the battery while the device is plugged into the socket and let it charge to 100%

    This is not a permanent solution but it will let you enjoy your device a little.
    However, don't ever let it go down below 40% before you charge it else you be calibrating it again.
    12-16-16 10:44 AM
  5. vishwajit1's Avatar
    Thanks man. Will try and hopefully it will work.
    Last edited by vishwajit1; 12-16-16 at 11:52 AM.
    12-16-16 11:05 AM
  6. snehal_kendre's Avatar
    That's The only thing that works. Still it gives issues time to time. So keep calibration

    Z10 white Knight
    12-16-16 07:57 PM
  7. Vijay Sankar's Avatar
    Am having bbz10 Verizon 4g lte...but I don't get a 4 g network...what can I do?

    Posted via CB10
    12-17-16 12:56 AM
  8. shorski's Avatar
    Am having bbz10 Verizon 4g lte...but I don't get a 4 g network...what can I do?

    Posted via CB10
    Z10 STL100-1 is not 4G or 4G LTE compatible.

    Z30_10.3.3.2163(somewhere in Hogwats)
    12-17-16 01:00 AM
  9. vishwajit1's Avatar
    It worked man.. thnx

    Posted via CB10
    12-19-16 12:42 PM
  10. ppeters914's Avatar
    Am having bbz10 Verizon 4g lte...but I don't get a 4 g network...what can I do?

    Posted via CB10
    Welcome to CrackBerry!

    If you have a Z10 from Verizon, then I doubt it's an STL100-1. Regardless, please start a new thread instead of hijacking this one.

    Posted via CB10 / AT&T /Z10 STL100-3 /10.3.2.2813
    12-19-16 03:20 PM
  11. vishwajit1's Avatar
    Hey same problem again
    as you said keep celebrating and doing this for a while now... is there any permanent fix to this?


    Posted via CB10
    01-01-17 08:30 AM
  12. snehal_kendre's Avatar
    Hey same problem again
    as you said keep celebrating and doing this for a while now... is there any permanent fix to this?


    Posted via CB10
    No permanent fix

    Posted via CB10
    01-09-17 03:50 AM

Similar Threads

  1. Blackberry Link backup files storage location?
    By Smokeaire in forum Ask a Question
    Replies: 3
    Last Post: 12-16-16, 01:39 PM
  2. blackberry PRIV is fallen into save mode. How to leave the save mode?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-16-16, 10:04 AM
  3. Blackberry z10 Is it 4g Available?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-16-16, 07:58 AM
  4. Why can't I transfer SMS with blackberry content transfer?
    By sunny95arora in forum General BlackBerry News, Discussion & Rumors
    Replies: 3
    Last Post: 12-16-16, 12:04 AM
  5. How do you scan with Blackberry Priv
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-15-16, 11:00 PM
LINK TO POST COPIED TO CLIPBOARD