1. CarloMB's Avatar
    I bought my z10 two years ago here in the Philippines. I did not buy it under any telco but I am currently using Globe Telecom here. Last night, it went off because of low battery. I was not able to immediately charge it because I was out and I forgot to carry my powerbank with me. When I got home, I plugged it to the wall socket but to my surprise, it's not charging anymore. What happens every time I plug it, the red LED lights up for solid 15 secs and then the blackberry logo shows up then the empty battery logo shows up and then nothing. Even if I leave for hours, nothing is happening. I tried the trick of plugging it for two hours, then removing the battery for 15 mins then plugging it again but still nothing happened. It has already been a day of not able to use my phone. Can someone help me? Thank you in advance.

    PS. I cannot buy a new battery right now because of my busy sched and don't know someone who has a z10 to borrow a battery.
    02-20-16 08:54 AM
  2. conite's Avatar
    It seems like you've tried the right tricks already. My guess is your battery is done.
    02-20-16 09:25 AM
  3. Rustybronco's Avatar

    PS. I cannot buy a new battery right now because of my busy sched and don't know someone who has a z10 to borrow a battery.
    Probably best at this time to buy a new phone then. Hope your schedule isn't so busy to do that instead.



    Posted from my X00 Z30
    02-20-16 12:33 PM
  4. Johnny Dollar's Avatar
    I would go the new battery route for sure.

    From my Tower of Power Q5
    02-21-16 06:13 AM
  5. HarveyIanM's Avatar
    Try to charge it without the battery and when the green light turns on, put back the battery.

    Z10 STL100-1 10.3.2.2474
    02-21-16 06:38 AM
  6. CarloMB's Avatar
    Thanks for your replies! I have charged it using a different charger (a samsung charger) and it started up. I am hoping for the best right now but I think I'll still buy a new battery when I'm free. )
    02-21-16 07:01 AM
  7. JAGUARBREAKER's Avatar
    I had the same problem and it will only charge with genuine chargers.

    Posted via CB10
    02-21-16 09:38 AM
  8. CarloMB's Avatar
    I had the same problem and it will only charge with genuine chargers.

    Posted via CB10
    I tried charging mine again using the charger that came with it but it really didn't work for me. Well I have to conclude that I may have suffered from a broken charger but I still have to look into it this week. I will still see if it's just a charger problem (hopefully) or a hardware or a battery problem. Anyway, thanks to all your replies! Have a great day!
    02-21-16 09:44 AM

Similar Threads

  1. How can I delete BlackBerry ID?
    By emel vi es in forum Ask a Question
    Replies: 5
    Last Post: 02-28-19, 04:31 PM
  2. EE BlackBerry unlock problem, what are my options?
    By CrackBerry Question in forum BlackBerry Priv
    Replies: 11
    Last Post: 02-25-16, 03:13 AM
  3. Latest BlackBerry update
    By vickvilles in forum BlackBerry Classic
    Replies: 19
    Last Post: 02-21-16, 09:54 PM
  4. Another hit to BlackBerry
    By robertillo in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 02-20-16, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD