1. niks_5in's Avatar
    Has anyone noticed that the z10 is lagging a lot or I am doing something wrong. I re installed the firmware noticed the z10 is lagging a lot even through scrolling menus or even calling someone.

    Pls let me know if u guys r having similar issues

    Posted via CB10
    09-06-13 12:58 PM
  2. qbnkelt's Avatar
    None at all.

    No lag, no freezing, no jerkiness.

    I'd check the apps you've got loaded. Perhaps uninstall them and add them again once at a time.
    09-06-13 01:11 PM
  3. grover5's Avatar
    No lag at all for me either. I don't know that I've ever had a phone that didn't have any lag but that has been my experience so far. I agree with removing the apps and adding them back. You could also do a security wipe and start over. I'm using the 10.2.0.1047 leaked OS for what it's worth. I recommend it.
    09-06-13 01:17 PM
  4. Spencerdl's Avatar
    No lag here either, running smoothly since day one. Maybe just maybe you have a bad unit....it happens
    09-06-13 01:32 PM
  5. hazarder's Avatar
    Has anyone noticed that the z10 is lagging a lot or I am doing something wrong. I re installed the firmware noticed the z10 is lagging a lot even through scrolling menus or even calling someone.

    Pls let me know if u guys r having similar issues

    Posted via CB10
    Mate, I have tried getting help for this issue myself. With no avail, I have a t mobile stl-3 and it ran smoothly, until I decided to load a leak..
    Ugh, it ran good for a while but the lag started.. I've done everything mentioned above, and then some.
    I've gone back to original OS.. no hope
    Best of luck

    Posted via that z10!
    09-06-13 01:56 PM
  6. JBML007's Avatar
    Phone does not lag. Period.

    Posted via CB10
    09-06-13 01:59 PM
  7. DiscoKing426's Avatar
    The phone does seem to lag and jitter if the phone has 400mb or less of storage space left on the device.

    Posted via CB10
    Last edited by DiscoKing426; 09-07-13 at 02:02 AM.
    09-06-13 02:07 PM
  8. niks_5in's Avatar
    I have enough storage left. Even if I call a contact it will take 6 seconds and the call the number and it keels jitter a bit

    Posted via CB10
    09-06-13 02:20 PM
  9. earlym's Avatar
    What version of firmware (OS)? Did you test it and did it lag after reinstallation?
    What & how many apps did you install? Did you test for a lag after each app?
    If you haven't done so, test after reinstallation and add one app at a time and test after each. Post back.

    Go BB!
    09-06-13 05:25 PM
  10. Shifty88's Avatar
    I have my phone almost completely filled so that's a blatant lie or a problem you've caused in some other way. Zero lag since the day I got it.


    9700 > 9900 > Z10
    09-06-13 05:28 PM
  11. Z10andy's Avatar
    Mine never lags smooth as silk.

    Have u tried a security wipe?

    Z10 enough said!
    09-06-13 05:37 PM
  12. MADBRADNYC's Avatar
    Has anyone noticed that the z10 is lagging a lot or I am doing something wrong. I re installed the firmware noticed the z10 is lagging a lot even through scrolling menus or even calling someone.

    Pls let me know if u guys r having similar issues
    TBH. I've found no lag at all as far as what you're describing.
    The flow and scrolling is smooth as a baby's bottom.
    However, I've found that when opening text messages it takes a second or two to populate.
    That. Is. All.
    09-06-13 05:40 PM
  13. EauRouge's Avatar
    I know this is no help. But mine is smooth as can be!

    Posted via CB10
    09-06-13 06:27 PM
  14. talberry's Avatar
    No lagging for me too!

    Posted via CB10
    09-07-13 12:59 AM
  15. pooar's Avatar
    Urdoinitwrong

    Posted from my Z10 via CB10
    09-07-13 01:11 AM
  16. wsfahmed's Avatar
    Mine doesn't lag but sometimes in the morning taking it off the charger u notice it freezes. Have to restart.

    Also sometimes using it outdoors in real hot weather when sweat gets on the screen it lags and won't do what I want it to easily.

    Posted via CB10
    09-07-13 01:19 AM
  17. DiscoKing426's Avatar
    I have my phone almost completely filled so that's a blatant lie or a problem you've caused in some other way. Zero lag since the day I got it.


    9700 > 9900 > Z10
    Hmmm, I had 200mb of free space and phone lag/ jittered and bbm video would freeze up. Removed The Bards Tale(1.7GB) and phone worked flawless. Installed Real Racing 3 (1.2GB) and magically the phone lags/jitters and BBM video problem is back. Do explain how that would be my fault.

    Don't be calling people a blatant liar just because it doesn't happen to you. No device is perfect. Some OS issues don't happen on every device. There are many reasons why these things happen. It could be a harware issue, it could be an OS issue and could be a 3rd party applications issue.

    I'm a BlackBerry fan and personally think the Z10 is one best mobile phones on the market, but I'm not going to lie and say the Z10/BB10 is without flaws. No one device is perfect.

    Oh and I test electronics for a living.

    Posted via CB10
    m_warden1 likes this.
    09-07-13 02:00 AM
  18. hazarder's Avatar
    No good suggestions being made
    Stick to topic please!

    Posted via that z10!
    09-07-13 11:55 PM
  19. BlackBerryFanaticZ10's Avatar
    About 2 months ago I loaded the BB 10.2.1 LEAK. The phone ran great, but had some key features missing. I reloaded to 10.1 and figured I would just wait for the public release from T-Mobile. Took about 6 hours to reload, and finally, when it did, it had horrible lagginess when switching between apps and opening large apps as well. I have reloaded software about 12 times and while better, still laggy, especially on the calendar, browser, camera and contacts book. It was still under warranty so I called Wednesday and will be receiving my replacement Z10 tomorrow. Sorry to be the bearer of bad news...
    02-27-14 03:32 PM
  20. imz's Avatar
    Mine started lagging to the point of wanting to throw it in bin.

    I wrote how I fixed the lag for myself, it was by tidying out my inbox in outlook.com, I think the forever sync and thousands of emails was killing the z10.

    Everything's foldered up now, just a suggestion, might help...

    Posted via CB10
    02-27-14 04:19 PM

Similar Threads

  1. Wifi Issues on my Z10 and 1443
    By heppyX in forum BlackBerry 10 OS
    Replies: 26
    Last Post: 12-11-13, 05:16 PM
  2. what improvement from z10 to z30?
    By qcbarry25 in forum BlackBerry Z30
    Replies: 11
    Last Post: 09-10-13, 03:01 PM
  3. Which has higher value blackberry Q10 or Note 2?
    By honeyme in forum General BlackBerry News, Discussion & Rumors
    Replies: 10
    Last Post: 09-06-13, 09:42 PM
  4. Z10 order of Priority
    By ECC1 in forum BlackBerry Z10
    Replies: 5
    Last Post: 09-06-13, 03:10 PM
  5. Will a Blackberry z10 from rogers work in South Korea?
    By Stephen Chan1 in forum BlackBerry Z10
    Replies: 2
    Last Post: 09-06-13, 12:30 PM
LINK TO POST COPIED TO CLIPBOARD