1. Charmaine Abbott's Avatar
    I was security wiping my z10 when it crashed and died and I havent been able to get it on since. What can I do?
    05-07-15 04:15 AM
  2. jaydee5799's Avatar
    remove the battery and try to boot? plug into your PC and load a new OS?
    05-07-15 05:16 AM
  3. Charmaine Abbott's Avatar
    I've tried all that its not coming to life at all. Dead as a doornail
    05-07-15 08:20 AM
  4. rawkerboi 07's Avatar
    Try a different battery

    Posted via CB10
    05-07-15 08:39 AM
  5. masterscarhead1's Avatar
    I would load an autoloader with battery out
    That usually fixes things
    05-07-15 08:41 AM
  6. Charmaine Abbott's Avatar
    done that to
    05-07-15 09:10 AM
  7. Charmaine Abbott's Avatar
    where do i get an autoloader? all my searches come up at a dead end
    05-07-15 09:11 AM
  8. Madhuchandran's Avatar
    Heart felt condolences!

    Posted via CB10
    05-07-15 09:14 AM
  9. Charmaine Abbott's Avatar
    so kind of you. do you have any advice
    05-08-15 02:06 AM
  10. Chris Degroote's Avatar
    Have you tried to run sic multywipe and then loading an autoloader?

    Posted via CB10
    05-08-15 02:08 AM
  11. Chris Degroote's Avatar
    When you connect to link,shows de device up?

    Posted via CB10
    05-08-15 02:09 AM
  12. Charmaine Abbott's Avatar
    not recognizing the device at all. its dead wont come on at all
    05-08-15 02:19 AM
  13. Charmaine Abbott's Avatar
    Well it doesnt seem like there is a solution
    05-08-15 02:59 AM
  14. Jrox74's Avatar
    Hi.. How long did you let it sit with the battery removed? Had this problem once I let it sit without the battery for 90 minutes then put the battery back in connected to the wall charger & it booted back up. Not sure what else to suggest there are others here that are much better at giving solutions than I am. I have not had anymore problems since. Good Luck & I'm sure someone will assist you on getting back up & running.... Rocking 24-7 with my Z10 & 64GB PlayBook.
    05-08-15 03:09 AM
  15. Charmaine Abbott's Avatar
    I love my z10 and its been out of order for nearly a week now. tried leaving the battery out for way longer. No result. Just dead
    05-08-15 03:22 AM
  16. goodayeh's Avatar
    When you insert the battery, does the led come on ?
    If yes you can try reviving with an autoloader :

    https://drive.bitcasa.com/send/6tMMp...3dTocYhTwQn6io

    If not, phone might be a goner !
    05-10-15 08:42 AM
  17. scrannel's Avatar
    Do not give up yet. Try the link above. Are you sure your battery is A-OK? Do you have another to try?
    05-10-15 10:23 AM
  18. goodayeh's Avatar
    Yes , scrannel is correct !
    ( I assumed your battery was ok )
    05-10-15 10:29 AM

Similar Threads

  1. Blackberry Z10 flashing problem
    By khanmdsajid in forum BlackBerry Z10
    Replies: 6
    Last Post: 05-15-15, 03:45 AM
  2. Preferable cloud storage for blackberry. Why?
    By makutoni in forum BlackBerry Passport
    Replies: 11
    Last Post: 05-14-15, 05:47 PM
  3. BlackBerry Leap arrives in Vietnam May 15th through authorized BlackBerry partners
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 1
    Last Post: 05-11-15, 12:29 AM
  4. Can you adjust the Z10 calendar to show a month?
    By castoridae in forum BlackBerry Z10
    Replies: 2
    Last Post: 05-07-15, 08:06 AM
  5. Replies: 0
    Last Post: 05-07-15, 04:13 AM
LINK TO POST COPIED TO CLIPBOARD