1. ryankidd17's Avatar
    Tried everything. re-installed numerous times. The minute I open it, the logo shows up and it crashes. No idea what to do... I'm about to give up. I wanna install the new OS leak on my Z10, but if I cant connect to link and back up, there is no way I would update. sigh... if ANYONE has solved this please let me know how!
    05-01-13 10:46 PM
  2. jafobabe's Avatar
    Can you give some more info, like what OS you are running on your computer?
    05-01-13 11:13 PM
  3. igotaq's Avatar
    Tried everything. re-installed numerous times. The minute I open it, the logo shows up and it crashes. No idea what to do... I'm about to give up. I wanna install the new OS leak on my Z10, but if I cant connect to link and back up, there is no way I would update. sigh... if ANYONE has solved this please let me know how!
    Edit
    did you try deleting the folder from pc then reinstall?


    Posted via CB10
    05-01-13 11:16 PM
  4. ryankidd17's Avatar
    Can you give some more info, like what OS you are running on your computer?
    An HP Pavilion running Windows 7, Service Pack 1, 64-bit with 8GB of RAM. Intel Core i5-2430M @2.40GHz
    05-01-13 11:17 PM
  5. ryankidd17's Avatar
    Edit
    did you try deleting the folder from pc then reinstall?


    Posted via CB10
    Yup, even tried Revo, even cleared out my computer. Nothing has worked thus far
    05-01-13 11:25 PM
  6. Kah Carter's Avatar
    Format hdd and reinstall windows

    Kah
    05-02-13 12:25 AM
  7. ESCON's Avatar
    Do you have the older desktop manager on your PC?
    Try to use ccleaner After uninstall to clear the registry...
    Try to Start it without network Connection ?
    05-02-13 01:19 AM
  8. DetlevCM's Avatar
    Revo... it would actually not use that at all, it made me reinstall the OS on my laptop once...

    In terms of OS - Win7 64bit is fine, as is having the old Desktop Manager installed, so this bags the question what else is left...

    Win7 does not need reboot between software installs - BUT I suggest you do the following:
    Uninstall BlackBerry Link and then hunt down any BlackBerry Link generated folders that are specific to the the software (I.e. Check program files, check appdata).

    Remove any remaining BlackBerry Link files then reboot.
    Maybe run cc cleaner - you can use the registry cleaner on cleaner BUT read EVERY entry it throws up. If any are BlackBerry Link related, consider deleting them - log off and on for the registry changes to take effect. Now try reinstalling Link and see if it works.

    If it does not, I suspect there is a clash with something - or the OS was broken at some point, but that will be hard to track down...


    Posted via CB10
    05-02-13 01:30 AM
  9. DetlevCM's Avatar
    Do you have the older desktop manager on your PC?
    Try to use ccleaner After uninstall to clear the registry...
    Try to Start it without network Connection ?
    BlackBerry Link connects to BlackBerry for BlackBerry ID - hence it needs an Internet connection (at least initially) .

    Posted via CB10
    05-02-13 01:31 AM
  10. ryankidd17's Avatar
    Revo... it would actually not use that at all, it made me reinstall the OS on my laptop once...

    In terms of OS - Win7 64bit is fine, as is having the old Desktop Manager installed, so this bags the question what else is left...

    Win7 does not need reboot between software installs - BUT I suggest you do the following:
    Uninstall BlackBerry Link and then hunt down any BlackBerry Link generated folders that are specific to the the software (I.e. Check program files, check appdata).

    Remove any remaining BlackBerry Link files then reboot.
    Maybe run cc cleaner - you can use the registry cleaner on cleaner BUT read EVERY entry it throws up. If any are BlackBerry Link related, consider deleting them - log off and on for the registry changes to take effect. Now try reinstalling Link and see if it works.

    If it does not, I suspect there is a clash with something - or the OS was broken at some point, but that will be hard to track down...


    Posted via CB10
    About to try these suggestions. Fingers crossed
    05-02-13 01:34 AM
  11. ESCON's Avatar
    BlackBerry Link connects to BlackBerry for BlackBerry ID - hence it needs an Internet connection (at least initially) .

    Posted via CB10
    So i had the old Desktop Manager on my PC and both got problems on my system they won't run side by side. I know for many ppl it was not a Problem but on my System this was the only problem i had with Link.

    I can Let link run without network ?

    Good luck OP..
    05-02-13 01:39 AM
  12. ryankidd17's Avatar
    Revo... it would actually not use that at all, it made me reinstall the OS on my laptop once...

    In terms of OS - Win7 64bit is fine, as is having the old Desktop Manager installed, so this bags the question what else is left...

    Win7 does not need reboot between software installs - BUT I suggest you do the following:
    Uninstall BlackBerry Link and then hunt down any BlackBerry Link generated folders that are specific to the the software (I.e. Check program files, check appdata).

    Remove any remaining BlackBerry Link files then reboot.
    Maybe run cc cleaner - you can use the registry cleaner on cleaner BUT read EVERY entry it throws up. If any are BlackBerry Link related, consider deleting them - log off and on for the registry changes to take effect. Now try reinstalling Link and see if it works.

    If it does not, I suspect there is a clash with something - or the OS was broken at some point, but that will be hard to track down...


    Posted via CB10
    well... the logo lingered 3 seconds longer... I got happy... annnndddddd...crash... That's it I guess... new laptop, nothing else on this... guess I gotta buy another and try it out... this really upsets me
    05-02-13 01:56 AM
  13. DetlevCM's Avatar
    well... the logo lingered 3 seconds longer... I got happy... annnndddddd...crash... That's it I guess... new laptop, nothing else on this... guess I gotta buy another and try it out... this really upsets me
    You could try sfc /scannow to check your system files are OK.

    Also no strange network setups a la VPN I assume?

    Posted via CB10
    05-02-13 02:14 AM
  14. ESCON's Avatar
    What about Firewall? Or maybe a Firewall (filter) inside your Router ? You can try to Twitter @blackberryhelp...
    05-02-13 03:59 AM
  15. darkehawke's Avatar
    I can't help you op.
    I too want to install the leak but until I find a way that doesn't use the absolutely piece of crap that is BlackBerry link, I will wait for the official release

    Posted via CB10
    beamolite likes this.
    05-02-13 04:36 AM
  16. beamolite's Avatar
    I feel for you. BlackBerry Link really is a train wreck.

    Posted via CB10
    05-02-13 05:55 AM
  17. Bs06TL's Avatar
    I had a similar problem... kind of.

    After I backed up, link froze. I forced close it and found the next tine I started it wouldn't get pass the small icon that comes up. I ctrl alt del and closed all processes related to blackberry. There are five that i saw. I was able to start it no problem without freezing after closing processes

    Posted via CB10
    05-02-13 06:14 AM
  18. ESCON's Avatar
    05-03-13 11:17 AM
  19. ubizmo's Avatar
    Now that you have Link running, I hope you don't encounter the next giving up hope point: Link detects your Z10 but won't let you backup or restore, and only gives you a yellow caution symbol.
    05-03-13 11:37 AM
  20. dubbsix's Avatar
    Had the same problem, but with Windows 8. It turns out my Kapersky AV was getting in the way. Windows 8 comes with AV built in so I removed Kapersky and now my BB connects just fine. What are you using for AV?

    Note, Im not recommending you remove the AV, but you may have to make some modifications to allow the program to run.
    05-03-13 11:40 AM
  21. vgorous's Avatar
    BlackBerry Link.exe file was probably removed from your firewall setting. Go to windows firewall and add that back in.

    Solved a lot of issues with mine.

    Posted via CB10
    05-03-13 11:40 AM
  22. ESCON's Avatar
    Now that you have Link running, I hope you don't encounter the next giving up hope point: Link detects your Z10 but won't let you backup or restore, and only gives you a yellow caution symbol.
    i heard that some apps stopping the backup process
    05-03-13 11:41 AM
  23. vgorous's Avatar
    I'm telling you guys. It's probably the firewall.

    I had reinstalled BlackBerry Link numerous times because it would freeze and once I actually got it running, I couldn't sync anything. It would see the phone and the files in it, but I couldn't delete or add any files.

    Then I read one post saying about the firewall and had my doubts. I tried it and bam! Everything works and the internal storage even shows up in "My Computer "

    Posted via CB10
    05-03-13 11:50 AM

Similar Threads

  1. Replies: 2
    Last Post: 05-22-11, 05:15 PM
  2. Replies: 2
    Last Post: 08-15-10, 03:34 PM
  3. Replies: 9
    Last Post: 05-20-10, 09:29 PM
  4. BlackBerry Messanger Contacts have their SMS show up in BBM
    By pauldovi in forum BlackBerry Tour 9630
    Replies: 9
    Last Post: 05-20-10, 09:29 PM
  5. Replies: 144
    Last Post: 10-22-09, 02:13 PM
LINK TO POST COPIED TO CLIPBOARD