12-12-14 08:03 AM
52 123
tools
  1. jhimmel's Avatar
    Has it got anything to do with BlackBerry Link setting to On on the device?

    Via The Monster Z30
    No. Something is wrong on the PC. It's working on my laptop.

    Posted via CB10
    01-04-14 08:54 AM
  2. scrapmetal58's Avatar
    Did you check device manager on the PC? May have to manually check for a driver.

    Posted via CB10
    01-04-14 03:19 PM
  3. jhimmel's Avatar
    Tried that, Scrap. It is not able to find a driver for it.

    Posted via CB10
    01-04-14 08:25 PM
  4. scrapmetal58's Avatar
    Very weird. Sorry I can't help more. Likely have to wait until the next update. Hopefully that will fix it for you.

    Posted via CB10
    01-05-14 04:37 AM
  5. jhimmel's Avatar
    This seems to be my problem on the PC - there is a BlackBerry Device update that is showing on my computer that fails to install.

    BlackBerry Link - Cannot communicate with device-bb001.jpg

    It continuously fails to install with the following error -

    BlackBerry Link - Cannot communicate with device-bb002.jpg

    I have tried to find out why this is happening, but no luck so far. It is the only such error I have ever seen.
    01-05-14 03:34 PM
  6. scrapmetal58's Avatar
    I've never seen that before. Have you searched for the error online?

    Posted via CB10
    01-05-14 05:33 PM
  7. jhimmel's Avatar
    Yes. Found nothing helpful.

    Posted via CB10
    01-05-14 05:44 PM
  8. jhimmel's Avatar
    Performed a Refresh of my Win 8.1 PC OS. Everything it working again. Obviously something on my PC had gone bad. Thanks for all the participation here.

    Posted via CB10
    FF22 likes this.
    01-11-14 05:04 AM
  9. Supa_Fly1's Avatar
    Someone from another thread dated way back in late 2013 stated that Microsoft .Net Framework (for Windows of course) 4.0 was required.

    Well since it's May 2014 the link pointed to me 4.5 ... straight from BlackBerry's btsc (old classic)

    Article ID: KB35829

    Resolution
    Upgrade Microsoft .NET frame work to the version 4.5 or later, see link below:

    IMPORTANT: A reboot is required for those with issues.
    PS: Also check for PC encryption/virii/maleware protection software maybe blocking .. most likely its Firewall rules (Advanced Firewall also intruding).
    05-20-14 09:03 PM
  10. tg1's Avatar
    I've had this same issue for a couple of months. Have tried reinstalling BlackBerry Link a couple of times works for a couple of connections then craps out. Thanks for the tips. Will try and see if it helps.

    Posted via CB10
    05-20-14 11:32 PM
  11. crazigee's Avatar
    I think some folks have had better luck if they turn off wifi.

    They really do need to seriously improve Link. It presents them in a poor light.


    You can try using Sachesi to backup/restore.

    Firechest in appworld can backup certain info to the Cloud.
    Yup. Link definitely needs to be improved.

    Posted using my Z10 via CB10
    05-20-14 11:44 PM
  12. TdotPickup's Avatar
    I SOLVED my issue. Took 1 desktop + 2 laptops . Fixed it on a windows 8 machine.

    I WIPED the device before trying to restore. Before that, it complained after I had completed my e-mail address passwords ...
    I used the security wipe, and typed the word "blackberry" to make it wipe the device. Took about 10 minutes in my estimate. After that Blackberry Link recognized the device.

    Apparently, Blackberry Link cannot detect bloated devices, ...

    More details
    Blackberry says connected. However, it says: "Blackberry Link Cannot communicate with the device" (something like that).
    So I WIPED the Blackberry. And restarted Blackberry Link(I think) and possibly unplugged and replugged in the Blackberry.
    At first I could NOT restore, but once I signed in Blackberry ID on my device it let me restore. i.e. complete the training tutorial thing.
    05-23-14 08:26 PM
  13. hirokomo's Avatar
    my bblink for mac is **** ,cant connet device for half year,bbid error..

    Posted via CB10
    05-23-14 08:52 PM
  14. Bring It On 2's Avatar
    Performed a Refresh of my Win 8.1 PC OS. Everything it working again. Obviously something on my PC had gone bad. Thanks for all the participation here.

    Posted via CB10
    That's exactly what it took for me. No amount of reinstalling Link, drivers, etc. did it, but a refresh on windows 8.1 and now it works.

    Posted via CB10 on my Z10
    05-24-14 08:31 PM
  15. vptsff's Avatar
    I got Z30, Blackberry Link (newest version) and Windows 8.1 and it was not be able to recognized my Z30 via USB cable.
    What should I do?
    12-01-14 03:38 AM
  16. FF22's Avatar
    I got Z30, Blackberry Link (newest version) and Windows 8.1 and it was not be able to recognized my Z30 via USB cable.
    What should I do?
    Try a different usb port on computer. Reboot both devices. Are you using the official bb usb cable? UNinstall and REinstall BBlink.
    vptsff likes this.
    12-01-14 09:01 AM
  17. vptsff's Avatar
    Try a different usb port on computer. Reboot both devices. Are you using the official bb usb cable? UNinstall and REinstall BBlink.
    I tried all! Still not working!
    12-10-14 07:39 AM
  18. ferchu's Avatar
    I tried all! Still not working!
    Hi.

    Try this link:
    So first you open the device manager from Control Panel. With the device manager open, scroll down to network adapter section.
    In my case there was an additional item Blackberry #3? or something similar. Doesnt matter what the name was, the important part is it had an exclamation point on it because the driver wasnt valid. Look for any blackberry related driver with an exclamation through it.

    BlackBerry Link Not Recognizing Your Z10? Try This

    Now, double click on the exclamation marked BlackBerry Device, go to Drivers tab & click Uninstall. The Last step is very simple. Just click the Scan for hardware Changes button located to the right most of Device Manger icon set (Monitor with magnifying glass). The list gets refreshed & you should now see a BlackBerry Device #x with no exclamation mark. Once found, unplug your BlackBerry Z10 & plug it in back again. Voila! BlackBerry Link will now connect to your phone seamlessly.

    Thanks Harold
    Source: N4BB
    vptsff likes this.
    12-10-14 08:06 AM
  19. vptsff's Avatar
    There was no BlackBerry Device #x within Device Manager and that why, there was no driver with exclamation mark on my laptop!
    12-10-14 09:01 AM
  20. ferchu's Avatar
    There was no BlackBerry Device #x within Device Manager and that why, there was no driver with exclamation mark on my laptop!
    You have successfully installed the BBLINK?
    install it again and follow above
    vptsff likes this.
    12-10-14 09:50 AM
  21. vptsff's Avatar
    Installing was fine.
    But problem still remains!

    You have successfully installed the BBLINK?
    install it again and follow above
    12-11-14 03:27 AM
  22. ferchu's Avatar
    Installing was fine.
    But problem still remains!
    Try clean installing of BLEND in your PC.
    And see if PC recognize the phone.
    vptsff likes this.
    12-11-14 08:49 AM
  23. vptsff's Avatar
    I will try it now!
    Then I will post back here!
    12-12-14 02:58 AM
  24. vptsff's Avatar
    Hi,
    I just upgrade the OS to 10.3.0 and now Link and Q10 are connected via UBS port (any USB port)
    So, the problem was from OS itself, wasn't it?
    12-12-14 04:06 AM
  25. ferchu's Avatar
    Hi,
    I just upgrade the OS to 10.3.0 and now Link and Q10 are connected via UBS port (any USB port)
    So, the problem was from OS itself, wasn't it?
    Z30 is not recognized and Q10 yes?

    I have a Z10 STL1 OS 10.3.0.1418 with a windows 8.1 and BLEND.
    sometimes not recognized by USB, and then do the procedure that comment above and all just fine.
    12-12-14 05:56 AM
52 123

Similar Threads

  1. 10.2.1.1925 combined with Snap: yihaw! Spotify works 100%
    By lepelz10 in forum BlackBerry Z10
    Replies: 8
    Last Post: 01-29-14, 03:49 AM
  2. How many Android and IOS users would purchase Blackberry's Flick Keyboard for their devices
    By ToddJack in forum General BlackBerry News, Discussion & Rumors
    Replies: 33
    Last Post: 12-26-13, 06:19 PM
  3. BBM cannot connect to server
    By Anduranz30 in forum BlackBerry Z30
    Replies: 3
    Last Post: 12-25-13, 10:31 PM
  4. Compatibility (or not) with Consumer Cellular Data Plan?
    By CookieInPa in forum BlackBerry Torch Series
    Replies: 1
    Last Post: 12-25-13, 09:58 PM
  5. Can't Wipe Z30 Device loaded with 10.2.1.1055
    By berrybait in forum BlackBerry Z30
    Replies: 6
    Last Post: 12-25-13, 06:03 PM
LINK TO POST COPIED TO CLIPBOARD