1. subz-zero's Avatar
    Okay, so my Z10 gets switched off after its battery level reaches below 25% mark. Is it normal or is there a bug?

    Posted via CB10
    09-18-14 10:49 AM
  2. Blacklatino's Avatar
    Okay, so my Z10 gets switched off after its battery level reaches below 25% mark. Is it normal or is there a bug?

    Posted via CB10
    Welcome to CrackBerry. Mine drains to 0. Is your Z10 new or used?
    09-18-14 11:04 AM
  3. Abhishek Sharma18's Avatar
    Okay, so my Z10 gets switched off after its battery level reaches below 25% mark. Is it normal or is there a bug?

    Posted via CB10
    You must have the STL100-1 unit since they're the ones having battery calibration issue. Whenever you feel it's showing wrong percentage just pull out the battery and keep it out overnight. I had the same issue, mine was worse though and this fixed it for a while. Hope this is fixed soon with the 10.3.1 official update.

    Thank you.

    Posted via CB10
    09-18-14 12:13 PM
  4. subz-zero's Avatar
    You must have the STL100-1 unit since they're the ones having battery calibration issue. Whenever you feel it's showing wrong percentage just pull out the battery and keep it out overnight. I had the same issue, mine was worse though and this fixed it for a while. Hope this is fixed soon with the 10.3.1 official update.

    Thank you.

    Posted via CB10
    So it's an OS related issue?

    Posted via CB10
    09-18-14 01:35 PM

Similar Threads

  1. my phone battery drained while off
    By Legeradda in forum BlackBerry Z10
    Replies: 4
    Last Post: 09-20-14, 11:29 AM
  2. Issues with Viber update.
    By Sayid91 in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 09-19-14, 07:22 AM
  3. outlook mail not getting configured on my Z30
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-18-14, 01:01 PM
  4. Viber Contact Sync Issue on Z10STL100-1/10.3.0.1154
    By avnishsp in forum BB10 Leaked/Beta OS
    Replies: 1
    Last Post: 09-18-14, 10:09 AM
  5. Switched from Z10 to Z30 now sideloaded app wont work
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-18-14, 08:51 AM
LINK TO POST COPIED TO CLIPBOARD