1. BlackBerryEnthusiast's Avatar
    Almost every time I change out my battery, since the 10.2.1.537 update, the hand set fails to register to the network. (No BlackBerry symbol in upper right corner) why does this happen?

    Posted Via Z10
    02-10-14 07:35 AM
  2. Umass021's Avatar
    Maybe you need to reload the is. That seems very strange.

    Sent from my Nexus 10 using CB Forums mobile app
    02-10-14 09:46 AM
  3. BlackBerryEnthusiast's Avatar
    It seems more and more I "need to reload the OS ", do constant battery pulls, restarts, etc. Just to get the friggin' thing to work. I can say this however. My BlackBerry Curve 9320 worked a lot better, had to do way less battery pulls, and it registered when you selected it to do so.

    I am starting to think going back to a curve 9320 is better than having a Z10...at least you can do a back up with BlackBerry Desktop, on the fly, and not have to plug it in on the desktop computer, like my Z10.

    And that phone is only $150.00!!!

    Posted Via Z10
    02-10-14 10:06 AM
  4. CyberMan2013's Avatar
    It seems more and more I "need to reload the OS ", do constant battery pulls, restarts, etc. Just to get the friggin' thing to work. I can say this however. My BlackBerry Curve 9320 worked a lot better, had to do way less battery pulls, and it registered when you selected it to do so.

    I am starting to think going back to a curve 9320 is better than having a Z10...at least you can do a back up with BlackBerry Desktop, on the fly, and not have to plug it in on the desktop computer, like my Z10.

    And that phone is only $150.00!!!

    Posted Via Z10
    Why rant? People here are just trying to assist you. No one knows exactly the what and why of your issue. Have a little patience. The people here aren't engineers or BlackBerry Technicians. They're just regular people who would offer suggestions. You would hear people tell you to reload the OS because they might never have had any of the issues you're experiencing on their device and OS version so they might likely want to see if the problem you're having exists with a clean slate.

    As smartphones get more and more complex it seems as if we need to get smarter users. It's as if the phones are smarter than the users now.

    Did you call your network provider and report the issue?

    Posted via CB10
    02-10-14 10:16 AM
  5. BlackBerryEnthusiast's Avatar
    Yes. And doesn't help. It must be on the carrier's end or a problem with the new update. It only happens way more frequently after the update of 10.2.1.537.

    It definitely isn't the operator. I have had tons of BlackBerry phones, and this is a traditional characteristic they have, lol.

    They need to get their act together, I know that....

    Posted Via Z10
    02-10-14 11:08 AM
  6. CyberMan2013's Avatar
    Yes. And doesn't help. It must be on the carrier's end or a problem with the new update. It only happens way more frequently after the update of 10.2.1.537.

    It definitely isn't the operator. I have had tons of BlackBerry phones, and this is a traditional characteristic they have, lol.

    They need to get their act together, I know that....

    Posted Via Z10
    That's not traditional characteristic for the many BlackBerry devices that my family, friends and I have had and used in different countries on different mobile networks over the last 5 or more years.

    That could also be a SIM card or cellular signal/tower issue. Or maybe your radio file got rolled back to an older version by the carrier. Can you verify that you have the 10.2.1.1899 radio installed?

    Posted via CB10
    02-10-14 02:27 PM
  7. davepett's Avatar
    Hope you find a solution, sounds like you have a bad phone. I bought the external charger/battery bundle over Xmas and have not experienced this, then again my two Z10s have been trouble free in all respects and running even better on 10.2.1.
    02-10-14 02:49 PM
  8. CyberMan2013's Avatar
    I've seen a similar thing occur after I installed the 10.2.1.1925 leak on a Q5. At the end of the phone setup it said Installing Additional Updates. After that the phone couldn't connect to BBM and couldn't receive nor make calls. When I checked the OS version the radio version was either 10.2.0.something or 10.1.0.something. I downloaded the 10.2.1.1899 radio using Sachesi, created an autoloader, installed it and all of the issues went away. If the original poster can provide me with some more info about what he sees in the OS version screen and what model Z10 he has, I might be able to point him in the right direction so that he can try to reload his radio.

    Posted via CB10
    02-10-14 07:09 PM
  9. Richard Buckley's Avatar
    Are you shutting the device down cleanly before removing the battery? If not, then the repeated unclean shut downs may have corrupted the OS or some critical system files.

    Posted via CB10
    02-10-14 07:58 PM
  10. FunktasticLucky's Avatar
    I used to have problems where it would tell me that the sim card wasn't provisioned for the network. I sent it back to the states and he tried to activate it on his verizon account and it wouldn't activate the sim at all. Turns out the phone was defective.

    If you are actually getting connected to the carrier but it's not registering with BlackBerry services then it might just be the phone glitching. Did you happen to upgrade the phone with a leak and then do a full restore, settings included? Restoring settings from older versions has sometimes caused major problems.

    As for the reload the OS suggestions. People are trying to rule out the phone. They want to know if the phone has an issue after the reload while it has nothing installed on it. It should be a last resort though.

    Posted via CB10
    02-10-14 08:10 PM
  11. TightDebbie's Avatar
    I seen this on numerous BlackBerry phones I owned. Nothing new here. Must be a characteristic of BlackBerry, lol.

    Posted via CB10
    02-10-14 09:21 PM

Similar Threads

  1. So why doesn't the Z10 have dark mode?
    By kalphreef in forum Site and App Feedback & Help
    Replies: 10
    Last Post: 02-27-14, 03:15 AM
  2. Is IMDB App a Battery Killer?
    By Stu Evans in forum More for your BlackBerry 10 Phone!
    Replies: 4
    Last Post: 02-12-14, 08:59 AM
  3. My BlackBerry Score of the Week
    By TheQuietRioter in forum General BlackBerry News, Discussion & Rumors
    Replies: 9
    Last Post: 02-11-14, 09:56 PM
  4. I want to update my BlackBerry Z10
    By Karim Hofer in forum General BlackBerry News, Discussion & Rumors
    Replies: 10
    Last Post: 02-11-14, 07:53 AM
  5. Battery drain on "System"
    By Q10Nutter in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 02-10-14, 08:24 AM
LINK TO POST COPIED TO CLIPBOARD