1. tanmay324's Avatar
    Hi, I just put a 4G enabled sim from Airtel India in my Z10 stl1, it doesn't seem to get the 4G network. There is no 4G/LTE option in network settings and also the signal icon stays on H+/3G.
    Anyone knows what can be the reason?

    Posted via CB10
    08-10-15 07:55 AM
  2. abhijangir31's Avatar
    Might b your phone doesn't have 4G support....
    Or might b you didn't active 4G on that sim....

    Posted via CB10
    08-10-15 08:33 AM
  3. Faizan Syed's Avatar
    Hi, I just put a 4G enabled sim from Airtel India in my Z10 stl1, it doesn't seem to get the 4G network. There is no 4G/LTE option in network settings and also the signal icon stays on H+/3G.
    Anyone knows what can be the reason?

    Posted via CB10
    STL100-1 model doesn't support 4G.

    Posted via CB10
    08-10-15 09:35 AM
  4. joeldf's Avatar
    If the model number of your phone is STL100-1, then you're stuck. That model does not have LTE capability, period.

    You need at least the STL100-2. I think that one has the LTE bands used in India.

    Posted via CB10
    08-10-15 09:37 AM
  5. rawkerboi 07's Avatar
    agreed with above!
    ST100-1 doesn't support 4G
    You are stuck! Dude

    Posted via CB10
    08-10-15 10:29 AM
  6. yeo123's Avatar
    Z10/STL100-1 no support 4G. Only 2G+3G quad band HSPA+1,2,5/6,8( 850/900/1900/2100 MHz) suggest you buy a BlackBerry Passport.

     Z10/STL100-2/2339 
    08-10-15 11:19 PM
  7. thurask's Avatar
    Indian LTE is hit or miss, and most of the time it's a miss. Most of the LTE spectrum is TD-LTE, which is completely useless. Find out which FD-LTE bands are in your area, if any.

    Regardless, the STL100-1 has zero LTE bands, so that won't do much good anyway.
    08-10-15 11:22 PM
  8. kenzo_44's Avatar
    The Z10 has 4G. Mine has been running 4G since 2 years now!

    Posted via CB10
    08-10-15 11:22 PM
  9. tanmay324's Avatar
    Ohh. I didn't know that stl1 has no 4g support. Thanks for the info. Time to buy a passport I guess.

    Posted via CB10
    08-11-15 12:10 AM
  10. scrannel's Avatar
    The Z10 has 4G. Mine has been running 4G since 2 years now!

    Posted via CB10
    Then you do not have the 100-1 model.
    08-12-15 08:32 PM
  11. kenzo_44's Avatar
    Then you do not have the 100-1 model.
    I don't!

    Posted via CB10
    08-13-15 06:54 PM
  12. scrannel's Avatar
    I don't!

    Posted via CB10
    Well... OP does. Thus the issue.
    08-14-15 08:22 AM
  13. rohan b's Avatar
    Hi Tanmay! Sadly, none of the current Blackberry models support the Indian LTE band, which is band 40 (2300 Mhz).

    Hopefully the future ones do

    Posted from my  Z30 STA100-2/10.3.1.2558
    08-17-15 06:52 AM

Similar Threads

  1. Does anyone have a video on how to replace a Blackberry Leap LCD Screen?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 10-03-15, 04:07 PM
  2. BB10 vs Android on BlackBerry
    By BB_Bulldog in forum BlackBerry Z30
    Replies: 22
    Last Post: 08-11-15, 10:11 PM
  3. Replies: 2
    Last Post: 08-10-15, 12:37 PM
  4. Replies: 1
    Last Post: 08-10-15, 08:11 AM
  5. IPsec vpn on BB Passport, why can't I open office servers?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 0
    Last Post: 08-10-15, 05:50 AM
LINK TO POST COPIED TO CLIPBOARD