1. anon8908589's Avatar
    I surfed the web and BBM'd on my phone for 25 minutes. By surfing the web I mean no videos, no games, just reading on websites. By BBM'd I mean just messaging, no file transfers, video calls or voice calls.

    My Z10 had 100% battery, after 25 minutes it had 85%... Is it me or is that ridiculous!!!!
    08-06-14 06:37 AM
  2. Sergiu1337's Avatar
    The web browser is unfortunately a battery hog on bb10 .

    It depends how heavy a web site is, it can heat up your phone so much (that actually it's a good thing in winter)

    Posted via CB10
    08-06-14 07:44 AM
  3. anon1727506's Avatar
    For the Z10... no.
    08-06-14 07:48 AM
  4. menshawy's Avatar
    That's absolutely normal on Z10.............. Unfortunately
    Sean Fanelli likes this.
    08-06-14 07:50 AM
  5. Jimberry Storm's Avatar
    Use WiFi as much as possible, get an extended battery or spare. Or if you can swing it go to a Z30, no batter or heating up issues there.
    08-06-14 08:14 AM
  6. anon1727506's Avatar
    08-06-14 09:07 AM
  7. serbanescu's Avatar
    On my Z10 STL 100-1 I get a drop of approx. 30% for 2 hours of websurfing on 3G / H network, screen brightness set to minimum.
    08-06-14 09:10 AM
  8. awindsr's Avatar
    Is this a new condition you are experiencing? Or has your phone always been like that?
    Also, it seems that certain cases hold too much heat and can severely impact battery.
    Need more reference info from you.
    08-06-14 06:39 PM
  9. anon8908589's Avatar
    Is this a new condition you are experiencing? Or has your phone always been like that?
    Also, it seems that certain cases hold too much heat and can severely impact battery.
    Need more reference info from you.
    I'm using the Z10 Transform Shell case, I guess it's not really a new condition I'm experiencing but then as time goes by, it's only going to get worse and worse as the battery wears. I have a 64GB MicroSD card in it, no headless apps running, wifi's enabled when I actually use it which is all day, bluetooth's never enabled, neither is NFC and all other connections. Vibration is off, mostly on silent during the day as I'm at work, loud in the evenings and I pretty much follow all the steps that scalemaster34 provided above...
    08-07-14 05:11 AM

Similar Threads

  1. Play Video in Background?
    By Heinz Katchup in forum BlackBerry 10 OS
    Replies: 15
    Last Post: 08-09-14, 02:11 PM
  2. deleted emails in the hub reappear with folder outline icons!
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 08-08-14, 03:51 AM
  3. How much standby % do you see in a hour?
    By Quakefreak121 in forum BlackBerry Z30
    Replies: 4
    Last Post: 08-06-14, 01:14 AM
  4. Anyone using Square in BlackBerry 10?
    By tg1 in forum BlackBerry OS Apps
    Replies: 4
    Last Post: 08-05-14, 07:16 PM
  5. BB10 becoming more popular in Trinidad (Caribbean)
    By SirJes in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 08-05-14, 09:19 AM
LINK TO POST COPIED TO CLIPBOARD