1. jnas1985's Avatar
    hello, i just recently traded another gentlemen for a Verizon Wireless Black Berry Storm 2 (9550) and he had told me that he had the phone unlocked through Verizon when he first had the phone. When I got the phone from him he had said he did a security wipe on the phone so everything was back to factory default settings. I am a TMOBILE customer and I have used my sim card on a BB Storm 9530 with no problems. But now when I tried using my sim card on the BB Storm 2 it showed up invalid sim and prompted me to enter a code for the phone. I entered the code that he said he had used before and it did not work. Since then every time I reboot the phone it no longer asks me to enter the code. If anyone can offer or provide me some advice on what I should do or what needs to be done. I have called Verizon and they cannot offer me any advice that has been helpful for me. I know my tmobile sim card will work on the phone since I am currently using it in a BB Storm 2.
    07-13-10 03:08 PM
  2. dkingsf's Avatar
    Only advice I can give is buyer beware. Put the old SIM back in, then search out here for places you can buy an unlock code. usually less than $10
    07-13-10 09:46 PM
  3. komatoez#CB's Avatar
    When I unlocked my phone, there was no message either. I'm wondering, did you remember to switch to GSM?
    07-14-10 11:21 PM
  4. titusilvering's Avatar
    A little confused.

    So this new bb accepted your sim?

    if no, if the bb still asking your for a code then please don't enter wrong code anymore. don't get your bb locked up. go seek an online unlock store for advice or seek local bb phone unlocker for help.
    07-15-10 01:55 AM
  5. CarrierUnlock's Avatar
    hello, i just recently traded another gentlemen for a Verizon Wireless Black Berry Storm 2 (9550) and he had told me that he had the phone unlocked through Verizon when he first had the phone. When I got the phone from him he had said he did a security wipe on the phone so everything was back to factory default settings. I am a TMOBILE customer and I have used my sim card on a BB Storm 9530 with no problems. But now when I tried using my sim card on the BB Storm 2 it showed up invalid sim and prompted me to enter a code for the phone. I entered the code that he said he had used before and it did not work. Since then every time I reboot the phone it no longer asks me to enter the code. If anyone can offer or provide me some advice on what I should do or what needs to be done. I have called Verizon and they cannot offer me any advice that has been helpful for me. I know my tmobile sim card will work on the phone since I am currently using it in a BB Storm 2.
    It may not have been unlocked.
    07-15-10 02:09 PM
LINK TO POST COPIED TO CLIPBOARD