1. rdyoung's Avatar
    I am "trying" to unlock a vzw 9530 for someone. Got the code, I know how to enter the code, etc. When inserting a TMO sim, mobile network options and status shows tmo as the provider/network. However the phone has "insert sim" at the top of the screen along with the infamous SOS sign.

    When I enter the code, it says code error please wait. And when I insert my valid tmo sim and boot it up, it asks me if I want to unlock the sim, however when I enter the code, it doesnt seem to work.

    Any and all suggestions would be very helpful here.

    Update: Tried inserting an old inactive ATT sim, and even after rebooting it shows T-mobile as the provider. Now I am even more stumped, if thats even possible.
    Last edited by rdyoung; 06-03-10 at 08:45 PM.
    06-03-10 07:34 PM
  2. k8108's Avatar
    Did you follow these steps EXACTLY:

    1. Power on the handset (wireless option should be off)
    2. Insert any SIM card
    3. Turn off all wireless connections (Options > Manage Connections)
    4. Select Advanced Options
    5. Select SIM Card
    6. Select Menu to show keyboard
    7. Type mepd (you will not see what you are typing)
    8. A status screen will appear
    9. Type mep2. A pop-up window will appear: “Enter Network MEP Code (10 tries left)”
    10. Enter your unlock code.
    11. Press Enter, 'Code Accepted!' will be displayed
    12. Turn on data and wireless connections
    13. Device should be unlocked!

    NOTE:
    1. * After unlocking your phone, please make sure your handset is set to “GSM”.
    Go to Options > Mobile Networks > Network Mode: GSM
    2. ** Make sure all your mobile connections are on. - Options > Manage Connections > Turn on Mobile Connections

    Also, then go to Options>Advanced Options>TCP/IP
    Check the box by APN Settings Enabled
    The next line should read:
    APN: wap.voicestream.com
    Do NOT check the box for APN Authentication Enabled
    no Username
    no Password

    I have followed these directions and successfully unlocked phones 4 times to Tmobile - if this process doesn't work, please tell us step by step what you have done so we can see where the hang up is.

    **You might try a new sim card from Tmobile.
    06-04-10 12:15 AM
  3. rdyoung's Avatar
    Did you follow these steps EXACTLY:

    1. Power on the handset (wireless option should be off)
    2. Insert any SIM card
    3. Turn off all wireless connections (Options > Manage Connections)
    4. Select Advanced Options
    5. Select SIM Card
    6. Select Menu to show keyboard
    7. Type mepd (you will not see what you are typing)
    8. A status screen will appear
    9. Type mep2. A pop-up window will appear: Enter Network MEP Code (10 tries left)
    10. Enter your unlock code.
    11. Press Enter, 'Code Accepted!' will be displayed
    12. Turn on data and wireless connections
    13. Device should be unlocked!

    NOTE:
    1. * After unlocking your phone, please make sure your handset is set to GSM.
    Go to Options > Mobile Networks > Network Mode: GSM
    2. ** Make sure all your mobile connections are on. - Options > Manage Connections > Turn on Mobile Connections

    Also, then go to Options>Advanced Options>TCP/IP
    Check the box by APN Settings Enabled
    The next line should read:
    APN: wap.voicestream.com
    Do NOT check the box for APN Authentication Enabled
    no Username
    no Password

    I have followed these directions and successfully unlocked phones 4 times to Tmobile - if this process doesn't work, please tell us step by step what you have done so we can see where the hang up is.

    **You might try a new sim card from Tmobile.
    It appears that storms are just finicky. This isn't the first storm I have had issues with. After sitting powered down while I slept, I booted it up, it asked me if I wanted to unlock the sim, I entered the code and it took it.
    06-04-10 12:58 AM
  4. k8108's Avatar
    Glad you got it working.
    06-04-10 08:03 AM
  5. CellUnlock.net's Avatar
    Great! Now you just need to put your SIM card and go to Options/Mobile Network and change Network Technology to GSM/UMTS and select 2G.
    06-04-10 09:57 AM
  6. rdyoung's Avatar
    Great! Now you just need to put your SIM card and go to Options/Mobile Network and change Network Technology to GSM/UMTS and select 2G.
    Not to seem snippy at all but here goes.

    As I made sure to put in my original post, I know how to unlock, the steps to take to get running off sim instead of cdma, etc. I even went the extra mile for this guy and loaded up the tmo books and and set the apn. I did forget to reprogram it with his phone # as a just in case, DOH... But if he has an issue he will call/text me and I will walk him through it.

    I am not new to BBs. I have my own little unlock business I run on the side, however I have only unlocked about 5 storms since I started it. And they are a giant PITA thanks to that damn screen.
    06-04-10 10:38 AM
  7. CellUnlock.net's Avatar
    We usually never enter the code through the pop-up window when powering with a SIM. We always go through the Options/Advanced Options/SIM card method.

    Just so you know, there are some Software issues with some Storm/Tours when unlocking. The phone will say Code Error but will actually unlock and the way to know that is to look at the counter that will not go down.
    06-04-10 10:42 AM
LINK TO POST COPIED TO CLIPBOARD