1. R0ku's Avatar
    So I got a 9550 a friend gave to me, it's from Verizon. Brand new, I got it since he bought an iPhone and he didn't want it anymore. I purchased an unlock code, put the new sim card in, and entered the code after I rebooted the device.
    I couldn't get a signal after the code and I notice it didn't ask for it anymore so I rebooted the phone. Once it completed I could see my carrier's name in the top and a full bar of signal.

    Now there's a small problem, my connection only shows edge in lower case letters, I checked the mobile network options and set it to GSM/UTMS, it was on global. Still no luck. I tried to make a phone call and send text messages and it didn't work, funny thing is my App World notified me of a new version, and i could browse the app world catalog and everything, but if I try to use the normal web browser it would tell me it's a "WiFi only service"

    I also noticed that when I entered the phone interface and My number would show like the previous number the phone had not the one in my simcard.

    Think I should do a wipe of the phone? Anything else I should try?

    Thanks for your time.
    11-21-11 12:18 PM
  2. DoctorUnlock's Avatar
    What network are you trying to use it with?

    Also if you are using it with any network other than Verzion and you want the Blackberry features to work such as Email, BBM, PIN, etc you need to install your networks service books on the phone, you can call your network and ask them to push the service books to the phone, if it doesn't work you need to install them manually (there are many threads on crackberrys that can show you how)

    Also to change the phone number to your real phone number

    type ##000000 send

    enter your phones correct number and click save!

    Thats it


    Hope I was of help!

    Thanks,

    Mark
    11-22-11 02:14 AM
  3. freethisberrydotcom's Avatar
    Only works on Verizon devices only. SPC code for other carriers use different MSL/SPC codes for different MEID
    11-22-11 11:33 AM
  4. CarrierUnlock's Avatar
    So I got a 9550 a friend gave to me, it's from Verizon. Brand new, I got it since he bought an iPhone and he didn't want it anymore. I purchased an unlock code, put the new sim card in, and entered the code after I rebooted the device.
    I couldn't get a signal after the code and I notice it didn't ask for it anymore so I rebooted the phone. Once it completed I could see my carrier's name in the top and a full bar of signal.

    Now there's a small problem, my connection only shows edge in lower case letters, I checked the mobile network options and set it to GSM/UTMS, it was on global. Still no luck. I tried to make a phone call and send text messages and it didn't work, funny thing is my App World notified me of a new version, and i could browse the app world catalog and everything, but if I try to use the normal web browser it would tell me it's a "WiFi only service"

    I also noticed that when I entered the phone interface and My number would show like the previous number the phone had not the one in my simcard.

    Think I should do a wipe of the phone? Anything else I should try?

    Thanks for your time.
    Need to make sure you have the necessary service books as well.
    11-24-11 05:18 PM
LINK TO POST COPIED TO CLIPBOARD