1. cmpy23's Avatar
    First off I have searched the forums for about an hour now and have found lots of threads but they all just seem to end with no answer if it got fixed or if they just lived with it or bought an iPhone.

    I have a Bold 9700 the was from Telus Canada and I bought an unlock code from cellunlock.net in hopes to use it on the Orange UK network. I have the BIS service form orange and it works, I have confirmed this on my other blackberry phones, an Orange 8520, Unlocked 9520, and an Unbranded 9700. This is not my first unlock experience either as I have unlocked the o2 9520 and used it on this account no problem.

    My problem is this, after unlocking my phone I can not receive BBM messages. I can send them, they show as delivered and I have talked to a friend and he is in fact getting them however he can not respond. My internet works fine and my email works fine. I am getting capital letter GPRS on the home screen which I believe confirms my BIS plan.

    I have tried deleting the service books and then registering under the HRT clicking on the entry in bold which I believe means it is the active one and gotten the confirmation message. This also replaces the service books and I have batt pulled after this. I have even tried updating the os, I tried the latest official, the latest leak and the latest from orange itself, all to no avail.

    If anyone has an answer that would be great but I am also willing to follow blindly any tips or wild goose chases you may want to send me at this point.
    05-08-10 02:51 PM
  2. CarrierUnlock's Avatar
    It is a network issue. Your not really getting a stable BIS connection. If you were you would get EDGE not GPRS.
    05-08-10 07:58 PM
  3. cmpy23's Avatar
    It is a network issue. Your not really getting a stable BIS connection. If you were you would get EDGE not GPRS.
    I have never had an EDGE connection on Orange with any of my blackberry phones so I do not think that is the issue. I am using the same sim and account in different one as I type and sending and receiving BBMs fine.
    05-08-10 08:43 PM
  4. CarrierUnlock's Avatar
    What does it say when you type MEPD under SIM Card in Advanced Options?

    Posted from my CrackBerry at wapforums.crackberry.com
    05-08-10 08:45 PM
  5. cmpy23's Avatar
    What does it say when you type MEPD under SIM Card in Advanced Options?

    Posted from my CrackBerry at wapforums.crackberry.com
    That shows

    SIM Disabled
    NETWORK Disabled
    NETWORK SUBSET Disabled
    SERVICE PROVIDER Disabled
    CORPORATE Disabled
    05-08-10 09:10 PM
  6. CarrierUnlock's Avatar
    Sounds like a phone issue.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-08-10 09:12 PM
  7. cmpy23's Avatar
    Sounds like a phone issue.

    Posted from my CrackBerry at wapforums.crackberry.com
    It worked fine when I was in Canada, thanks for your help though.
    05-08-10 09:31 PM
  8. cmpy23's Avatar
    Well I solved my own problem, I went out today and bought a new orange pay as you go sim and called them up asked them to activate the 5 pound a month BIS service and once they did that everything works fine. I made absolutely no changes other than the sim card and it works perfect. I have no idea why it did not work with my other active account so other than having a new number now I am happy. Hopefully this may end up helping some.
    05-12-10 08:05 PM
LINK TO POST COPIED TO CLIPBOARD