1. dzabroni's Avatar
    sorry in advance for the length

    i just purchased the 8320 curve while in the states...for the record, im a newbie when it comes to bb, though im not that dense with technologies and cellphones in general but bear with me please

    the curve was originally locked to t mobile i believe, i left it untouched while still in the states, but when i inserted my fido simcard (in Canada no longer roaming) i could not connect to BIS (for the record i do have the necessary plan now and I have contacted my carrier to double and triple check this). furthermore in the set up wizard email can only be set up through BES not BIS (im not sure if this is normal or not)

    I have only two service books on the phone (wi-fi and browser), i have registered it with fido.blackberry.com, clicked "Send Service Books" even receive a success message, but nothing on my phone. data is turned on, the firewall is disabled, i have also attempted to go through registering at the host routing table, a receive a "registration message sent!" but nothing happens afterwards. ive tried a few different combinations with the TCP/APN, also to no avail (most of this fido customer service told me to do)

    all i know is im supposed to get it to say "EDGE" not "edge" in the top right corner (and i have no idea how to do this at this point) is this maybe a problem with the phone itself or is it the carrier? has it not been unlocked properly?

    thanks in advance for any ideas you may have

    ps i have tried pulling the battery

    EDIT: under services status > voice services it states that i am roaming, its a fido simcard im on the fido network...
    10-06-09 12:40 AM
  2. dzabroni's Avatar
    bump

    please help
    10-06-09 02:53 PM
  3. CarrierUnlock's Avatar
    Your title states unlocked, but not once have you mentioned actually unlocking it this may be your issue.
    10-12-09 10:22 AM
LINK TO POST COPIED TO CLIPBOARD