1. gilbertp23's Avatar
    Crackberry Nation, I need your help.
    I just received a Bold that was previously locked to AT&T and I am trying to use it on Rogers.

    Issue: When connected to 3G, I cannot make or receive phone calls. Every other feature of the phone works as per expectations.

    Message on Screen:
    Call failed due to SIM Toolkit control error. Please try again later.
    SIM: Call barred.

    Facts:
    - Everything, including phone calls, works under EDGE
    - Tried several SIM cards at the Rogers store, but they only worked as well as mine.
    - Rogers rep confirmed I have a 3G sim card, and it was a 4000 series (or something)
    - I've read tons of threads on several sites (including this one) about this. I also read the one about the Israel Orange which had a resolution. It doesn't seem an OS update works, for some people changing the SIM worked, but i've tried this.

    Any advice would help, Thanks
    08-06-09 11:03 AM
  2. mandony's Avatar
    Try to downgrading the OS to original 167 and determine if the problem still exists
    08-06-09 01:16 PM
  3. Klotar's Avatar
    If he downgrades to .167, he will lose the 3G/2G option and will probably lose what limited function he has now.

    Also, .282 is an official Rogers release.

    I would first confirm that it is indeed unlocked (options, advanced options, sim card, and then type mepd), just to be sure. However, since the phone works on EDGE, that may accomplish nothing.

    Everything suggests a bad BATCH of sim cards that won't work with the Bold. I emphasise batch, because trying several at the same store may be misleading. I would try a different Rogers store next.
    08-06-09 02:03 PM
  4. gilbertp23's Avatar
    Thanks for the tips so far, i'll try going to another Rogers and see, I hope your right.
    And yes, i've heard that the original OS from .167 doesnt have 2G support. But also all threads i've read say changing the OS doesn't fix this issue.

    I'll post again with further results and more testing.
    08-06-09 02:25 PM
  5. berrydeck's Avatar
    Having the same issue. Can't call out, but can receive calls. All worked yesterday on Edge.

    Its a Bold. Was AT&T on rogers.

    Anyway to force it to use edge until I can sort it out?? I can't even call rogers to figure this out!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-07-09 05:13 PM
  6. ninja1989's Avatar
    I believe the only solution can be done by RIM with new firmware. Because the same SIM card works very well with other 3G cell phones like Panasonic, Samsung, LG, Sharp, etc.

    By the way, I am in Japan. Japan doesn't use GSM for 2G. I love my unlocked BB9000, however, with SoftBank 3G SIM Card, I can only receive calls and SMS text, but can't make a call or send any SMS message. The BB9000 shows such kind of error message: sim toolkit control error. Is there any one who can push RIM to solve this problem ? There are so many BB lovers which have been suffering such kind of things for so long time, why RIM can't release the solution ?
    08-21-09 11:01 AM
  7. krown's Avatar
    My wife has the same issue with her phone. From searching the Net, I have learned that only the old Rogers 3040 sim card will work with an AT&T Bold. The new 4000 sim card will not work. I'm picking one up today and will let you know if it works or not.
    08-28-09 01:44 PM
  8. BBadicto's Avatar
    My wife has the same issue with her phone. From searching the Net, I have learned that only the old Rogers 3040 sim card will work with an AT&T Bold. The new 4000 sim card will not work. I'm picking one up today and will let you know if it works or not.

    Did the 3040 sim card work for you? What do you mean by 3040 and 4000? I dont see such numbers on my sim cards...please I would really appreciate the help. Thank you!
    09-21-09 02:29 AM
  9. krown's Avatar
    Yes, it ended up working. The sim card has 5 rows of numbers printed on it. The middle set of numbers will read either 3040 (older) or 4000 (current). You need an older 3040 sim card for it to work. You can try craigslist or ebay to fins them.
    09-29-09 01:14 PM
  10. shoesRnotFood's Avatar
    I have had the same problem for a few months now and have *not* debranded. I'm using a Pay-per-use sim card and not debranding, but forcing 2G/edge. To get into the engineering screens, you need to get a passcode... google it and you may find it, but it is getting harder to do this now (it was removed from this site). My real preference is to go 3G but when I went to Rogers to get a newer SIM card, it didn't work.

    The problem with accessing the engineering screens is that the bold jumps back to 3G if turning on/off WIFI or powering up/down.. and the passcode to get to the engineering screens is max. 30 days. Pain in the **** to constantly do this, and I would really like to not de-brand and use a off-the-shelf newer SIM card.

    Any advice appreciated.
    12-31-09 02:31 PM
LINK TO POST COPIED TO CLIPBOARD