1. therieldj's Avatar
    hi i got a storm2 unlocked for tmobile. my issue is sometimes (atleast 9 out of 10 calls) get dropped. i noticed its about after 30 secs into the call the phone usually tells me call failed. sometimes i end the call(because you cant hear the other person EVEN THOUGH IT SAYS CONNECTED) before it displays any message. this never happened with my storm 1 but i had to use tmo service books and such as outlined in http://forums.crackberry.com/f135/ho...m-95xx-106023/ . but i havent been able to find such a guide for the storm2. basically i bought the phone for a non contract price and cell unlock from this forum helped me unlock it. no other steps were taken. the phone is awesome and I LOVE IT WAAAAAAAAAAAY MORE THAN MY STORM 1, but i cant stand these dropped calls.

    p.s- idk if it makes a diff but i see the two directional arrow (data) in the corner of the screen (never noticed them on the storm) during the call before it says call failed. also after it shows call failed i notice the edge on the corner of my screen changes to grps
    Last edited by therieldj; 12-07-09 at 08:15 PM.
    12-07-09 08:05 PM
  2. mpallo's Avatar
    hi i got a storm2 unlocked for tmobile. my issue is sometimes (atleast 9 out of 10 calls) get dropped. i noticed its about after 30 secs into the call the phone usually tells me call failed. sometimes i end the call(because you cant hear the other person EVEN THOUGH IT SAYS CONNECTED) before it displays any message. this never happened with my storm 1 but i had to use tmo service books and such as outlined in http://forums.crackberry.com/f135/ho...m-95xx-106023/ . but i havent been able to find such a guide for the storm2. basically i bought the phone for a non contract price and cell unlock from this forum helped me unlock it. no other steps were taken. the phone is awesome and I LOVE IT WAAAAAAAAAAAY MORE THAN MY STORM 1, but i cant stand these dropped calls.

    p.s- idk if it makes a diff but i see the two directional arrow (data) in the corner of the screen (never noticed them on the storm) during the call before it says call failed. also after it shows call failed i notice the edge on the corner of my screen changes to grps
    Yes..I had the same problem and had to revert to the 9700. I did like the phone but could not handle the edge issues and dropped calls. Same thing as you. About 30-90 seconds into the call, it would go 'call failed'

    For the most part it would stay on EDGE, but it was riding way too much on edge for my liking for data.
    12-07-09 08:33 PM
  3. therieldj's Avatar
    bump i reinstalled the service books from the above post last night... see how good it is today. any other tips? thanks in advanced pppl
    12-09-09 01:47 PM
  4. TheLastOf's Avatar
    I'm going to go out on a limb and say the problems you are encountering have to do with the coverage in your area. I have an Unlocked Storm2 on T-Mobile, and I've yet to drop a single call, I've had this device unlocked for about two weeks now. The only time I've ever seen GRPS or grps for that matter is after traveling outside of prominent coverage areas.

    Outside of that, I've always had a steady EDGE connection, and the only time my phone goes to edge for a few moments is after resetting the device or turning off the Mobile Network.
    12-09-09 03:55 PM
  5. mpallo's Avatar
    I'm going to go out on a limb and say the problems you are encountering have to do with the coverage in your area. I have an Unlocked Storm2 on T-Mobile, and I've yet to drop a single call, I've had this device unlocked for about two weeks now. The only time I've ever seen GRPS or grps for that matter is after traveling outside of prominent coverage areas.

    Outside of that, I've always had a steady EDGE connection, and the only time my phone goes to edge for a few moments is after resetting the device or turning off the Mobile Network.
    The dropped calls are some combo of the phone and network. Zero dropped calls with my 8320 and 9700 with same SIM card.

    Are you running any 3rd party apps? Twitterberry, Ubertwitter, Berry Weather, BBAlerts, ScoreMobile?
    12-09-09 04:00 PM
  6. mo0620's Avatar
    i was going to post about this yesterday. I have the same exact issue as you do. I'm currently running a hybrid, i'm thinking it might be because of that, but I'm to lazy to revert back to the stock software. Also, like you it's constantly on GPRS. My service is in northwest Indiana, near chicago.
    12-09-09 04:17 PM
  7. mo0620's Avatar
    i'm trying to go back to .320 to see if this will solve the issue
    12-12-09 06:09 PM
  8. cat5shotta's Avatar
    I had the issue when i first unlocked my phone, but it went away. But my friend's phone has the problem and it still persists.(both storm2's unlocked, His running .320, mine running a hybrid.) Not sure what causes this problem. Dont think it is the OS though.
    The service provider is Digicel and it is in the cayman islands.
    12-12-09 11:01 PM
  9. Attiqmalik's Avatar
    Have you tried OS .428? The problem is greatly reduced though not fully.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-23-09 01:14 PM
  10. CarrierUnlock's Avatar
    It's basically cause its T-Mobile LOL
    12-23-09 04:48 PM
  11. Carnag3's Avatar
    Try a different radio code.
    12-23-09 06:03 PM
  12. pixelitis's Avatar
    hey everyone --have read just about every-single-post regarding this issue.

    my situation: have been waiting anxiously for the release of the storm2. a local vendor was finally selling the "unlocked" verizon version of the phone. picked one up and was able to switch out the mode to GSM and it appeared like everything was normal with messenger working, email, etc. but wasn't able to keep phone calls for longer than 20-30 seconds at a time.

    i was literally freaking out because this vendor does not process refunds or exchanges.

    here's how i fixed it. try it out --it just might work for you:

    1. launch "Manage Connections"
    2. switch-out the "Network Selection Mode" to Manual
    3. press the "Scan for Available Networks"
    4. with your current GSM provider's SIM card it should find your provider and just beneath the "Scan for Available Networks" button you should see a list labeled "Available Networks"
    5. press your provider's name in the list. a menu should pop-up - press "Select Network".

    your GSM provider's information should all be listed directly across the name. including its network type, 2G, etc. i'm not too keen on the specifics of WHY this actually worked for me but if you haven't already given it a try..you might want to see if it'll work. since then, i've rebooted the phone several times and did a battery pull and the storm2 is still keeping its call connections.

    hope this helps
    12-24-09 05:31 AM
LINK TO POST COPIED TO CLIPBOARD