1. hnjngo's Avatar
    I'm on Wind mobile, and im leaving town next week so i will not be in a wind zone therefore will have to pay for data, txting, and calls, so im going to get a prepaid from rogers with some data and txting.

    I have called Wind and they have provided an unlock code, and i used that with the instructions on iunlockblackberry.com

    So here's my problem, my bb9900 should work on both Telus, and Rogers but i've tried several times with both companies and it always fails to find there network, when i try to manually scan for networks it still says "wind home".

    When i go back to advanced system settings > Sim and type mepd i see:


    When i type mep2 nothing happens.

    Did Wind screw me? Do i need to do something else when i put in a new sim? Can a third party Unlocking service help me?

    Ive call Rogers, Wind, and Rim they have all told me there is nothing they can do, and to call the other companies. Im not sure what to do next.

    Thanks in advance
    03-12-12 03:14 PM
  2. Branta's Avatar
    You need to test with a SIM from a different provider. The phone will ALWAYS select the SIM's home network if it is available, and it is highly unlikely that WIND has a roaming agreement with other in-country networks which compete in the same geographical area so your Wind SIM would be barred on other Canadian networks. You should find it will work just fine when you use a different SIM, and will automatically use the new SIM's home network if it is available.
    03-12-12 08:15 PM
  3. freethisberrydotcom's Avatar
    your wind device will only work on 2G on rogers .. will not work at all on Telus or Bell
    03-12-12 09:56 PM
  4. hnjngo's Avatar
    You need to test with a SIM from a different provider. The phone will ALWAYS select the SIM's home network if it is available, and it is highly unlikely that WIND has a roaming agreement with other in-country networks which compete in the same geographical area so your Wind SIM would be barred on other Canadian networks. You should find it will work just fine when you use a different SIM, and will automatically use the new SIM's home network if it is available.
    Ive Tried Sims on both Rogers and Telus, both times it fails to connect to any network. When i manually scan for a network for some reason it scans for "Wind home" network.
    03-12-12 11:16 PM
  5. hnjngo's Avatar
    your wind device will only work on 2G on rogers .. will not work at all on Telus or Bell
    Why wont it work on Rogers 3g, doesnt it support Rogers 3g frequencies? Ive gone to the Telus website and did their "compatible device check" punched in my imei, and it said that my device would work... they lied?
    03-12-12 11:18 PM
  6. hnjngo's Avatar
    So i fixed the problem, i had to manually scan for the network under both 2g and 3g, when scaning it picks up Wind 3g, Rogers 2g, and Mobilcity 2g, weird. When you connect to the rogers 2g, then it will find the edge network. Automatic doesn't work.

    Just thought id share in case someone else has this problem, is this not common?
    03-14-12 05:12 PM
  7. freethisberrydotcom's Avatar
    will only work on 2g.. switch it to 2g in mobile network options,.
    03-14-12 07:52 PM
LINK TO POST COPIED TO CLIPBOARD