1. 2low4snow's Avatar
    The phone has a full T-mobile signal, just can't make an outgoing call...it calls a number and then disconnect's right away.

    Has anyone encountered this??

    Also, does someone have a link to the service books to get the browser and MMS working again??

    THanks in advance for any help as I am a total novice here.
    Last edited by 2low4snow; 10-08-09 at 08:33 PM.
    10-08-09 08:28 PM
  2. john1210's Avatar
    yea its a known problem and others correct me if I am wrong but there isn't a fix yet
    10-08-09 10:04 PM
  3. CarrierUnlock's Avatar
    Have you switched it to 2G?
    10-12-09 11:20 AM
  4. jonjonjon's Avatar
    yes i think a have the same problem i jus unlock my blackberry tour to use for tmobile and i cnt make any calls allit says that no circuit channel available please help any one know whats wrong with this please help thanks
    10-12-09 12:41 PM
  5. CarrierUnlock's Avatar
    As stated before please switch it to 2G, T-mobile doesn't run a 3G network frequency band that the Tour does.
    10-12-09 12:43 PM
  6. fresnogamer's Avatar
    Please...does anybody have a answer...?
    10-13-09 03:05 AM
  7. CarrierUnlock's Avatar
    Everyone still hasn't stated if they switched it from UMTS/3G to 2G.
    10-13-09 11:04 AM
  8. Carnag3's Avatar
    PM me with your email. I'll help you out. I'll see what I can do for you.
    10-13-09 03:47 PM
  9. mldzaj's Avatar
    it is switched to 2G and it still says the same thing i have the same problem too "/
    10-17-09 03:20 PM
  10. CarrierUnlock's Avatar
    Did you reboot after this?
    10-17-09 03:25 PM
  11. pltaylor's Avatar
    What os are you using?
    10-17-09 03:30 PM
  12. mldzaj's Avatar
    how do you reboot?
    10-17-09 03:35 PM
  13. CarrierUnlock's Avatar
    Pull out the battery and put it back in.
    10-17-09 03:36 PM
  14. mldzaj's Avatar
    i've done it several times
    10-17-09 03:44 PM
  15. CarrierUnlock's Avatar
    Then you will need to contact T-Mobile to push out your service books.
    10-17-09 03:50 PM
  16. pltaylor's Avatar
    im using v4.7.1.40


    Then you will need to contact T-Mobile to push out your service books.
    Service books have nothing to do with it. It's the .40 OS
    10-17-09 03:55 PM
  17. CarrierUnlock's Avatar
    That could work as well. Don't forget to delete the vendor.xml file for it to load.
    10-17-09 04:00 PM
  18. effe_86's Avatar
    As stated before please switch it to 2G, T-mobile doesn't run a 3G network frequency band that the Tour does.
    its not that simple
    10-28-09 02:29 AM
  19. porto35's Avatar
    Carrier Unlock has no idea what he is talking about.
    10-30-09 11:57 PM
  20. CarrierUnlock's Avatar
    And you do? There e always many simple steps to try before going into more advanced steps that are a we bit confusng if you are a novice user.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-31-09 12:04 AM
  21. porto35's Avatar
    I don't know either,if you do then show me the fix for this problem, my friend
    11-02-09 02:06 AM
LINK TO POST COPIED TO CLIPBOARD